• Wenn Ihr hier einen Thread erstellt, dann erwartet Euch im Beitragformular eine Vorlage mit notwendigen Grundinformationen, durch die Euch die Community schneller helfen kann. Mehr Informationen dazu findet ihr in diesem Thread.

Kaufberatung: Heim-Server / NAS


Interessant finde ich, dass die Seite auch 2400MHz RAM listet, wo doch Supermicro selbst nur 2133MHz RAM als kompatibel listet.
Dieser Crucial 2133MHz RAM sieht kompatibel aus, aber ich hatte den verworfen, da er als EUDIMM-Formfaktor beschrieben wird, während das Board UDIMM will. Vielleicht bin ich da zu pingelig, aber das war mein Grund einen anderen zu nehmen.
 
Zuletzt bearbeitet:

Kaufberatungsbot

Werbung
Teammitglied
Günstiger Spiele-PC für ca. 640 Euro: PCGH-Beispiel
Im Internet wird vermutet, dass EUDIMM bei Crucial für ECC UDIMM steht. In der Bezeichnung des Moduls steht ja auch eindeutig UDIMM.
 
Hey Shadow, schau mal auf der Supermicro-Seite rechts im Menü unter "Testd Memory List". Dort wird auch der 2400er ECC Speicher aufgeführt. Diese Info fehlt anscheinend einfach auf der Hauptseite.

Habe mal ein paar Anfragen zur Lieferzeit an einige Händler geschickt. Mal sehen, was dabei rauskommt. Ich halte es nicht mehr lange aus. ;-)

Gruß Hoppel
 
Moinsen,

habe gerade nochmal über RAID bzw. ZFS nachgedacht. Ich bin mir nun sicher, dass es ZFS werden soll. Und wenn ZFS, dann auch gleich ein RAID-Z2-Pool.

Wenn ich das aber mit den 8TB-WD-Red-Platten mal durchrechne, wird mir das doch etwas zu teuer.

Da ich nun mehrfach gelesen habe, dass man den Pool bestenfalls direkt so aufbaut, wie man ihn irgendwann mal haben möchte und nicht im Nachgang um 2 Platten (2 Platten, um die Parität zu erhalten) erweitert, müsste ich wie folgt einkaufen:

A.) 4x8TB-(2x8TB für Parität)=16TB

Das Verhältnis passt nicht, diese Variante scheidet aus.

B.) 6x8TB-(2x8TB für Parität)=32TB

WOW, werde ich so viel Speicher wirklich in den nächsten 5 Jahren belegen können? Die "WD Red 8TB" kostet derzeitig pro Stück ca. 350€, macht dann für alle 6 HDDs 2.100€.

Wenn ich mir das ganze dann mal mit der 6TB-WD-Red-Platte durchrechne, sieht das wie folgt aus:

C.) 8x6TB-(2x6TB für Parity)=36TB

Die WD Red 6TB kostet derzeitig ca. 250€ pro Stück. Variante C bringt also 4TB mehr Speicher als Variante B und würde mich insgesamt sogar noch 100€ weniger kosten. Ok, ich hätte 2Platten mehr im Gehäuse, die zusätzlichen Strom kosten. Den Platz habe ich im Gehäuse. Nun hätte ich aber immer noch viel zu viel Speicher.

D.) 6x6TB-(2x6TB für Parity)=24TB

Wenn ich mir also Variante D anschaue, habe ich 6 Platten a 6TB, die mich insgesamt 1.500€ kosten. Derzeitig habe ich 8TB an Daten. Ich hätte also weitere 16TB Spielraum. Ja, ich weiß, wenn der Speicher komplett voll ist, kann ich auch nicht mehr löschen. ;-)

Hinzu kommt, dass sich die WD Red 6TB Platte am Markt mittlerweile schon etabliert hat, während die 8TB-Platte noch nicht mal erworben werden kann. Evtl. gibt's da anfangs noch Kinderkrankheiten. Mal abgesehen davon, dass im Fehlerfall die Wiederherstellung der Daten aus der Parität bei 8TB-Platten noch länger dauert, als bei 6TB-Platten.

Später könnte man natürlich so nach und nach jede 6TB-Platte gegen 8TB- oder XXTB-Platten austauschen und den Pool auf diese Weise vergrößern.

Bei allen 3 Varianten (B, C, D) komme ich dann entsprechend der ZFS-Faustregel mit 32GB RAM nicht mehr aus. Ich müsste, also auf 64GB gehen. AUA! [emoji33][emoji6]

Grundsätzlich tendiere ich nun zu Variante D. Andererseits befinden wir uns bereits im Zeitalter von 4K-Bildqualität, so dass man evtl. bald noch mehr Speicher benötigt. Müsste ich mich zwischen B und C entscheiden, müsste es rein logisch betrachtet Variante C werden.

Wie seht ihr das?

Spricht etwas dagegen den Pool im Nachgang um zusätzliche Platten zu erweitern?

Dann könnte ich evtl. zunächst auf Variante D (6x6TB) gehen. Wenn ich dann mehr Speicher benötige, habe ich die Wahl zwischen:

- entweder Variante C (8x6TB), indem ich den Pool um 2 HDDs erweitere
- oder Variante B (6x8TB), indem ich direkt alle 6 Platten gegen größere 8TB-Modelle austausche

Wenn ich dann immer noch mehr Speicher benötige, könnte ich noch 2x8TB ergänzen. Wobei dann fehlt mir entsprechend der ZFS-Faustregel der RAM für das OS. Verhältnis 64TB zu 64GB RAM (max. mögliche RAM-Größe des Mainboards). Naja, da wird wohl noch ein Bisschen Speicher für das OS übrig bleiben und nicht komplett in Beschlag genommen. [emoji1]

Ich nehme also eine weitere Erkenntnis mit. 10TB-Platten und größer sind für mein Vorhaben mit diesem Mainboard nicht mehr wirklich geeignet, da ich dann relativ schnell an die max. RAM-Speichergröße stoße. Der einzige Vorteil könnte sein, weniger Platten im Chassis zu haben. Ob das ein Vorteil ist, darüber lässt sich streiten. [emoji6]

Gruß Hoppel
 
Zuletzt bearbeitet:
Hey Shadow, schau mal auf der Supermicro-Seite rechts im Menü unter "Testd Memory List". Dort wird auch der 2400er ECC Speicher aufgeführt. Diese Info fehlt anscheinend einfach auf der Hauptseite.

Ich vermute da eines: Da überall nur von 2133Mhz Ram die Rede ist (Handbuch, Homepage,...) denke ich, dass der 2400-er Ram zwar Kompatibel ist, aber nur mit 2133Mhz betrieben wird.

6 Platten ist bei Z2 Preis-Leistungstechnisch das Optimum. Du bekommst die gute Redundanz von 2 Platten und 100% netto Kapazität für 50% Aufpreis. Und ja, ZFS vergrößert deine Arrays NICHT. du kannst Platten hinzufügen, aber unter großem Risiko deine Daten zu verlieren (etwa wie eine RAID0). Was du aber tun kannst, ist alle bestehenden Platten durch Größere zu ersetzen.
Ich schreibe heut Abend mehr dazu.

Edit:
Du kannst dir das so vorstellen:
Du legst 6 physische Festplatten ein und machst daraus ein RAID-Z2 Verbund -> Eine virtuelle Festplatte die unter der Haube mit den Raid-spezifikationen/Redundanzen arbeitet.
Wenn du jetzt 3 neue Platten (zb RAID-Z1) einlegst, dann kann ZFS diese nicht der ersten virtuellen Festplatte hinzufügen, sondern macht eine zweite und bindet beide über RAID-0 zusammen.
Du hast jetzt gemäß Z2 und Z1 auf den virtuellen Platten redundanz, aber sobald eine der virtuellen Platten abschmiert (zb die Z1 verliert 2 Platten), verlierst du den ganzen Pool. RAID-0 eben.

Ich weiß nicht, wie deine Anforderungen sind - 8 TB sind schon ne Menge und offensichtlich erwartest du großen Wachstum. In diesem Fall könnte es sich lohnen mehr kleine Platten einzusetzen. Da du das fertige Array (ohne Datenverlust) nur vergrößern kannst, indem du kleine Platten durch größere Platten einwechselst, würde ich nicht gleich am oberen Ende anfangen (8 TB Platten). Nimm zb 8x4 TB oder 8x6 TB. Du kannst am Ende immer noch auf 8x8 TB upgraden. Wenn du mit 6x6 TB anfängst, ginge nur noch 6x8 TB. (Oder Enterprise 10 TB)
 
Zuletzt bearbeitet:
Wahrscheinlich sollte ich wirklich 8x4TB (=24TB netto) in die nähere Betrachtung miteinbeziehen. Später, wenn sich der freie Speicher dem Ende neigt, gehe ich dann auf 8x8TB (=48TB netto). Das wäre dann nochmal eine Verdopplung und ich hätte durch den Austausch der HDDs gegen frische HDDs wieder eine neue Lebenszeit von 3-5 Jahren.

Wenn ich direkt auf 8x8Tb gehen würde, würden mir die Platten wahrscheinlich, weit bevor ich den Speicher annähernd voll habe, abrauchen. Mit 24TB netto sollte ich die nächsten 3-5Jahre auskommen. In der Konstellation 8x4TB liege ich mit WD Red bei knappen 1.300€.

Das werde ich mir auf jeden Fall nochmal durch den Kopf gehen lassen.

Hoffentlich ist das Mainboard bald lieferbar.

Danke für diesen Ideenaustausch.
 
Zuletzt bearbeitet:
Hey Leute,

ich habe mittlerweile das gesamte Equipment bestellt. Man kann es kaum glauben, das Mainboard habe ich bereits erhalten. Es war kurzzeitig genau die Menge 1 im Lager des Händlers "klarsicht-it.de" verfügbar. Nachdem ich sofort zugegriffen habe, traf es tatsächlich schon einen Tag später bei mir ein.

Festplatten-technisch habe ich mich nun für 8x4TB (WD Red) entschieden. Was den Prozessor betrifft, habe ich mich nochmal umentschieden. Es ist nun die Stromsparvariante E3-1240Lv5 geworden. Auch wenn die CPU etwas weniger kräftig ist, sollte sie für meine Zwecke ausreichen.

Bisher habe ich lediglich das Mainboard und 3 HDDs zu Hause. Insgesamt kaufe ich alles bei 3 verschiedenen Händlern. Einerseits war es mir wichtig, nach Möglichkeit die HDDs aus unterschiedlichen Produktionsreihen zu bekommen (mal sehen sehen ob das klappt) und andererseits gibt es keinen Händler der wirklich alles, was ich haben wollte, im Portfolio hat.

Ich melde mich sobald es weiter geht.

Gruß Hoppel
 
Ich habe mich für 6x4TB RED (non pro) entschieden. Das sollte für meine Zwecke reichen.
Mein Gehäuse packt 10x 3,5Zoll Platten (2x4 + 2x1), darum hab ich mir gedacht 6 Arbeitsplatten + 2 Hotspares (vielleicht gleich 8TB Platten) sitzen zu lassen. Damit sollten die Daten lokal in diesem Gerät super solide sicher sein. Dazu kommt logischer Weise externes Backup.
So hab ich noch 2x HDDs für andere Sachen. Ich hab mir zB überlegt die ein oder andere Überwachungskammera auf zu stellen und mit RAID1 Purples zu betreiben.
Übrig bleiben 2x 2,5 Zoll (SSD) slots, die ich für Jails in FreeNAS bereit halte und OS-Backup, auch RAID1. Ich hoffe, ein vollwertiges Debian o.ä in eine Jail zu bekommen, damit ich so die Flexibilität behalte. Ich konnte schon MythTV (TV-Software) zum laufen bekommen, also ... mal sehn.

Übrigens hab ich heute Morgen bei Sona.de rein geschaut, und sie sagen, dass sie das Mainboard lagernd haben!!! :D :D :D
Ich rechne mit der Lieferung kommende Woche, dann werden Kabel geraucht was das Zeug hält!
Dass du dein Board schon hast ... mir steht der Neid ins Gesicht geschrieben. Gratuliere!
 
Übrigens hab ich heute Morgen bei Sona.de rein geschaut, und sie sagen, dass sie das Mainboard lagernd haben!!! :D :D :D
Ich rechne mit der Lieferung kommende Woche, dann werden Kabel geraucht was das Zeug hält!
Dass du dein Board schon hast ... mir steht der Neid ins Gesicht geschrieben. Gratuliere!

Ich drück dir die Daumen, dass du deins auch schnell bekommst. Ich wäre an deiner Stelle auch neidisch! :D Mein Problem ist, dass ich das Mainboard habe, aber alles andere noch fehlt. ;)
 
Mein Problem ist, dass ich das Mainboard habe, aber alles andere noch fehlt. ;)

Dann sind Hopfen und Malz doch noch nicht verloren ;-)
Ich hab heute noch etwas im Handbuch geschmökert. Ich bin einfach begeistert von dem Funktionsumfang in dem Board! Wie schön die vielen Komponenten ineinander greifen, da freut man sich über den Griff nach einem Server-Board. Du musst wissen, als ich es gefunden und bestellt hatte, war von einem Handbuch weit und breit nichts zu sehen. Ich hatte auf gut Glück nach der Spezifikations-Seite entschieden - und meistens haben so tolle Dinge irgendwo einen Haken.

Sag mal, hast du vor eine M.2 SSD zu nutzen? Bzw ist auf dem Board wirklich nur Platz für eine 2260? Denn ich habe ein großes Auge auf die "Samsung 950 Pro" geworfen, aber die ist eine 2280.
Ein so schnelles Laufwerk wäre gut um meine Transfers - sobald ich ganz auf Linux umgesprungen bin - über NFS als synchron laufen zu lassen. (FreeNAS kann die langsamen aber sicheren synchronen Transfers beschleunigen mit einem eigens dafür bereitgestelltem Laufwerk, besonders wenn dieses für sich sehr schnell ist)
 
Dann sind Hopfen und Malz doch noch nicht verloren ;-)
Ich hab heute noch etwas im Handbuch geschmökert. Ich bin einfach begeistert von dem Funktionsumfang in dem Board! Wie schön die vielen Komponenten ineinander greifen, da freut man sich über den Griff nach einem Server-Board. Du musst wissen, als ich es gefunden und bestellt hatte, war von einem Handbuch weit und breit nichts zu sehen. Ich hatte auf gut Glück nach der Spezifikations-Seite entschieden - und meistens haben so tolle Dinge irgendwo einen Haken.

Ja, ich bin auch hin und weg! :D

Sag mal, hast du vor eine M.2 SSD zu nutzen? Bzw ist auf dem Board wirklich nur Platz für eine 2260? Denn ich habe ein großes Auge auf die "Samsung 950 Pro" geworfen, aber die ist eine 2280.
Ein so schnelles Laufwerk wäre gut um meine Transfers - sobald ich ganz auf Linux umgesprungen bin - über NFS als synchron laufen zu lassen. (FreeNAS kann die langsamen aber sicheren synchronen Transfers beschleunigen mit einem eigens dafür bereitgestelltem Laufwerk, besonders wenn dieses für sich sehr schnell ist)

Damit habe ich mich nicht befasst. Als Systemplatte wird eine einzelne SSD herhalten. Evtl. werde ich das später mal in ein Raid 1 wandeln, derzeitig sehe ich irgendwie keinen Bedarf dafür.

Wo nun auch die SAS-Kabel da sind, ist mir (gerade noch rechtzeitig vor Ostern) aufgefallen, dass die von dir zuvor in diesem Thread benannten Kabel nicht passen:

LSI CBL-SFF887OCF-5M MultiLane SATA/SAS-Kabel: Amazon.de: Computer & Zubehor

Ich habe mal ein Foto vom Stecker des Kabels (mini-SAS) und vom Anschluss am Mainboard (mini-SAS HD) gemacht:

IMG_1749.JPG

Ich habe nun folgendes Modell bestellt, da im Handbuch von "mini-SAS HD" die Rede ist:

mini-SAS HD.PNG

LSI LOGIC LSI41 CBL-SFF8643-SATASB-6M ,6m Mini-SAS: Amazon.de: Computer & Zubehor

Falls du diese Kabel also tatsächlich bestellt hast, wirst du nochmal andere bestellen müssen. Ich hoffe, dass das denn nun die richtigen sind.

Gruß Hoppel
 
Zuletzt bearbeitet:
Mein Board ist endlich angekommen und ich hab gestern gleich das gute Stück zusammen gebaut :D
Alles ging ganz gut von der Hand und ist auch direkt gestartet. Soweit bin ich mal zufrieden mit dem Ergebniss. Das einzig kleinere "Problem" (abgesehen vom nicht passenden SAS) war, dass ein einzelner Lüfter seltsame Drehzahlen hatte. Er war 2 Sekunden lang schnell, 2 Sekunden nachher langsam, 2 Sekunden nacher wieder schnell etc. In einem anderen Lüfterslot blieb er konstant schnell/laut. Gelöst habe ich das mit einem Low-Noise Adapter (war beim Noctua Lüfter dabei). Jetzt läuft die Maschine ruhig und leise im Memtest86 bis ich wieder von der Arbeit komme.

Danke für den Hinweis, hoppel! Ich hab mir direkt Ersatz bestellt. Der sollte bis morgen auch da sein.
Wer hätte gedacht, dass SAS nicht gleich SAS ist :-/

Das einzige was mir noch Kopfzerbrechen bereitet ist das IPMI. Ich wollte mich direkt einloggen, kam auch über Browser an die Log-In Seite, aber ich kann auf die Schnelle kein Passwort finden. Warscheinlich steht es im Handbuch, aber das muss jetzt bis heute Abend warten.
 
Hallo Shadow,

welcher Lüfteranschluss war das genau? Dann teste ich diesen Anschluss bei mir auch nochmal. Evtl. handelt es sich ja um ein generelles Problem.

Bei mir laufen derzeitig Error Tests für jede einzelne der 8x 4TB-HDDs in meinem Desktop Rechner mit HD Tune. Jeder Test nimmt ca. 9 Std. in Anspruch. Die 6. HDD habe ich gerade eingeschoben, bisher gab es keine Fehler. Für die Installation möchte ich gern auf der sicheren Seite sein, dass alle Platten in Ordnung sind.

Memtest86, guter Hinweis. Das hatte ich gar nicht auf dem Schirm. Da ich mich nun doch für 64GB RAM entschieden habe, weil ich mit ZFS und 8x 4TB die 32GB nahezu ausschöpfen würde, macht es umso mehr Sinn, auch den RAM nochmal zu testen. Da die Platten in ein paar Jahren potentiell gegen 8TB-Modelle ausgetauscht werden sollen, benötige ich dann sowieso die 64GB RAM. Und wer weiß, ob dieses RAM-Modul (gleicher Hersteller und gleiches Modell) dann noch verfügbar ist.

Ich drücke dir die Daumen, dass alles glatt läuft.

EDIT: Achja, die mini-SATA-HD-Kabel sind angekommen. Die passen! :D

Gruß Hoppel
 
Der Vollständigkeit wegen, der Benutzername und Passwort für das IPMI lauten "ADMIN"

Zu dem Lüfter: Diese, die ich in FAN 1+2 sowie FAN 3+4 (die zwei doppel-Anschlüsse) angesteckt habe sind problemlos gelaufen. Den letzten hatte ich in FAN 5, als er sprunghaft die rpm wechselte. Dann habe ich ihn zu FAN A (Handbuch - am Board war es glaub ich als FAN 4 angeschrieben) gesteckt und er blieb konstant schnell.
Wie gesagt, ein Noise-Adapter löste bei mir das Problem.

Gut, dass die SAS-Kabel passen, dann kann ich meine Laufwerke auch bald anschließen. Hardwaretechnisch wäre ich dann fertig mit dem Server :) (vorerst)
Softwaretechnisch prügle ich mich gerade etwas mit dem Bootlaufwerk. IPMI läuft wunderbar, aber das OS ist zickig wie ein Mädel *gg* Ich boote zwar von der .iso, aber irgendwie scheint der Server das nicht mounten zu können. Auch den vorinstallierten USB-Stick spuckt er wieder aus.
Toll am IPMI finde ich bisher, dass man Laufwerke virtuell einbinden kann. So brauche ich den Server wirklich nur als Rohbau ins Eck zu stellen und kann alles Software-technische vom Notebook aus machen - auch booten!
Also ne Lösung wird sich finden, das ist Tag 01 und dafür läuft es besser als ich gehoft habe :D

Edit: Soweit ich rausgefunden habe, liegt das Problem an der Hardware. Kein Defekt - sondern kein Support seitens FreeNAS. D:
Ich werde morgen weiter rechercieren, aber so wie's aussieht ist Linux die Wahl der Dinge. Also OMV+ZoL
 
Zuletzt bearbeitet:
Heute ist das richtige SAS-Kabel angekommen. Ich konnte alles anstecken und jetzt funktioniert soweit alles.

Ich habe mir auch die OMV 3.0.2 Beta geladen und installiert, allerdings ist der Netzwerk-Treiber etwas Banane. Auch wenn ich den Treiber aus der mir gezeigten Liste nehme (hier: ixgbe = Intel 10 GBit Ethernet) will er das Gerät nicht haben - folglich auch keine Internetverbindung und keine Pakete - folglich auch kein Web-GUI, nur Konsole. So gerne ich die Konsole auch mag, mir ist das eeetwas zu barebone. Ich bin kein Arch-Typ
Ich lade mal die Treiber-ISO von Supermicro und probiere es morgen mit der aus. U.A sollten Linux-Treiber dabei sein. Intel bietet sie zwar auch an, aber die kann ich so (*.tar.gz) nicht über IPMI einbinden.
 
So, ich bin jetzt wahrscheinlich an dem gleichen Punkt wie du. Oder hast du es mittlerweile hinbekommen? Mit dem Backport Kernel funktionieren die Netzwerkkarten auf jeden Fall. Habe mir gerade mal eine aktuelle Knoppix CD gezogen und getestet. Aber wie kriegt man den Kernel installiert ohne Netzwerk?

Bin am Überlegen mir irgendeine andere Linux-kompatible Netzwerkkarten zu ordern, den Backport Kernel zu installieren und die Karte wieder rauszunehmen.

Wie hast du omv installiert bekommen ohne Netzwerktreiber? Bei mir geht's dann einfach nicht weiter.

Gute Nacht! ;)
 
Die Installation kannst du abschließen, indem du, indem du einfach sagst "keinen Ethernet Anschluss" (1. Option, wenn er dir die Treiberliste gibt)
Ich habe gehofft mit einem puren Debian Jessie Install den Treiber reib zu bekommen (Hab jetzt nur Debian ohne OMV auf dem Server).

Ich hab inzwischen das hier gemacht:

- Den Backport-Kernel 4.3.0 heruntergeladen (Download - AMD64)

- Zusätzlich initramfs-tools 0.120 heruntergeladen (Download - AMD64)
(Note: Beide Links kommen von hier: Debian -- List of sections in "jessie-backports")

- Beides auf einen USB-Stick kopiert

- USB im Server eingesteckt (langsam wirds peinlich genau)

- cd zum Stick (/media/USER/STICK/...), dann:
dpkg -i init[TAB] lin[TAB] [ENTER]

- reboot

Jetzt hab ich eine Internetverbindung und Debian aktualisiert (apt-get update + upgrade). Jetzt ist OMV dran - Mal sehn ob das "proof of concept" das ich gefunden habe taugt :D
Howto install OpenMediaVault on Debain 8.x Jessie EXPERIMENTAL)
 
Zuletzt bearbeitet:
Zurück