[HOW TO] "Nvidia Grafikkarte flashen" mittels USB-Stick (NVFlash) / Update Nibitor G200 Voltmod

Ratty0815

Freizeitschrauber(in)
Nach ein paar Tagen ist mir doch echt aufgefalen das ich nur den das erste Bios meiner GTX295 geflasht habe.

Und da evtl. mehrere Leute SLI bzw. Dual-GPU Karten mit mehr als einer PCB nutzten sollte man evtl. das Tut erweitern, wie man auf die zweite PCB flasht.

Durch die suche von Tante-Google habe ich das hier gefunden & hat super geklappt.

und sorry für Doppelpost, war mir nur nicht sicher ob "ändern" die Aufmerksamkeit bringt die dieses Thema eigentlich verdient.

So Long...
 

DaRkNeZRaVer

PC-Selbstbauer(in)
Also um jeweils eine Karte nach der anderen zu Flashen muss man nurnoch -i0 oder -i1 nach dem nvflash.exe einfügen. Sry wenn es hier schon irgendwo steht.
Beispiel:
"C:\nvflash.exe -i0 -4 -5 -6 88SLI.rom"
und ich glaube man kann die auch gleich kombinieren wenn beide Karten vom gleichen Hersteller sind.
Ich habe zum Beispiel eine Karte von Asus und eine von Leadtek. Dort geht das gleichzeitige Flashen nicht, weil das Vendor dings nicht übereinstimmt.

Beide gleichzeitig:
"C:\nvflash.exe -i0 -i1 -4 -5 -6 88SLI.rom"
 
K

kmf

Guest
Also um jeweils eine Karte nach der anderen zu Flashen muss man nurnoch -i0 oder -i1 nach dem nvflash.exe einfügen. Sry wenn es hier schon irgendwo steht.
Beispiel:
"C:\nvflash.exe -i0 -4 -5 -6 88SLI.rom"
und ich glaube man kann die auch gleich kombinieren wenn beide Karten vom gleichen Hersteller sind.
Ich habe zum Beispiel eine Karte von Asus und eine von Leadtek. Dort geht das gleichzeitige Flashen nicht, weil das Vendor dings nicht übereinstimmt.

Beide gleichzeitig:
"C:\nvflash.exe -i0 -i1 -4 -5 -6 88SLI.rom"
Das stimmt nur bedingt. Wenn der 200er SLi-Chip auf dem Board verbaut ist, hat der generell die Geräte-Nr. 0 - um im flash-Jargon zu bleiben -i0.

Dann hat die 1. Karte -i1 und die 2. -i2.

Der Parameter -3 erzwingt das Schreiben des Biosfile, egal ob Vendor stimmt oder nicht.
 
Zuletzt bearbeitet von einem Moderator:

Ollieee

Kabelverknoter(in)
Mahlzeit...
Nach ewigen suchen ubd googln bin ich zum Glück auf dein HOW-TO gestoßen. Es ist absulut leicht zu verstehen und umzusetzen.:hail:
Hab jetzt nur noch ein kleines Problem. Ich gehe genau nach deiner Beschreibung vor, habe das Backup gemacht und jedes Mal nachdem ich folgendes eingeb:
nvflash.exe xxx.rom bzw. mit -5-6 (flashen möchte ich eine 8800GTS mit dem Bios einer 8800GTSXXX), bringt er mir den Fehler
"Error: Board ID mismatch" :huh:

Achso, wäre es auch möglich das Bios einer 8800GTX drauf zu machen?

Kann mir bitte irgenjemand helfen bevor all meine Harre ausgefallen sind...

Danke im Voraus.

Mfg
 
Zuletzt bearbeitet:

chiller93

Freizeitschrauber(in)
Das mit dem 8800GTX Bios würde ich lieber lassen, da diese ja mehr Shadereinheiten besitzt, deshalb dürfte das Bios eig nicht kompatibel sein.

Aber wieso liest du nicht einfach dein eigenes Bios aus und flasht auf XXX Taktraten? bzw wieso flashst du überhaupt (garantieverlust ;))?

Lg Danny :D

Edit: 8800GTS 512 oder 640/320MB?
 

Ollieee

Kabelverknoter(in)
Wegen Garantieverlust muß ich mir da kein Kopf machen. Hab die mir im Jahr 2006 zugelegt.:D Hab die Graka hier rumliegen und nehm die so bissl zum Testen. Sie hat Grafikfehler und deswegen hab ich gedacht eh ich sie wegwerf kann ich es auch mal mit flashen versuchen. Na das mit dem Bios auf ne GTX lass ich dann mal. Muss sie ja nich mutwillig abschiesen.
Mit Nibitor brau ich bei mir auch nichts versuchen auszulesen, hab n 64 bit BS.;)
Aber selbst wenn ich sie auf Standard flashen will bekomm ich immer wieder den Fehler

"Error Board ID mismatch"

Wenn das wenigstens irgendwie ma funzen würde.:(

Aso, is ne 640MB. Gab es glaub auch nur als XXX Variante...

Mfg
 

chiller93

Freizeitschrauber(in)
Dann lies dein Bios mit GPU-Z aus ;) das geht auch, siehe SC im Anhang ;)
Dann nur noch die .bin datei in eine .rom Datei umbennen und schon kannst die mit Nibitor öffnen und bearbeiten und flashen.

Lg
 

Ollieee

Kabelverknoter(in)
Aalsooo...
Danke erstma für die schnelle Antwort, hab jetzt alles so weit geschafft. Jetzt kann ich sicher sein, dass die Graka wirklich im Eimer is.:(
Hab von paar verschiedenen 8800GTS (mal mehr mal weniger Takt) s Bios drauf gemacht. Gefunzt hat es bei mir mit der Eingabe
"nvflash.exe -4-5-6 new.rom"
und dann halt immer mit "z" bestätigen...
Das mit Nibitor und s Bios mit GPU-Z auslesen war ne gute Idee, nur sträubt sich Nibitor absolut gegen ein 64 Bit BS und ging somit garnich.:huh:
Im Großen und Ganzen hab ich ja das was ich wollte.

Also Thx & Lg
 

chiller93

Freizeitschrauber(in)
Komisch, weil bei mir läuft Nibitor ohne Probleme.

Versuch einfach folgendes.:

1. Mit Gpu-Z das Bios auslesen.
2. Unter ordneroptionen -> Ansicht-> Haken bei "Erweiterungen bei bekannten Dateitypen ausblenden" entfernen.
3. Bei der gesicherten .bin Datei das .bin durch .rom ersetzten und
4. In Nibitor open file oder so und dann öffnen ;)

Klappt normalerweise ohne Probleme :D

Lg
 

ich558

Volt-Modder(in)
Schönes HowTo!

Ich habe eine gtx260 black edition welche leider einen kaputten OCP hat. Kann man diese trotzdem flashen wenn man dann die Spannung anpasst?
 
D

DAEF13

Guest
Hallo, es ist zwar schon etwas länger her, das hier etwas geschrieben wurde, aber ich denke mal, der Thread ist immer noch aktuell.

Da ich eine GTX260 im Non-Referenzdesign habe, und der Lüfter ab 20% im Idle schon etwas stört wollte ich die Drehzahl auf 15% herabsetzen, was bis zum 195er Treiber immer wunderbar mittels des MSI Afterburners geklappt hat. Ab dem 196er Treiber kann ich die Drehzahl aber nur auf minimal 30% herabsetzen, und das ist mir zu laut.

Bei 15% Drehzahl wird die Karte im Idle kaum über 40°C warm, also möchte ich es wieder so haben.
Anscheinend führt nun kein Weg an einem BIOS-Flash vorbei, also habe ich ersteinmal mein BIOS gesichert und mir NiBiTor 5.6 runtergeladen.
Ich habe die Lüftersteuerung schon angepasst und auch die Taktraten etwas erhöht/gesenkt.
Jedoch bin ich nun etwas unsicher, als ich bei den "Bootup clocks" angelangt bin.
Hier werden unglaublich hohe Taktraten angezeigt, und ich glaube nicht, das die richtig sind, deshalb habe ich hier mal ein Bild angehangen.
Ich habe daran nichts verändert und so scheint es im Original BIOS zu stehen.

Ich hoffe mal, ihr könnt mir helfen:)
Danke im Vorraus!
 

Freakezoit

PCGHX-HWbot-Member (m/w)
Bootup Clocks - Mal auf autoselect gedrückt ?? (anzeige ist normal wenn man das nicht gemacht hat.)
Zweitens würde ich die finger davon lassen zumindest bei den Bootup clocks.
Ein Fehler und du kannst die nur noch Blind oder mit ner anderen Karte flashen.;)
 
D

DAEF13

Guest
Ich werd' mal gucken, was bei Autoselect passiert.
Aber wie bring' ich dem Teil bei, dass es die normalen 3D Takte nehmen soll? EInfach eingeben? Und welche Timings muss ich dann auswählen?!

S*****! Wenn ich auf Autoselect klicke kommt "Cant start Driver: 1275"
Das gleiche passiert auch, wenn ich in NiBiTor auf "Read BIOS" klicke, aber dass soll unter 64bit (laut diesem How-To) wohl normal sein...
 

-_Elvis_-

PCGHX-HWbot-Member (m/w)

Lord Wotan

Freizeitschrauber(in)
Wenn du was tust? Hast du zufällig ein 64bit OS und hast über NiBiTor versucht den Treiber zu laden?
Nee ich habe hier eine neue Firmware geladen unter
http://www.techpowerup.com/vgabios/60926/Palit.GTX260.896.090922.html

Da es Bin Daten sind (und nvflash dann sagt es geht nur mit Rom Dateien) habe ich die mit NibiTor v 5.7 unter Windows 7 pro 64bit geöffnet. Und anschließend ohne was zu ändern als Rom Datei gespeichert.

Dann habe ich mit einen USB Stick gebootet um mit nvflash ein Firmware Update zumachen.

(Noch ein Hinweiß ich habe in diesen PC eine Palt 260GTX und eine Sparkle 240GT.)

So wenn ich besagtes update machen will mit diesen befehl:
c:\nvflash p090922.rom

kommt besagte Fehlermeldung
I/O Error: Cannot open File:p09022.rom
 
Zuletzt bearbeitet:
D

DAEF13

Guest
Lad' dir GPU-Z und speichere damit dein BIOS.
Benennedie .bin zu einer .rom um und zieh sie in das NiBiTor Fenster;)
 

Lord Wotan

Freizeitschrauber(in)
Hat sich erledigt. Ich habe die Datei noch mal heruntergeladen. Und gleich als Rom Datei gespeichert. Dann ging es.
 
Zuletzt bearbeitet:
Oben Unten