• Hallo Gast, du kaufst gerne günstig ein und erfährst oft vor deinen Freunden von interessanten Angeboten? Dann kannst du dein Talent als Schnäppchenjäger jetzt zu Geld machen und anderen PCGH-Lesern beim Sparen helfen! Schau einfach mal rein - beim Test der Community Deals!

Micro-stottern bei meiner RX480

sputnik1969

Komplett-PC-Käufer(in)
Ich habe seit geraumer Zeit eine RX480, aber habe damit aber lange quasi gar nicht gespielt, und wenn dann eher Spiele, bei denen die FPS keinerlei bedeutung hat.
Als ich letztens GTA V rausgekramt habe und spielen wollte, fiel mir auf, dass es trotz hohen Frameraten ständig stottert. Dabei ist es vollkommen egal, ob VSync an- oder abgestellt ist, es ist egal welche Auflösung läuft und wie groß die Details sind. Selbst das Umschalten zwischen Framelimiter an oder aus ändert nichts.
Das lief damals auf meiner Radeon 7950 Boost deutlich flüssiger.
Das Phänomen tritt auch bei allen anderen Spielen auf, die ich getestet habe, kann also nicht an GTA liegen. Selbst Uralt-Spiele ruckeln so vor sich hin.

Am restlichen System kann es nicht liegen, damals mit der 7950 passierte das auch nicht.
Ich habe mal den Furmark laufen lassen und mit dem Afterburner Hardwaremonitor alles aufgezeichnet. Und NEIN, am Afterburner liegt es auch nicht, den hatte ich früher bereits und für die Tests sogar zeitweise deinstalliert, das Stottern blieb. Die Temperaturen bleiben innerhalb normaler Grenzen (kommen nie über 90° C), der Grafikspeicher ist nicht überfüllt und meine CPU sollte auch reichen (i7 3770k, maßvoll OC, ging sonst auch immer, sollte also auch nicht der Grund sein).
OS ist Win 10 Prof. 64 Bit
CPU i7 3770k
RAM 12 GB DDR3
GPU XFX RX480
neuester AMD Treiber ist drauf, das war das erste was ich versucht habe.
frametime.jpg

Ich hoffe jemand kann mir helfen, das Problem zu lösen. So ist Spielen echt eine Qual
 

SnaxeX

BIOS-Overclocker(in)
Deine Frametims sind miserabel, die springen hin und her - genauso wie deine GPU Auslastung, da passt wirklich was nicht.

Welchen Treiber hast du installiert?
Sauber mit DDU neu installiert?
Wie viel RAM hast du verbaut?
 
TE
sputnik1969

sputnik1969

Komplett-PC-Käufer(in)
Der Treiber ist der aktuelle 17.12.1, sauber neu aufgespielt, den alten natürlich vorher vollständig entfernt. Die RX480 hat 8 GB, das System selbst 12 GB. Die GPU-Auslastung sinkt jedes mal wenn die Frametime sich verschlechtert.
Probiert habe ich mit GTA IV + V, Battlefield Heroes (Rising Heroes) und Furmark.
Auch mit dem letzten Treiber war das Problem schon da, habe deshalb den neue Treibe aufgespielt.

Mein Windows wollte ich eigentlich nicht neu aufsetzen, sofern es nicht absolut nötig ist
 

HisN

Kokü-Junkie (m/w)
Das hoch und runter könnte ein Problem sein den Treiber auszulesen.
Es gibt den AMD-Kompatibilitäts-Schalter im AB und im alten Crimson gabs die Effizienz-Schaltung.
Kompatiblität an, Effizenz aus.

Wenn es das nicht ist schau Dir den Takt Deiner CPU an ... nicht dass die Auslastung der Graka mit dem Takt der CPU zusammen Ballett tanzt.
 
TE
sputnik1969

sputnik1969

Komplett-PC-Käufer(in)
Aber auch bei hoher CPU Auslastung und hohem takt macht es keinen Unterschied.
Beim Furmark läuft die CPU dauerhaft mit 4252 MHz, CPU Auslastung ist dabei bei etwa 16, maximal 23 %. Die Spikes korrelieren auch nicht mit den Aussetzern.
Ich habe das noch mal mit CPU Takt aufgezeichnet. Bild anbei.mitcpuclock.jpg
 
TE
sputnik1969

sputnik1969

Komplett-PC-Käufer(in)
Nein, ich nutze weder f.lux noch andere entsprechende Software. Ich habe selbst den Afterburner und dazugehörigen Kram zwischenzeitlich deinstalliert, aber nachdem es nichts gebracht hat wieder aufgespielt um die Daten mal aufzuzeichnen
 
TE
sputnik1969

sputnik1969

Komplett-PC-Käufer(in)
Ich habe vorher und nach der Afterburner Installation auch den Treiber vollständig entfernt und neu aufgespielt
 

SnaxeX

BIOS-Overclocker(in)
Aber auch bei hoher CPU Auslastung und hohem takt macht es keinen Unterschied.
Beim Furmark läuft die CPU dauerhaft mit 4252 MHz, CPU Auslastung ist dabei bei etwa 16, maximal 23 %. Die Spikes korrelieren auch nicht mit den Aussetzern.
Ich habe das noch mal mit CPU Takt aufgezeichnet. Bild anbei.Anhang anzeigen 981715

Eigentlich müsste die CPU immer auf ihre 4.2GHz laufen, da dürfte der Takt nicht herum springen. Da ist also was falsch.
Wie kommst du auf 12GB RAM? 8+4GB RAM?
 

alalcoolj

Software-Overclocker(in)
Also deine frametimes sehen extrem nach VSync aus. Warum hast du sonst immer exakt 16,7 bzw. 33ms? Hast du V-Sync nicht nur im Spiel sondern auch treiberseitig abgestellt?
Oder spielst du im (rahmenlosen) Fenstermodus? Da wird auch synchronisiert, obwohl VSync abgeschaltet ist.
 
TE
sputnik1969

sputnik1969

Komplett-PC-Käufer(in)
@alalcoolj
Natürlich habe ich den Vsync sowohl in der Software als auch im Treiber abgestellt. Ich sehe ja, dass bei vielen Spielen bei geringer Auflösung und wenig Details mal eben 100-180 FPS möglich sind (BFH zum Beispiel). Ausserdem habe ich bereits genug Erfahrungen diesbezüglich, ich nutze ja PCs nicht erst seit Gestern. Ich weiss auch, dass meine RX480 und mein i7 3770k eine recht gute Kombination abgeben, sofern man nicht höchste Ansprüche stellt.
Bei 180 FPS mit abgeschalteten Vsync merkt man die "Verschlucker" dann ja auch deutlich weniger. Bei aber nur etwa 70 FPS ohne Vsync merkt man schon die Ruckler. Und in den Aufzeichnungen kann man ja auch sehen, dass es sie gibt.
Und einfache Spiele, die mir 180 FPS liefern werde ich sicher nicht ohne Vsync spielen. Unnötiger Energieverbrauch ohne sinnvoller "Gegenleistung", dafür mit gelegentlichem Tearing.

@Snaxe
Wenn ich z.B. den Furmark nehme, da ist der Takt beim Laufen IMMER auf 4252 MHz mit 100% Auslastung . Bei Spielen wie GTA aber eher nicht. Die Arbeitsteilung läuft da deutlich weniger glatt. Trotzdem bleibt er dann beim hohen Takt. Habe ich alles bereits untersucht.
Und ja, die 12 GB sind 2x4 + 2x2. Hatte in meinem alten PC die 2x2 drin und da sie dann (fast) identisch mit den neuen waren, habe ich sie dazu gesteckt. Gab damit auch in den letzten 5 1/2 Jahren keine Probleme - die gibt es erst jetzt, unabhängig vom Speicher (der knapp unter den 1600 laufen, da ich ja die BCLK höher gestellt habe, auch seit langer Zeit bereits. Vielleicht auch schon nachdem ich die RX480 kurz hatte hat es angefangen, habe lange nix "schnelles" mehr gezockt und bei Spielen wie "Life is strange" kommt es quasi nicht auf die FPS an. Alles über 30 ist da OK.
 
Zuletzt bearbeitet:

HisN

Kokü-Junkie (m/w)
Wobei Furmark doch eigentlich ein Graka-Test-Tool ist.
Das sollte die CPU überhaupt nicht belasten ...

Alter Screen, aber schau Dir die CPU-Last an.
Da läuft genau ein Kern. Klar, die CPU taktet hoch, weil ein Kern voll ausgelastet ist. Aber bitte ... das ist doch was ganz anderes als GTA5.
Die beiden Programme haben so dermaßen gar nix miteinander zu tun, das es mich wundert, warum sie zum Vergleich herangezogen werden.

http://abload.de/img/stromverbrauch_nur_grcepws.png
 
TE
sputnik1969

sputnik1969

Komplett-PC-Käufer(in)
Zum "Nachschaufeln" an die GPU wird sie belastet, nicht wie bei Spielen, aber trotzdem bleibt er natürlich hochgetaktet. So schlecht laufen die Scheduler und Gouvenors von Windows auch nicht, dass sie den Takt immer ändern bei jeder Gelegenheit.
 

alalcoolj

Software-Overclocker(in)
Und im Fenstermodus spielst du auch nicht?

Siehst du wirklich tearing? Das müsste bei 60Hz eindeutig erkennbar sein. Ansonsten wird, warum auch immer, synchronisiert, was zu unruhigen frametimes führt.
 
Zuletzt bearbeitet:
TE
sputnik1969

sputnik1969

Komplett-PC-Käufer(in)
Ja, bei 60 fps ohne vsync sehe ich tearing. auch bei mehr als 60. und dann sind die frametimes insgesamt wechselnd. und tearing, ne will ich nicht, dann eher auf vsync - sofern die grafikleistung ausreicht immer weniger als 16,7 ms für eine bildberechnung zu brauchen
 

RawMangoJuli

Volt-Modder(in)
vllt mal testen die CPU Nutzung von GTA auf 90% oder so zu begrenzen mit BES (Battle Encoder Shirase) oder welche Tools es da sonst noch gibt
 
Oben Unten