• Hallo Gast, du kaufst gerne günstig ein und erfährst oft vor deinen Freunden von interessanten Angeboten? Dann kannst du dein Talent als Schnäppchenjäger jetzt zu Geld machen und anderen PCGH-Lesern beim Sparen helfen! Schau einfach mal rein - beim Test der Community Deals!

Probleme mit EFI Raid 0 GPT Partition, Fachmann erwünscht !

Ratlosigkeit

Schraubenverwechsler(in)
Probleme mit EFI Raid 0 GPT Partition, Fachmann erwünscht !

Hallo Gemeinde

Ich sitze jetzt hier schon ein paar Tage an div. Problemen mit dem Raid 0 Verbund. Habe schon einiges versucht und mich belesen, da durch habe ich auch Einblick in diese komplexe Materie bekommen. Für jemanden der damit so nie wirklich in Berührung gekommen ist, sehr umfangreich und auch teils verwirrend.

Mein System: Windows 7 Pro 64 bit, Mainboard GA-Z77 D3H rev.1.2, icore 5, 8gb ram, 2 Intel SSD 530 Series je 120 GB Sata3, 1x Seagate Barracuda 7200. 12,

Zum eigentlichen Problem.

Keine Ahnung wie es zu diesem Problem kam aber ich wollte den PC neu starten und alles was ich bekam war "reboot and select proper boot device".
da wusste ich, ohje das ist nicht gut und wird länger dauern. was ich nicht wusste, das es ein Partitionstabellen / Bootsektor (oder so) Problem ist. Also hab ich Windows versuchen lassen es selber zu reparieren mit der Win-DVD. Was sich jetzt im nachhinein hoffentlich nicht als Fehler darstellt. Diese Prozedur war alles vergebens.
Ich habe dann angefangen mich zu belesen. Habe Informationen ran geholt, div. Programme probiert wie Diskpart und nun auch Gparted. Ich bekomme viele Informationen aus den Programmen, teils Fehlermeldungen, teils auch Informationen wo ich nicht weis wie ich damit umgehen soll um sie zu beheben. Manche Infos verstehe ich gar nicht.
Habe über die Eingabe Aufforderung einige Daten auf eine andere Platte kopieren können, allerdings lückenhaft da ich nur mit den Dos befehlen arbeiten konnte.

wen es hier vielleicht jemanden gäbe der sich in Sachen Boot Sektor und Partitionstabellen auf EFI mit Raid auskennt wäre das toll. Auch würde ich mir jemanden wünschen der diese ganzen (Fehler) Meldungen versteht.
Fragt mich einfach was ihr wissen wollt und ich werde versuchen es so detailliert wie möglich zu erklären zur not mit Bildern. Aber bitte de Reihe nach und nicht 50 Fragen auf einmal :)

super lieben Dank schon mal.

Ps auf die Barracuda kann ich auch nicht mehr zugreifen. wird aber noch angezeigt. denke da ist auch was mit dem Bootsektor. Aber die Windows Partition ist erstmal wichtiger.
 
G

Gast20180803

Guest
AW: Probleme mit EFI Raid 0 GPT Partition, Fachmann erwünscht !

eventuell wird dir eine platte aus dem raid verband ausgefallen sein, ssd im raid bringen dir ja auch nicht wirklich viel und die win7 raid treiber sind halt auch nicht wirklich gut, ich würde ne win installation ohne raid versuchen
 

wuselsurfer

Kokü-Junkie (m/w)
AW: Probleme mit EFI Raid 0 GPT Partition, Fachmann erwünscht !

Hallo Ratlosigkeit!

Willkommen im PCGHe_Forum! ;)

Leg die Windows DVD ein, starte bis zu den Reparaturoptionen und versuche einen Wiederherstellungspunkt zu finden.
Ist der vorhanden, setze den PC zurück.

Wenn nicht: klemme alle Platten bis auf eine SSD ab und versuche eine Windows-Installation.
Aber Achtung: damit löschst Du alle Daten vom vorherigen System!

 
TE
R

Ratlosigkeit

Schraubenverwechsler(in)
AW: Probleme mit EFI Raid 0 GPT Partition, Fachmann erwünscht !

Erst mal danke für die schnellen Antworten.
Aber eine Neuinstallation will ich noch nicht in Betracht ziehen. Das mach ich wenn ich keinen Ausweg mehr habe. Weil ich denke das hinter dem Bootsektor /Parttabelle das win noch in Ordnung ist. Ich brauch nur mal jemanden der mir das Raid zum Boot wieder sortiert bzw die Parttabelle wieder richtet. Einer de sich mit den ganzen begriffen wie /dev/md126p1 oder die Markierungen boot, esp und msftres (begriffe aus gparted) etc. auskennt .

beim starten von gparted kommen Fehlermeldungen und die möchte ich, soweit möglich, erklärt bekommen.
wie zb. Libparted-Fehler: end of file while reading /dev/md126: ich klicke ignorieren,
nächster darauf folgender Fehler "the Primary GPT table is corrupt, but the backup appears ok. so that will be used" ich klicke ok
dann der nächste Fehler invalid Argument during seek for read on /dev/sdb ich klicke ignorieren
dann kommt die Tabelle mit den 5 Partitionen. des Laufwerkes C: (was die beiden ssd´s ja beinhaltet) also das Raid ist in Ordnung die laufen als eine Festplatte anscheinend.

ich häng mal Bilder an vielleicht hilft das.

die ersten beiden Bilder sind DiskPart
IMG_20180223_191059.jpg
IMG_20180223_191252.jpg

die anderen Bilder sind von Gparted

Start Vorgang
IMG_20180225_124948.jpg
IMG_20180225_125009.jpg

das ist die Parttabelle
IMG_20180225_124737.jpg
 
Zuletzt bearbeitet:

wuselsurfer

Kokü-Junkie (m/w)
AW: Probleme mit EFI Raid 0 GPT Partition, Fachmann erwünscht !

Erst mal danke für die schnellen Antworten.
Aber eine Neuinstallation will ich noch nicht in Betracht ziehen. Das mach ich wenn ich keinen Ausweg mehr habe.
Ich will Dir ja nicht die Hoffnung nehmen, aber bei RAID 0 ohne saparaten Hardwarecontroller ist das meist vergeudete Lebenszeit.

Den MBR stellt man wie folgt wieder her:

Booten mit DVD in die Reparaturkonsole, folgende Befehle eingeben:
1. bootrec.exe /ScanOS
Man sieht, welche Windowsinstallationen gefunden werden.

2. bootrec.exe /fixboot
Der Bootsektor wird rückgesichert.

3. bootrec.exe /fixMBR
Der Masterbootsektor wird neu erstellt.

Hier ausführlich beschrieben:
Master Boot Record reparieren: MBR reparieren .


Man kann noch
chkdsk c: /b
eingeben und laufen lassen, falls c: erkannt wird.

Im RAID ist das alles aber fraglich.
 
TE
R

Ratlosigkeit

Schraubenverwechsler(in)
AW: Probleme mit EFI Raid 0 GPT Partition, Fachmann erwünscht !

na aber wenn ich das alles richtg verstanden habe hier mit dem ganzen, dann gibt es entweder einen MBR oder GPT und wenn das wirklich unterschiedlich ist, dann ist das kein MBR sondern ein GPT .

weil, ich habe das glaub schon mit dem MBR versucht.
 
Zuletzt bearbeitet:
TE
R

Ratlosigkeit

Schraubenverwechsler(in)
AW: Probleme mit EFI Raid 0 GPT Partition, Fachmann erwünscht !

Den MBR stellt man wie folgt wieder her:

Booten mit DVD in die Reparaturkonsole, folgende Befehle eingeben:
1. bootrec.exe /ScanOS
Man sieht, welche Windowsinstallationen gefunden werden.

das hab ich jetzt trotzdem mal gemacht. Allerdings ist da etwas komisch und zwar wenn ich von DVD boote findet er mein Windows und überprüft ob und was repariert werden soll. Ich breche alle Vorschläge ab, weil die nichts bringen, komme irgend wann dann in das Menü mit der Eingabeaufforderung, die ich auch gleich starte. Dann gebe ich den Befehl "bootrec.exe /scanos" ein und er meldet " die Suche nach Windows-Installation war erfolgreich. Gesamtanzahl der identifizierten Windows-Installationen: 0"
Wieso Erfolgreich wenn da 0 steht ? :/
 

wuselsurfer

Kokü-Junkie (m/w)
AW: Probleme mit EFI Raid 0 GPT Partition, Fachmann erwünscht !

Gesamtanzahl der identifizierten Windows-Installationen: 0"
Wieso Erfolgreich wenn da 0 steht ? :/
Das sieht schlecht aus.
Weder GPT noch MBR werden gefunden.
Das war's wohl mit den Daten.

Gparted findet auch weder benutzte Sektoren noch Bootsektoren, nur eine Bootmarkierung.

Windows 7 wird auch meist als MBR-Formatierung eingerichtet.

Also neuinstallieren.

Wozu dient das RAID 0?
 

nikon87

BIOS-Overclocker(in)
AW: Probleme mit EFI Raid 0 GPT Partition, Fachmann erwünscht !

Wieso Erfolgreich wenn da 0 steht ? :/
Naja...die Suche war erfolgreich aber es wurden eben 0 Ergebnisse gefunden. Von daher schon korrekt die Anzeige.

Allgemein: Bezüglich Software-RAID unter Windows kann ich auch nur sagen: Wenn da was kaputt ist, dann ist es kaputt. Habe bisher noch keine Möglichkeit gefunden wie man sowas wieder hinbiegen kann. Meist war der Aufwand einer Neuinstallation um einiges geringer einzuschätzen als eine weitere Lösungssuche um das RAID wieder zum laufen zu bringen. Kannst also eigentlich lediglich noch versuchen die Daten von einer der Platten zu sichern und dann neu installieren...am besten dann natürlich ohne RAID. Das bringt eh kaum eine Verbesserung der Performance wenn man kein echtes Hardware-RAID mit Caching usw. hat.

Hast du denn schon geprüft ob überhaupt die beiden Platten noch funktionieren? Wenn eine davon wirklich defekt ist kann logischerweise auch das RAID nicht repariert werden (falls es eine Möglichkeit gibt) und somit wären all deine bisherigen Bemühungen sinnlos.

P.S.: Das was du als "diskpart" angibst ist kein DiskPart. Zumindest in den Screenshots zeigst du ein Programm namens "TestDisk 7.0". In wie weit da im Hintergrund die Befehle von DiskPart genutzt werden weiß ich nicht, aber DiskPart ist ein offizielles Windows-Tool und kommt nicht von einem gewissen Christophe Grenier. DiskPart ist bei jedem Windows integriert, einfach in der Eingabeaufforderung "diskpart" eingeben. Das nur kurz der Vollständigkeit halber.
 
Oben Unten