ntoskrnl.exe, "Blue"Screens, Fehler-in-Anwendung-Crashs, Application Errors

dreamdomain

Freizeitschrauber(in)
Hallo liebe Community,

seit einiger Zeit bin ich von Abstürzen und Crashs geplagt, die mich mittlerweile an den Rande der Verzweiflung treiben. Anfang diesen Jahres lief alles noch super. Ende 2021 noch FH5 gespielt, dann eine Pause wg. defekter Graka, dann PC-Neubau, viel TW3 gezockt, Forza wieder angefangen. Nun habe ich seit Juli massive Probleme, augenscheinlich nur in FH5. Anbei hänge ich Bilder an, die die Fehler zeigen. PC Daten siehe unten.

1. Fehler in Anwendung; Passiert häufiger als die Bluescreens, der PC läuft weiter, lediglich Fh5 wird geschlossen
2. "Blue"screens, die nicht wirklich welche sind: Ich denke das Bild beschreibt es am besten. Der Monitor wird größtenteils schwarz, Farben ändert sich, Autoscheinwerfer werden weiß. Das ganze bleibt dann für ein paar Sekunden, bevor der PC neustartet (auch hier ohne den blauen Neustart Bildschirm). Dazu hänge ich 5 DMP Dateien mit an.
3. Application Errors: Hierbei schmiert das Game ohne Meldung ab. Anbei evtx File.

Leider habe ich keine so grafikintensiven Games, mit denen ich vergleichen kann. 1,5h Hell Let Loose gehen aber (vermutlich noch länger, bin dann ins Bett ;) ), in Forza schaff ich das nicht. Da sind es zwischen 0,5-1h. Laut Afterburner werden meist 6500MB der 8GB Vram benutzt. Dazu auch ein Bild, wie die monitoring Daten so aussehen während dem Zocken. Ansonsten habe ich übrigens weder in anderen Anwendungen wie Chrome noch im Idle Abstürze. Rocket League geht auch, nach ein paar Abendrunden an unterschiedlichen Tagen ist es heute abgeschmiert ohne Meldung, Nur in der Ereignisanzeige stand Application Error.

Was habe ich schon probiert?
- GPU Treiber mit DDU deinstalliert, ältere Version neuinstalliert (hat nichts gebracht), dann wieder auf aktuellste Version geupdatet
- sfc scannow und DISM online (ab und zu wird was repariert)
- GPU Core und Memory Takt auf -30 Mhz (Afterburner)
- Nvidia Systemsteuerung Energieverwaltungsmodus auf max. Leistung
- Windows ist komplett aktuell
- geplant ist ein Reinstall von Forza, wenn das nichts bringt bin ich schon bereit den PC platt zu machen :(

Ich bitte um Hilfe, kann mir jemand sagen was die Fehler verursacht? Über BlueScreenView.exe kann ich mir auch nicht erklären wo das Problem liegt...

Vielen Dank und viele Grüße
dreamdomain

PS: Kann die 5 DMPS nicht hochladen, da der Zip Ordner 1GB hat?? Wie kann ich euch die Daten zu Verfügung stellen?

----------------------------
CPU i5-11400 [EK WB Basic 240 AiO
GPU:MSI RTX 3060 Ti Gaming X LHR
MB: MSI Z590-A PRO
RAM: Corsair Vengeance LPX DDR4-3000 CL15 16GB Kit
NT: be quiet! Straight Power 11 CM 850W
FP: Kingston A2000 NVMe 1TB
 

Anhänge

  • 20220517_200914.jpg
    20220517_200914.jpg
    3,2 MB · Aufrufe: 49
  • 20220729_233757.jpg
    20220729_233757.jpg
    3,5 MB · Aufrufe: 31
  • 20220906_201757.jpg
    20220906_201757.jpg
    3,1 MB · Aufrufe: 30
  • IMG-20220725-WA0008.jpeg
    IMG-20220725-WA0008.jpeg
    935,7 KB · Aufrufe: 31
  • 20220515_213659.jpg
    20220515_213659.jpg
    1,9 MB · Aufrufe: 43
Zuletzt bearbeitet:
Arbeitsspeicher Meldungen wegen fehlerhaften Schreibens oder gar keinen schreiben

Kannst du dir RAM leihen bei einem Kollegen oder so ?
Ich glaube RAM läuft bei 13gb voll und lagert aus
Da wärst du noch was entfernt


Ich tippe wirklich auf Speicher

Ansonsten nochmal raus holen reinigen und wieder in Slot 2 und 4 einsetzen
 
Ich könnte den RAM aus dem PC den ich für meine Eltern gebaut habe ausbauen und testen. Das geht allerdings nicht zeitnah, da sie den PC täglich nutzen. Wie reinige ich den RAM? Mit einem Mikrofasertuch? Entstehen da keine Entladungen?

Kann es auch die Graka sein, oder gar das Mainboard? RAM wäre ja noch angenehm zu tauschen.

Wie kann ich euch die DMP Files hochladen? Die sind mehrere hundert MB groß jeweils.... Die müssten aber genauere Infos liefern oder? Würde mich freuen wenn vielleicht einer der Spezialisten hier die Files auswerten könnte :)

Edit: Hier der Download: --------------------- (siehe Screenshots Post #6)
 
Zuletzt bearbeitet:
So, mit etwas Verspätung die Screenshots. Auffällig: ntoskrnl.exe

Bitte auf die Nummerierung achten.

Edit: Anbei noch was aus dem Eventviewer
 

Anhänge

  • DMP1.1.png
    DMP1.1.png
    313,1 KB · Aufrufe: 22
  • DMP1.3.png
    DMP1.3.png
    366,8 KB · Aufrufe: 21
  • DMP1.2.png
    DMP1.2.png
    365,4 KB · Aufrufe: 15
  • DMP2.1.png
    DMP2.1.png
    311 KB · Aufrufe: 15
  • DMP2.2.png
    DMP2.2.png
    364,2 KB · Aufrufe: 14
  • DMP2.3.png
    DMP2.3.png
    365,2 KB · Aufrufe: 15
  • DMP3.1.png
    DMP3.1.png
    313 KB · Aufrufe: 14
  • DMP3.2.png
    DMP3.2.png
    365,5 KB · Aufrufe: 14
  • DMP3.3.png
    DMP3.3.png
    365,9 KB · Aufrufe: 14
  • DMP4.2.png
    DMP4.2.png
    363,6 KB · Aufrufe: 14
  • DMP4.1.png
    DMP4.1.png
    310,5 KB · Aufrufe: 15
  • DMP4.3.png
    DMP4.3.png
    366,2 KB · Aufrufe: 13
  • DMP5.1.png
    DMP5.1.png
    311,7 KB · Aufrufe: 12
  • DMP5.2.png
    DMP5.2.png
    361,7 KB · Aufrufe: 13
  • DMP5.3.png
    DMP5.3.png
    366,7 KB · Aufrufe: 12
  • DMP5.4.png
    DMP5.4.png
    364,9 KB · Aufrufe: 16
  • Ereignisanzeige 10.09.2022 12_41_21.png
    Ereignisanzeige 10.09.2022 12_41_21.png
    81,2 KB · Aufrufe: 11
  • Ereignisanzeige 10.09.2022 12_41_19.png
    Ereignisanzeige 10.09.2022 12_41_19.png
    70,8 KB · Aufrufe: 13
  • Ereignisanzeige 10.09.2022 12_41_00.png
    Ereignisanzeige 10.09.2022 12_41_00.png
    89 KB · Aufrufe: 12
  • Ereignisanzeige 10.09.2022 12_41_23.png
    Ereignisanzeige 10.09.2022 12_41_23.png
    81,4 KB · Aufrufe: 19
Zuletzt bearbeitet:
Kleiner Hinweis, die relevanten Daten (die Parameter der Fehler oben im Bild) sind teilweise abgeschnitten, die sind wichtiger als die Auflistung, welche Prozesse alle zu dem Zeitpunkt liefen. Relevant ist vor allem, was genau den Crash verursacht hat und welche Parameter und Details dazu gespeichert wurden.

In diesem Fall reicht es aber um einen Eindruck zu kriegen: MEMORY_MANAGEMENT mit 0x1a und 0x61941 heißt, dass die paging hierarchy beschädigt/falsch (corrupt) ist. Ich würde daher in folgende Richtungen prüfen:

  • RAM: hast du mal einen Memcheck über Nacht laufen lassen? Wenn nicht würde ich das mal tun um zu prüfen, ob der Speicher ok ist.
  • Pagefile/Festspeicher: hast du an der Auslagerung/Virtueller Speicher was geändert? Das sollte auf "Windows managt automatisch" stehen. Prüfe mal deine SSDs/Platten, ob die in Ordnung sind, wenn da Sektoren kaputt sind kann es sein dass versucht wird aus falschen Speicherseiten zu lesen. Deine Fehlermeldungen ganz oben auf Adressen wie 0xFFFFFFFFFFFFFFFFF und 0x0000000000000000 zeigen jedenfalls, dass da durch korrupte Daten ganz falsch versucht wird zu lesen und dann möglicherweise auf die kleinste mögliche und die größte mögliche Adresse gecappt wird.
  • Treiber: das kann aber auch von schlechten oder kaputten Treibern kommen. Wenn der Fehler nicht nur beim Forsa zocken käme hätte ich gesagt schau mal, ob er im safe mode auch auftritt. So könntest du mal alles rausschmeißen bzw. deaktivieren, was nicht unbedingt nötig ist (auch solche Sachen wie MSI Afterburner usw.) und schauen ob der Fehler dann noch kommt. Grafiktreiber hast du zwar durchprobiert, aber der Fehler in DirectX, der zwischendrin aufgelistet wird deutet eigentlich schon in die Richtung. Was aber auch da wieder passen würde wäre kaputter Arbeits- oder Festspeicher, siehe oben.

Was habe ich schon probiert?
- sfc scannow und DISM online (ab und zu wird was repariert)
Was genau wird denn repariert? Das wäre vielleicht ein wichtiger Hinweis.
 
Zuletzt bearbeitet:
Pagefile/Festspeicher: hast du an der Auslagerung/Virtueller Speicher was geändert? Das sollte auf "Windows managt automatisch" stehen. Prüfe mal deine SSDs/Platten, ob die in Ordnung sind, wenn da Sektoren kaputt sind kann es sein dass versucht wird aus falschen Speicherseiten zu lesen. Deine Fehlermeldungen ganz oben auf Adressen wie 0xFFFFFFFFFFFFFFFFF und 0x0000000000000000 zeigen jedenfalls, dass da durch korrupte Daten ganz falsch versucht wird zu lesen und dann möglicherweise auf die kleinste mögliche und die größte mögliche Adresse gecappt wird.
- Wo kann ich diese Einstellung überprüfen? Habe lediglich im Systemschutz neulich etwas verändert (die Abstürze waren aber vorher schon da), um einen VolSnap Fehler auszumerzen. Der war immer in der Ereignisanzeige, Windows konnte kein Backup erstellen. Habe dazu den Slider auf 1% gestellt, seitdem ist Ruhe. Siehe Anhang

- Habe das Laufwerk überprüfen lassen (Eigenschaften > Tools). Ergebnis: keine Fehler

hast du mal einen Memcheck über Nacht laufen lassen? Wenn nicht würde ich das mal tun um zu prüfen, ob der Speicher ok ist.
Wie kann ich so einen Memcheck machen? Geht das über Windows oder benötige ich extra ein Programm?

Was genau wird denn repariert? Das wäre vielleicht ein wichtiger Hinweis.
Kann mich da leider nur dran erinnern, dass da meist stand dass Win eine Komponentenschädigung (oder so ähnlich) erkannt hat und erfolgreich repariert hat
 

Anhänge

  • Desktop Screenshot 2022.09.10 - 13.02.15.72.png
    Desktop Screenshot 2022.09.10 - 13.02.15.72.png
    44 KB · Aufrufe: 20
- Wo kann ich diese Einstellung überprüfen? Habe lediglich im Systemschutz neulich etwas verändert (die Abstürze waren aber vorher schon da), um einen VolSnap Fehler auszumerzen. Der war immer in der Ereignisanzeige, Windows konnte kein Backup erstellen. Habe dazu den Slider auf 1% gestellt, seitdem ist Ruhe. Siehe Anhang
Einstellungen --> System --> Erweiterte Systemeinstellungen --> Erweitert --> Leistung/Einstellungen --> Erweitert --> Virtueller Arbeitsspeicher
Wie kann ich so einen Memcheck machen? Geht das über Windows oder benötige ich extra ein Programm?
Zum Beispiel mit memtest86, damit machst du einen bootbaren USB Stick und bootest davon. Windows hat glaube ich auch irgendeine "Speicherdiagnose", aber ich muss ehrlich sagen, dass ich die noch nie benutzt habe und nicht weiß, ob sie was taugt.
 
Hallo,
wäre mal gut zu wissen, seit wann du diese Abstürze hast. Nutzt du Windows 11 oder 10? Hast du Resizable BAR für deine nvidia aktiviert?
 
Hallo,
wäre mal gut zu wissen, seit wann du diese Abstürze hast. Nutzt du Windows 11 oder 10? Hast du Resizable BAR für deine nvidia aktiviert?
Ich habe die Abstürze seit Juni ca.
Nutze Windows 10
Resizable Bar ist deaktiviert

1662827152420.png


Einstellungen --> System --> Erweiterte Systemeinstellungen --> Erweitert --> Leistung/Einstellungen --> Erweitert --> Virtueller Arbeitsspeicher

Zum Beispiel mit memtest86, damit machst du einen bootbaren USB Stick und bootest davon. Windows hat glaube ich auch irgendeine "Speicherdiagnose", aber ich muss ehrlich sagen, dass ich die noch nie benutzt habe und nicht weiß, ob sie was taugt.

1662827311534.png
 
Sorry für die späte Rückmeldung.

Letztes WE wurde Memtest und forza reinstall leider nichts. Hoffentlich nächstes.

Werde zusätzlich DDU ordentlich ausführen, im abgesicherten Modus ohne Lan, und den Nvidia Treiber neu installieren. Vielleicht sollte ich eine Version nehmen, die älter ist als der Zeitpunkt wo die Probleme begonnen haben?

Zudem habe ich TridentZ RGB 3200 CL16 2x8GB für 70 Euro gesehen. Ist der RAM kompatibel mit meiner CPU? Ich meine mal gelesen zu haben, Aegis macht Probleme.
Wäre es dann eigentlich schlauer, gleich 2x16GB zu nehmen? (135€)

Würde wie gesagt den memtest machen. Wenn der keine Fehler ausspuckt, kann es dann noch der RAM sein?
 
Wahrscheinlich, aber nicht zwangsläufig. Jedenfalls sollten sich alle Versuche das zu fixen jetzt erst mal auf das RAM konzentrieren.

Wie läuft denn das RAM, auf einem XMP Profil? Wenn ja dann lass mal mit default laufen und schau ob die Fehler noch auftreten. Ansonsten könntest du die Timings mal von Hand eingeben. Evtl. die Voltage von Hand anpassen. Wenn das alles nichts bringt oder du keine Lust drauf hast bleibt nur noch RAM auswechseln. Ach ja, BIOS ist aktuell?
 
Ich hatte die DRAM Voltage auf 1.350 gestellt damals, weiss nicht mehr weshalb. Zurück auf Auto gestellt. XMP deaktiviert.

UEFI Version: E7D09IMS.130
Build Date: 09/06/2021

Leider steht bei meiner Version nicht vXX wie auf der Website. Aber es scheint eine alte Version zu sein:


Der Test lief jetzt nur 10min, aber es kamen schonmal keine Fehler.

ps. XMP scheint gar nichts zu verändern? Siehe Bild
 

Anhänge

  • 20220913_215827.jpg
    20220913_215827.jpg
    877,9 KB · Aufrufe: 17
  • 20220913_220530.jpg
    20220913_220530.jpg
    1,5 MB · Aufrufe: 12
Achso das ist nur weil ich das kurz angeklickt habe, damit diese weisse Zeile getriggered wird.

Xmp ist aber disabled.

Was ist eigentlich besser, Memtest86 oder Memtest86+? Reicht das schon, nur 10 Minuten den Memtest86 durchlaufen zu lassen? Könnte in den folgenden Tagen oder am Wochenende mal einen Test komplett durchlaufen lassen bzw. 2-3 komplette Tests machen.


Jedenfalls danke schon mal für deine bisherige Hilfe :daumen:
 
Zuletzt bearbeitet:
Was ist eigentlich besser, Memtest86 oder Memtest86+? Reicht das schon, nur 10 Minuten den Memtest86 durchlaufen zu lassen? Könnte in den folgenden Tagen oder am Wochenende mal einen Test komplett durchlaufen lassen bzw. 2-3 komplette Tests machen.
Memtest86+ war mal ein Fork und wurde auch glaube ich mal eine Zeit lang nicht weiter entwickelt. Hab mal eben geschaut und es gibt aktuelle Versionen. Ohne mir jetzt die aktuelle Version im Detail angeschaut zu haben wage ich mal zu sagen dass es für Standardtests, so wie du es jetzt gemacht hast, egal ist.

Das ist ja mal erfreulich, dass mit anderen Einstellungen keine Fehler mehr kommen. Dann wäre es jetzt an der Zeit, zu schauen, ob dein Problem immer noch so auftritt.
 
Okay, also werd ich mal schauen ob Forza ohne Abstürze läuft.

Habe gestern den Nvidia Treiber 511.65 installiert. Mit DDU im Safemode den alten plattgemacht und nach dem Neustart weiterhin im Safemode den Treiber installiert.
Damit lief Forza 1h ohne Abstürze, dann kam wieder der read error. Da ich nicht viel Zeit habe zum "Test-Zocken", könnte es bis zum WE dauern, bis ich dazu Ergebnisse posten kann.

Ist es aber nicht komisch, dass diese Abstürze urplötzlich auftraten? Habe seit März oder so nichts am PC verändert, einstellungsmäßig.

Welchen Nachteil hätte ich ohne XMP? Wie man sieht haben sich die Einstellungen ja nicht verändert (die 2 weißen Zeilen im Bild siehe #15)
 
Update:
Bios Update gemacht. Weiterhin Fehler in Memtest
Habe mit den DRAM Voltages rumgespielt, mit XMP enabled:
1.40V -> Fehler
1.45V probiert, keine Fehler. Gelesen dass das schon etwas viel ist.
Also auf 1.41V zurück. Erster Test keine Fehler, zweiter Test Fehler.
Das gleiche mit 1.42 und 1.43V.
Danach XMP deaktiviert, von 2133mhz auf 2933mhz gestellt, zurück auf 1.35V gegangen. 3x Test, keine Fehler.
Jeden Test habe ich nur ca. 2-3min laufen lassen, da meist sofort nach den ersten Sekunden schon Fehler auftraten.
-> Forza spielen steht noch aus, werde ich noch testen, heute und morgen.

Was hat das zu bedeuten? Ohne XMP scheint ja (vorerst) alles i.O.
Vielleicht ist das gesamte System instabil? Könnte ja auch die CPU oder das MB sein.

Sehr frustrierend das ganze.... :(

Glaube ich bestell mal neuen RAM. Bin aber sehr pessimistisch und denke mal, dass sich dadurch nichts ändern wird. Dann ist die Enttäuschung nicht so groß später...
Diese RAMs habe ich rausgesucht (wollte eigentlich Ballistix aber die gibt es ja nicht mehr):
 
Zuletzt bearbeitet:
Zurück