• Hallo Gast, du kaufst gerne günstig ein und erfährst oft vor deinen Freunden von interessanten Angeboten? Dann kannst du dein Talent als Schnäppchenjäger jetzt zu Geld machen und anderen PCGH-Lesern beim Sparen helfen! Schau einfach mal rein - beim Test der Community Deals!

Merkwürdiges Problem mit Windows 10 und Apps aus dem Store

shahisinda

Komplett-PC-Aufrüster(in)
Moin Community
Ich habe weiterhin ein merkwürdiges Problem mit Apps und Games aus dem Microsoft Store und heute kam etwas Neues hinzu, zu dessen Lösung ich immer noch keine weitere Idee habe.
Im Grunde ist es so, dass jede App oder Spiel bisher aus dem AppStore absolut keine Tastatur- und Mauseingaben akzeptierten.. Der Verdacht wurde schon einmal in einem anderen Forum geäußert. Es hilft auch nicht die Tastaturtreieber und Maustreiber zu deinstallieren,
Andere Apps abseits des Stores haben absolut null Probleme. Ich habe auch alle Treiber (alle erdenklichen) erneuert, den Store De- und installiert,zurückgesetzt. Das Installationsverzeichnis ist default auf c:/
Soweit so schlecht. Da ich den Gamepass Ultimate besitze habe ich dann noch einmal gewagt das akutuelle Spiel Humankind zu installieren. Ich habe nicht erwartet, dass ich über das Menü hinauskomme, da ja wie gesagt Maus- und Tastatureingaben nicht angenommen werden. Es gibt auch keine Overlay Software die das Spiel killen könnte

Nun ist es aber so, dass dieses Spiel gar nicht erst in das Menü kommt, sondern kurz nach Start und schwarzen Spielbildschirm abschmiert und kommentarlos auf dem Desktop zurückkehrt. Im Grunde war ich damit dann auch schon durch und hätte es als unlösbar abgehakt.
Mehr durch Zufall war ich dann auf einem zweiten Account (ebenfalls Admin) auf meinem System, im Grunde mit allen gleichen Einstellungen.
Da dachte ich mir doch, gehst Du aus Spaß mal den Store, meldest dich mit deinem Account an und startest das Spiel. Nachdem ich durch einen Download des Zertifikats für das Spiel auf Start geklickt habe, siehe da: Es läuft, ebenso alle anderen Apps. Ohne Probleme. Ja, WTF?!?!?

Das kann ja nur heißen das irgendwas in meinem Standard-Account broken sein muss, damit es dann auf dem anderen einwandfrei funktionieren kann.

Natürlich habe ichvorher auch einen sfc /scannow über das Terminal gemacht (keine Fehler) und auch in das Fehlerprotokoll von Windows geschaut und folgende Fehlermeldung gefunden, sobald das Spiel abgeschmiert ist:

Code:
Name der fehlerhaften Anwendung: Humankind.exe, Version: 0.0.0.0, Zeitstempel: 0x608d8859
Name des fehlerhaften Moduls: ucrtbase.dll, Version: 10.0.19041.789, Zeitstempel: 0x2bd748bf
Ausnahmecode: 0xc0000409
Fehleroffset: 0x000000000007286e
ID des fehlerhaften Prozesses: 0xe98
Startzeit der fehlerhaften Anwendung: 0x01d795aaa8e22500
Pfad der fehlerhaften Anwendung: C:\Program Files\WindowsApps\AmplitudeSTUDIOS.Humankind_1.1.58.0_x64__sm4da3szdwjfr\Humankind.exe
Pfad des fehlerhaften Moduls: C:\Windows\System32\ucrtbase.dll
Berichtskennung: bfc6a359-e259-455d-9e77-c5adcc3a160e
Vollständiger Name des fehlerhaften Pakets: AmplitudeSTUDIOS.Humankind_1.1.58.0_x64__sm4da3szdwjfr
Anwendungs-ID, die relativ zum fehlerhaften Paket ist: Humankind

Demnach ist die ucrtbase.dll für den Abbruch verantworktlich. Wohl eine Komponente des VC++ Rep Pakets. Also habe ich auch dieses im Vorfeld komplett neu installiert und gepatcht. Leider auch ohne Erfolg.

Hat jemand eine Idee, wie ich dem Murks auf dei Schliche kommen könnte um nicht auf dem Zweitaccount ausweichen zu müssen?
 
Zuletzt bearbeitet:

Dooma

Freizeitschrauber(in)
Also ich hab mal ein wenig gegoogelt und so wie ich das verstehe, gibt es viele Möglichkeiten woran es letztendlich liegen kann.
Dass es bei einem User funktioniert und bei einem anderen nicht, dazu habe ich gar nichts gefunden... leider.
Erstaunlicherweise konnten einige das Problem lösen indem GPU oder Audio Treiber neu installiert wurden.
Andere mussten Windows komplett neu installieren um das Problem zu lösen.

Du könntest auch noch Dism vor sfc ausprobieren.
 

Herbststurm

Freizeitschrauber(in)
Nun ist es aber so, dass dieses Spiel gar nicht erst in das Menü kommt, sondern kurz nach Start und schwarzen Spielbildschirm abschmiert und kommentarlos auf dem Desktop zurückkehrt

Ich hatte bei Win10 auch mal eine Zeit lang das Problem, dass Spiele die immer gestartet sind, sich einfach ohne Grund mit schwarzem Bild beendeten.

Nachdem ich z.B. Gears4 damals neu heruntergeladen hatte ging es plötzlich wieder ohne Probleme bis aus heiterem Himmel wieder der gleiche Fehler auftrat.

Ich bin damals von einem Lizenzproblem ausgegangen hatte aber keine Lust ständig die großen Spiele neu herunter zu laden.

Hab dann immer einen sehr kleine DLC neu installiert, dann gingen die Spiele wieder, irgendwann ist das Problem nicht mehr aufgetaucht ... ich denke mal der Fehler ist durch ein Update bei mir verschwunden.
 
Oben Unten