• Hallo Gast, du kaufst gerne günstig ein und erfährst oft vor deinen Freunden von interessanten Angeboten? Dann kannst du dein Talent als Schnäppchenjäger jetzt zu Geld machen und anderen PCGH-Lesern beim Sparen helfen! Schau einfach mal rein - beim Test der Community Deals!

Zweite NVME SSD Funktioniert, bis ein Spiel darüber gestartet wird

Arkonos66623

Freizeitschrauber(in)
Ich habe ein doch recht seltsames Problem, habe mir eine Pioneer 2TB NVME Gen3 für meinen zweiten M2 Slot geholt, diese funktioniert an sich auch, man kann alles Speichern und abrufen, allerdings wird die SSD nur mit Gen 2 angesprochen. Im UEFI des B450 Mortar Max habe ich auch keine Möglichkeit gefunden mehr Lanes für den 2.M2 bereit zu stellen, ist aber auch halb so wild.

Sobald aber ein installiertes Spiel von dieser NVME ausgeführt wird, fangen nach kurzer Zeit irgendwelche Ladefehler an, bis das Game abstürzt. Danach ist es nicht mehr möglich irgendwas auf der SSD zu löschen oder zu speichern. Es kommt immer die Meldung : Das angegeben Gerät ist nicht vorhanden, durchblättern geht aber!. Nach einem Neustart funktioniert wieder alles bis man wieder irgendein Spiel startet:huh:. Große Dateien mit über 30GB kopieren / löschen kein Problem, Spiel starten und nix geht mehr danach....

Mit den anderen SSD gibt es keine Probleme. Habe ich hier evtl. keine Ressourcen/Lanes mehr übrig oder was kann das sein?

Mein System:
Ryzen 3700X
32 GB Gskill 3600 CL 16 DDR4
Palit RTX 3090
M2 Slot 1 : ADATA 1TB NVME Gen3 / Gen3
M2 Slot 2 : Pioneer 2TB NVME Gen3 / Gen2
SATA : 1xSamsung SSD TB 2x Sandisk 256GB SSD
B450 Mortar Max Motherboard
750 Watt Cooler Master Netzteil
Windows 10 Pro
 

Cosmas

BIOS-Overclocker(in)
B450 ist das Problem, der hat nur 24Lanes, davon gehen 16für die GPU, 4für die IO und 4 für die erste NVME drauf, wenn du 2 nutzt werden beide in der Bandbreite halbiert, ausserdem ist dann auch noch Portsharing angesagt, srich 2 SATA Ports teilen sich für gewöhnlich die Laness mit der ersten NVME so geht eben nur entweder oder und beim 2ten dürfte das nicht anders sein.

B550 oder bei dem nicht gerade günstigen Setup nen anständiges X570Brett und das Problem is Geschichte. ;)

Mich hatte das schon damals beim B350 genervt, weil ich so in meinen Möglichkeiten eingeschränkt wurde und mir die NVME die ersten 2 SATA Ports klaute...deshalb bin ich dann beim 3700X gleich mit auf X570 gegangen und kann hiuer problemlos beide M.2 und 4 SATAPorts belegen, ohne das die sich anzicken. 40Lanes FTW!^^
 
TE
Arkonos66623

Arkonos66623

Freizeitschrauber(in)
Hm, heißt das sobald ich das System auslaste gehen mir die Lanes flöten für die SSD und die fliegt quasi raus ? Naja ursprünglich war gar nicht geplant, das System so auf zu blasen, aber irgendwie ist es mit der Zeit dann doch so gekommen:ugly:. Wusste gar nicht das es möglich ist die Lanes zu sharen, dachte die werden vorher einfach festgelegt und gut ist..


Danke für die schnelle Antwort!
 

rhalin

Freizeitschrauber(in)
Ich habe zwar B550 und kein B450 aber auch ich kann nicht alle SATA-Ports nutzen wenn beide NVME belegt sind.
Schau mal in dein Mainboard-Handbuch, bei mir zum Beispiel würden SATA Port 5 & 6 wegfallen wenn ich die 2te NVME verbaue die über den Chipsatz läuft.
Vielleicht kannst du da noch was umstecken.
 

vb87

Komplett-PC-Käufer(in)
Im Handbuch steht drin, das der 2. Slot über den B450 Chipsatz nur mit Gen2 angebunden ist. Auserdem findet dort Lanesharing mit PCIe Slot 4 statt.
 

Schori

Software-Overclocker(in)
Die obere m.2 SSD ist direkt an die CPU angebunden, bei der unteren läuft es bei jedem Board über den I/O Hub.
Bei deinem Board ist der untere m.2 Anschluss nur mit PCIe 2.0 angebunden und teilt sich die PCIe Lanes mit dem PCIEe Slot 4. Beides gleichzeitig kann man nicht nutzen.
Lane-Sharing ist bei dir also gar kein Problem.

Ich vermute, dass die Anbindung der SSD unzureichend ist und es deshalb zu deinen Problemen kommt.
Testhalber könntest du die zwei m.2 SSDs tauschen um einen defekt der Pioneer SSD auszuschließen.
 
Oben Unten