• Hallo Gast, du kaufst gerne günstig ein und erfährst oft vor deinen Freunden von interessanten Angeboten? Dann kannst du dein Talent als Schnäppchenjäger jetzt zu Geld machen und anderen PCGH-Lesern beim Sparen helfen! Schau einfach mal rein - beim Test der Community Deals!

Übertragungsgeschwindigkeit zum NAS zu niedrig?

Sn0w1

Freizeitschrauber(in)
Übertragungsgeschwindigkeit zum NAS zu niedrig?

Grüße zusammen, folgende Situation:

Ich betreibe eine WD MyCloud EX2 (die nicht-Ultra Version) mit 2x2TB WD RED im Raid 1 Verbund. Angeschlossen an einem Gigabit Switch an dem auch mein Rechner direkt dran hängt. Im Rechner arbeiten 2 WD Black Platten im Raid 0 Verbund. NAS, Switch, Rechner und Netzwerkleitungen sind fähig ein Gigabit Netzwerk herzustellen.
Wenn ich jetzt eine Einzeldatei von 1GB von meinem Rechner aufs NAS kopiere passiert das ganze mit so ca. 40-45MB/s. Das ist der Wert den Windows-Explorer und auch die Übersicht des NAS anzeigen.
Wenn ich nun mehrere Dateien (hauptsächlich Bilder) via WD Sync synchronisiere passiert das ganze mit relativ genau 13MB/s +/- 2MB/s. JPG's sind 12MB groß, also etwa eines pro Sekunde. RAW Dateien gehen mit etwa 20MB/s durch und größere Videodateien mit etwa 30MB/s.

Im NAS sind 512MB RAM verbaut welche nie über 60% ausgenutzt sind, die CPU hat teilweise Peaks mit über 90%, läuft im Gesamtschnitt aber mit rund 70%.

Das Netzwerk ist während des kopierens nicht anderweitig belastet (Internet würde eh max. 100MBit wegziehen; theoretisch); im NAS habe ich bereits manuell die 1000er Geschwindigkeit eingestellt und Jumbo Frame von 1500 (AUS) auf 9000 gesetzt. Die beiden Sachen haben mir etwa 3MB/s bei den Bildern gebracht.

Die eigentliche Frage ist, ob die Geschwindigkeiten so normal sind. Einzeldateien sind in aller Regel ja etwas langsamer zu kopieren; als ich die ganzen Bilder von meiner USB3.0 Platte rüberkopiert hab ging das allerdings auch mit ganz lockeren 40MB/s + konstant durch; darüber hinaus würde ich allein schon bei der 1GB Testdatei mehr als 40-45MB/s erwarten.
Ich bin allerdings kein Profi und deshalb wende ich ratsuchend an dieses Forum.

Bei weiteren Fragen stehe ich gerne zur Verfügung und danke schon einmal im voraus für jegliche Tips :)

VG
 

Malkolm

BIOS-Overclocker(in)
AW: Übertragungsgeschwindigkeit zum NAS zu niedrig?

40MB/s sind in etwa das, was man von der non-ultra Version erwarten würde im sequentiellen Schreiben. Mehr schafft insbesondere die CPU nicht (imho eine 1.2(?) GHz single-Core CPU). Die Ultra-Variante kommt auf bis zu 60.
 

fotoman

Volt-Modder(in)
AW: Ãœbertragungsgeschwindigkeit zum NAS zu niedrig?

Wenn ich mir die Ergebnisse hier ansehe
WD My Cloud EX2 NAS im Test: Alternative zu Synology und QNAP? (Seite 3) - ComputerBase
(nahezu die einzigen, die ich für das alte WD MyCloud EX2 finde), dann kann es beim Schreiben einfach nicht mehr. Damit dürfte es (wie bei alten und günstigen Synology/QNap NAS) seinen Grund haben, warum WD schon 2016 die Ultra-Version heraus gebracht hat. Das ganze tritt wohl leider nicht nur bei RAID1 auf, sondern auch mit einzelnen Platten.

Daß das Kopieren von Einzeldatein nochmal langsamer wird, ist völlig normal und wäre bei jedem NAS so. Da hilft allenfalls ein anderes Kopierprogramm, welches parallel Daten kopiert, falls das NAS mit sowas umgehen kann.

Beim Kopieren von 400.000 kleinen Bilddateien von einem Rechner auf den anderen (beide mit SSD) war es effektiver, die Daten auf der Quelle in ein Archiv zu packen, dieses per GBit Lan zu übertragen und am Ziel wieder zu entpacken. Das geht mit einem normalen NAS natürlich nicht, da muss man halt warten.
 
TE
Sn0w1

Sn0w1

Freizeitschrauber(in)
AW: Übertragungsgeschwindigkeit zum NAS zu niedrig?

Vielen Dank schon einmal für die Antworten, dachte nicht das es tatsächlich an der CPU liegen könnte. Die Ultra Version schafft laut irgendeinem Test den ich gestern mal gefunden habe und nun nicht mehr finde wohl sogar knapp 100 MB/s (vermutlich Einzeldatei auf Einzelplatte).
Ich werde mir wohl mal angucken ob es eine aktuelle Übersicht gibt und ob das ganze auch schneller gehen kann und dann ggf. upgraden.
Nach dem Urlaub rund 1TB an Fotos & Videos zu kopieren dauert mir dann am Ende doch etwas zu lang in der jetzigen Variante. Habe ich damals beim Kauf aber auch ehrlich nicht drauf geachtet, weil da noch nicht relevant. :schief:

Edit: Nach 10 Stunden habe ich jetzt einen Schnitt von ziemlich genau 20MB/s mit primär Fotos und einigen Videos. Ich werd mich wie gesagt mal umsehen obs da was alternatives gibt :)
VG
 
Zuletzt bearbeitet:

TurricanVeteran

Volt-Modder(in)
AW: Übertragungsgeschwindigkeit zum NAS zu niedrig?

Ich wußte garnicht, das ein NAS so langsam sein kann. :huh:
Mein linksys-router, der hier aber nur als switch+wlan-zugriffspunkt+NAS fungiert, schafft mit einer einzelnen 2,5 zoll platte um die 80 MByte lesend bzw. schreibend und mit der angeschlossenen ssd das, was der popelige realtek-controller auf meinem board her gibt. (44MByte große bilddateien richtung NAS sind das 101 MByte/sek und ein großes file von selbigen um die 90...)
 
TE
Sn0w1

Sn0w1

Freizeitschrauber(in)
AW: Übertragungsgeschwindigkeit zum NAS zu niedrig?

Naja, bin alles in allem auch etwas überrascht; auf der anderen Seite muss man dazu erwähnen das das Modell nicht mehr das jüngste ist und das für den normalen Heim-Anwender ja völlig ausreicht.
Mir war das ja auch lange Zeit schnell genug, wenn da nur mal eben ein Export aus Premiere Pro rübergebügelt werden muss oder ein paar exportiere Bilder aus Lightroom fällt die Geschwindigkeit ja garnicht ins Gewicht, die Dateien sind entweder sofort synchronisiert oder brauchen max. 1 Minute.
Das Problem stellt sich erst bei so Mengen wie ich sie jetzt hatte, 2 Wochen Urlaub, 1TB auf rund 16.000 Dateien. Das dauert dann halt ewig. Aber hier sind wir wieder beim Thema, der normale Heim-Anwender hat ja eher selten mal soviele Daten. Meine Kollegen z.B. haben dann vielleicht mal 80GB in 2 Wochen zusammengesammelt.
Ich werde auf jeden Fall weiter schauen was es aktuell am Markt gibt und ob ich verlässliche Werte finden kann wie schnell die Geräte tatsächlich mit Einzeldateien sind. Das Synology DS218 z.B. sieht auf den ersten Blick ja garnicht mal so schlecht aus.

VG
 

fotoman

Volt-Modder(in)
AW: Übertragungsgeschwindigkeit zum NAS zu niedrig?

Aber hier sind wir wieder beim Thema, der normale Heim-Anwender hat ja eher selten mal soviele Daten.
Was ist denn ein normaler Heimanwender? Leuten mit wenig Daten würde ich nur sehr selten ein NAS empfehlen, die sind meist mit einer ext. HDD für Backups besser bedient.

Mir war mein altes QNap NAS aus 2012 mit ca. 40 MB/s Schreibgeschwindigkeit zu langsam. Also wurde der (damals) 10 Jahre alte PC zum NAS umfunktioniert. Das lief alles recht gut (große Dateien mit 112 MB/s in beide Richtungen), und weil mein NAS/Server sowieso nicht 24/7 läuft, waren mir auch die 120 Watt Stromverbrauch egal.

Seitdem ich des öfteren mal große VMs oder Backup-Images auf das NAS kopiere, haben NAS und PC jeweils 10 GBit Karten bekommen und ich werde demnächst die HDD auf RAID0 erweitern, damit mehr wie 180 MB/s erreichbar sind.

Kopiere ich aktuell 541 Bilder (15,2 GB, ca. 28 MB/s pro Bild) vom PC aufs NAS, komme ich auf 125-150 MB/s (je nachdem, auf welchen Bereich der HDD Linux gerade schreiben muss). Bei großen Dateien sind es 140-180 MB/s.

Mache ich das ganze mit nur 13 MB großen Bildern, bleiben nur noch 110-120 MB/s übrig. Und nehme ich 7500 Datein mit jeweils 20-30 KB, dann bleiben trotz 10 GBit Anbindung nur noch knapp 3 MB/s Übertragungsrate übrig.

Das allles mit einer einzige SATA HDD als Ziel und mit "normalem" Kopieren mittels Windows-Explorer.

Kopiere ich die selben Daten mittels robocopy /MT:8 (also mit 8 Copy-Threads parallel), komme ich bei den 28 MB Bildern auf 182 MB/s (mehr kann die WD Red nicht) und bei den 20-30 KB Dateien trotzdem nur auf 8,6 MB/s. Für bedeutend mehr müsste man das Ram im NAS noch viel intensiver als Cache nutzen und die damit verbundenen Risiken in Kauf nehmen.

Auch mit günstigen modernen NAS kann man GIbt problemlos ausnutzen, jedenfalls ohne RAID und ohne Verschlüsselung und wenn Quell- und Ziellaufwerk schnell genug sind. Das DS216 ider DS218 sind m.W.n. solche Geräte.
 
TE
Sn0w1

Sn0w1

Freizeitschrauber(in)
AW: Übertragungsgeschwindigkeit zum NAS zu niedrig?

Dem kann ich natürlich zustimmen, Leute mit weniger Daten haben tatsächlich selten ein NAS rumstehen.
Ich danke auf jeden Fall schon einmal für die ganzen Infos!

Wie bereits erwähnt ging das synchronisieren heute Nacht mit dem automatischen Ablauf der WD Sync App mit 20MB/s im Schnitt. Aktuell habe ich einen zweiten Ordner mit ca 650GB den ich ganz normal über den Windows Explorer kopiere (rund 17.000 Dateien). Die Videodateien am Anfang gingen mit 60MB/s durch, bei allem was danach kam (Fotos mit 2-8MB) ist die Übertragungsrate wieder extrem eingebrochen und kommt jetzt - meisten - auf max. 3 MB/s. Dazu muss ich allerdings erwähnen das nebenbei noch Video Dateien über WD Sync kopiert werden, das könnte der Grund dafür sein.

Theoretisch könnte ich mir auch überlegen meinen alten PC als NAS zu nutzen. Vom Alter her dürfte er etwa deinem entsprechen, muss mir dann allerdings überlegen ob es mir das wirklich Wert ist.
Der alte PC müsste dann nämlich so oder so noch mindestens eine GBit Netzwerkkarte bekommen da das Motherboard kein GBit Anschluss hat, dann würde ich allerdings vermutlich nicht mehr rausholen als mit einer DS218 (glaube ich zumindest).
Alternativ müssten in beide Rechner noch 10GBit Netzwerkkarten, da bleibt dann die Frage wie sich Kosten <-> Nutzen verhalten. Am Ende würde ich damit meiner Vermutung nach trotz Einzeldateien (50MB je Bild) mehr rausholen als mit einer DS218 mit GBit Anschluss, allerdings zu einem höheren Preis, mehr Aufwand bzgl. Einrichtung und zuletzt auch nicht der Garantie das meine Hardware noch sehr lange hält (der DDR2 RAM hat am Ende schon Probleme gemacht und Ersatz ist inzwischen auch relativ teuer geworden).

Interessant wäre es mal das DS218 zu testen und zu gucken wie gut es für meinen Zweck arbeitet.
 

Matusalem

PC-Selbstbauer(in)
AW: Übertragungsgeschwindigkeit zum NAS zu niedrig?

Im NAS sind 512MB RAM verbaut welche nie über 60% ausgenutzt sind, die CPU hat teilweise Peaks mit über 90%, läuft im Gesamtschnitt aber mit rund 70%.

512 MB sind auch arg wenig und die 60% wenig aussagekräftig. Die meisten Computer schaufeln schon einmal RAM frei und lagern Speicher aus, auch wenn dieser nicht direkt benötigt wird. Sobald dann Speicher von Platte wieder gelesen werden muss, wird es sehr langsam.
 

Eol_Ruin

Lötkolbengott/-göttin
AW: Übertragungsgeschwindigkeit zum NAS zu niedrig?

Dem kann ich natürlich zustimmen, Leute mit weniger Daten haben tatsächlich selten ein NAS rumstehen.
Ich danke auf jeden Fall schon einmal für die ganzen Infos!
Nicht wirklich!
Ich kenne einige die kein hohes "Datenaufkommen" haben und trotzdem eine NAS mit mindestens zwei HDs zuhause haben!

Mein bester Kumpel hat z.B. eine Synology DS216j mir 2x1TB wovon nach einem halben Jahr Nutzung ca 800GB "voll" sind.
Da es sich zu 80% um ACAD/Office-Daten, Bilder und MP3s handelt - welche ja nicht viel Platz belegen - braucht er auch nicht viel mehr!#

Was er allerdings benötigt ist die Verfügbarkeit der Daten per Internet - deshalb eine NAS!
Er könnte die Daten natürlich auch "in die Cloud" laden - aber bei sich zuhause auf dem land hat er nur LTE und auch das nicht mit besonders hohen Datenraten!
Und daheim braucht er am öftesten Zugriff darauf - deshalb keine "Cloud"!

Viele Leute welche - wie mein Kumpel - in den letzten ein Haus gebaut haben haben diese "ver-LAN-t"! ;)
Und da lohnt es sich schon eine "kleine NAS" zu nutzen!
 

fotoman

Volt-Modder(in)
AW: Übertragungsgeschwindigkeit zum NAS zu niedrig?

Der alte PC müsste dann nämlich so oder so noch mindestens eine GBit Netzwerkkarte bekommen da das Motherboard kein GBit Anschluss hat, dann würde ich allerdings vermutlich nicht mehr rausholen als mit einer DS218 (glaube ich zumindest).
Das zwar nicht, dafür sind es 10€ für die Netzwerkkarte (mein Q6600 aus 2007 hatte die schon OnBoard) zu 250€ für die DS218. Dazu hat man dann 3-4 SATA Anschlüsse im PC, fals das Gehäuse groß genug ist. Das Problem könnte eher in WoL sein, oder die Stromkodten, wenn der PC dann 24/7 durchlaufen soll.

10 GBit lohnt sich für sowas nicht wirklich, bei den Netzwerkkarten (je 80-100€) bleibt es nicht, Du brauchst mit Sicherheit auch noch mind. einen passenden Switch, wenn nicht sogar zwei davon. Außerdem dürfte Dein alter PC noch nicht einmal einen (freien) PCIe2x4 Slot haben. Dann braucht man noch SSD oder RAID 0 (bzw. RAID 6, wenn man Geschwindigkeit und Ausfallsicherhheit haben möchtest), also 2-4 Platten. Nur, um von 112 auf 140-180 MB/s kommen lohnt sich sowas m.M.n. nicht.

Wobei mich deine Mengenangaben mittlerweile etwas wundern. Du hast 2*2 TB im NAS mit RAID 1 (also effektiv nur 2 TB), sprichst aber von 1 TB an (unsortierten/unbearbeiteten) Bildern/Videos, die Du nach einem Urlaub dort ablegen möchtest. Entweder werden in den kommendne Wochen >90% der Daten wieder gelöscht oder das NAS ist schon nach einem Urlaub voll.
 

Tekkla

Software-Overclocker(in)
AW: Übertragungsgeschwindigkeit zum NAS zu niedrig?

Eine Synology wird nicht viel schneller sein. Gerade wenn es sich um viele "kleine" Dateien handelt, kommt das SMB Protokoll ganz schnell an seine Grenzen. Der Overhead frist dermaßen Leistung, dass es keinen Spass mehr macht. Ich selber habe hier ein selbst gebautes NAS mit einem J3455 Quadcore Celeron, 8 GB RAM, 1x 250 GB SATA SSD und 2x 4 TB WD Red unter Ubuntu. Über Samba schockt das gar nicht viele Daten zu schreiben. Egal ob Bilder oder Arbeiten mit Eclipse bzw IntelliJ an Projekten auf Netzlaufwerken, es schnarcht so vor sich hin, beim Lesen wie beim Schreiben. Mit NFS gibt es keinerlei dieser Einbrüche. Aber das kann Windows wieder nicht richtig.

Wenn du so viele Daten von einem Windows PC auf ein NAS bringen willst, dann freunde dich damit an, dass es nicht schnell geht. Es hilft eigentlich nur die Daten auf einen Stick oder ne Festplatte zu kopieren und dann per USB3.0+ ans NAS zu klemmen. Und selbst dann solltest du die Daten am NAS schon in kleine Portionen aka Ordner verpacken, damit das Laden der Vorschaubilder nicht Ewigkeiten dauert.
 

Er404

Schraubenverwechsler(in)
MoinMoin,
bin neu hier im Forum und würde gerne diesen Thread wiederbeleben. Auch ich hab eine WD MyCloud und versuche seit letztem Wochenende (nun schon 5 Tage) eine Sicherung da drauf zu schieben. Das erste Problem hatte ich letztes Wochenende gelöst, indem ich das SMB1 Protokoll unter Win10 wieder aktiviert habe. Seither ist zumindest das NAS wieder im Netzwerk sichtbar und die einzelnen Ordner als Laufwerke auswählbar. Soweit so gut, nun wollte ich ein BackUp aller Daten machen, und dafür drei Ordner einfach auf das NAS kopieren. Beim ersten hat das noch gut funktioniert, aber nun beim zweiten ist die Übertragungsgeschwindigkeit nahe 0. Und das meine ich ernst, die Übertragungsgeschwindigkeit sinkt immer wieder auf 0kBit/s ab, dann bleibt das so für 10-15sek, dann geht´s in kurzen Schritten wieder hoch auf max 1-3MBit/s und innerhalb ~ 5sek wieder runter auf 0kBit/s. Ich bin wirklich geduldig, brauche da keine 100MBit/s und will auch keinen neuen Übertragungsrekord aufbauen, aber so geht das nicht. Da warten noch über 250GB im dritten Ordner und die restlichen 8GB im Zweiten haben in den letzten 3 Tagen einen Sprung von 86% auf 87% geschafft. Gut gestern den Tag über hab ich die Übertragung mal pausiert, dachte vielleicht braucht irgendeine Komponente Ruhe und ist zu warm, aber nach Einschalten Abends und den Stand ablesen heute morgen, hat das rein gar nix gebracht.

Mein PC:
Prozessor: AMD Ryzen 5 3600X
Arbeitsspeicher: G.Skill RipJaws V DIMM Kit 32GB, DDR4-3200, CL16-18-18-38 (F4-3200C16D-32GVK)
Grafikkarte: Gigabyte GeForce GTX 670 OC, 2GB GDDR5, 2x DVI, HDMI, DP (GV-N670OC-2GD), auch wenn die wahrscheinlich am wenigsten dafür kann... ;-)
Motherboard: MSI X570-A Pro (7C37-003R)
Systemfestplatte (für Win10): Samsung SSD 850 EVO 250GB, SATA (MZ-75E250B)
Datenfestplatte (hier liegen auch die zu kopierenden Daten): Seagate Baracuda 2TB, ST2000DL003
Jetzt kein Höllengerät, sollte doch aber hier wirklich nicht der limitierende Faktor sein...

Verbindung zur NAS über LAN und einen Telekom Speedport W 724V TypA dazwischen.

NAS ist eine WD MYCloudMirror Gen2 mit 2x 3TB.
Die beiden Platten habe ich in einen Raid1 Verbund konfiguriert.
Den DLNA Server, iTunes hab ich deaktiviert, ebenso wie Elephant Drive und Amazon S3.

Warum (zum Henker) ist das bei mir soooooo langsam?
These 1: Der Raid1 Verbund hat nach dem ersten Ordner angefangen zu arbeiten und kopiert nun munter die Daten in der NAS von Platte 1 auf 2, ist damit fast ausgelastet und lässt kaum neue Daten zu.
These 2: Mein Speedportrouter ist für solche Datenmengen auf einmal nicht gemacht und benötigt eine Pause.
These 3: Ich bin kein IT-Profi und sollte die Finger von Dingen wie NAS lassen... :-(

Ich meine das war bei den letzten BackUps auch der Fall, nur nicht so extrem. Gut seither sind eben auch wieder einige GB Daten mehr aufgelaufen die nun kopiert werden sollen.
In der Hoffnung alle relevanten Informationen gegeben zu haben, bitte helft mir. Wenn ich einen wichtigen Teil unterschlagen habe, bitte fragt.
Ich mach das BackUp nicht aus Spaß, sondern weil ich ein Win10 neu aufsetzen, und kein Risiko eingehen wollte.
 

fotoman

Volt-Modder(in)
Zu These1: RAID 1 spiegelt sofort
Ich habe aber keine Ahnung, mit welcher Geschwindigkeit der WD MYCloud Mirror Gen 2 dies macht aber öfters sind solche Fertig-NAS mit RAID1 langsamer wie ohne RAID.

Ich rate jetzt einfach mal ins Blaue, dass Du mit dem Windows Explorer kopierst und dann noch Ordner, die viele kleine Dateien enthalten. Das "mag" weder Windows noch SMB, womit auch eine lokale Kopieraktion extrem langsam wäre.

Dann schreibst Du noch etwas von "Amazon S3" (u.U. liest das NAS auch noch parallel die Daten und schickt sie in die Cloud?). Genauso der DLNA Server, wenn der aktiv genutzt wird, liest er halt auch wieder Daten von den Platten. Mit Pech ist er sogar so konfiguriert, dass er alle neu geschreibenne Dateien erst einmal analysiert und u.U. katalogisiert.

Zusätzlich lese ich dort "sind eben auch wieder einige GB Daten mehr aufgelaufen", was die Quellplatte auch nicht so locker sieht, wenn parallel gelesen und geschrieben wird.

Das einzige, was mir einfallen würde, wäre die Nutzung eines anderen Kopiertools. Egal ob Robocopy auf der Kommandozeile oder irgnedeine GUI, die effektiver kopiert.

Ich meine das war bei den letzten BackUps auch der Fall, nur nicht so extrem.
Mit etwas Pech sind im NAS die "falschen" Platten verbaut (SMR-Platten), die bei höhererm Füllgrad langsam werden können.

Falls dort WD Red verbaut sind
https://www.westerndigital.com/products/internal-drives/wd-red-hdd
musst Du wohl damit leben. Und nein, ich weiss nicht, was WD dort verbaut oder wie man mit dem WD die Plattentypen ohne Ausbau ermittelt.
 

Er404

Schraubenverwechsler(in)
Ich rate jetzt einfach mal ins Blaue, dass Du mit dem Windows Explorer kopierst und dann noch Ordner, die viele kleine Dateien enthalten. Das "mag" weder Windows noch SMB, womit auch eine lokale Kopieraktion extrem langsam wäre.
Das ist korrekt, einfach Ordner anklicken, "STRG+C" und aufm dem NAS einen Ordner mit aktuellem Datum erstellt, reingegklickt und "STRG+V".

Dann schreibst Du noch etwas von "Amazon S3" (u.U. liest das NAS auch noch parallel die Daten und schickt sie in die Cloud?). Genauso der DLNA Server, wenn der aktiv genutzt wird, liest er halt auch wieder Daten von den Platten. Mit Pech ist er sogar so konfiguriert, dass er alle neu geschreibenne Dateien erst einmal analysiert und u.U. katalogisiert.
Diese Funktionen sind alle deaktiviert, wie geschrieben, daher denke ich nicht, dass sie einen negativen Einfluss haben.

Zusätzlich lese ich dort "sind eben auch wieder einige GB Daten mehr aufgelaufen", was die Quellplatte auch nicht so locker sieht, wenn parallel gelesen und geschrieben wird.
Wieso wird auf der Quellplatte geschrieben? Also kopiert hab ich nur in Richtung NAS, also sollte auf der Quellplatte keine parallele Schreibaktion stattfinden.

Das einzige, was mir einfallen würde, wäre die Nutzung eines anderen Kopiertools. Egal ob Robocopy auf der Kommandozeile oder irgnedeine GUI, die effektiver kopiert.
Mit etwas Pech sind im NAS die "falschen" Platten verbaut (SMR-Platten), die bei höhererm Füllgrad langsam werden können.
Falls dort WD Red verbaut sind
https://www.westerndigital.com/products/internal-drives/wd-red-hdd
musst Du wohl damit leben. Und nein, ich weiss nicht, was WD dort verbaut oder wie man mit dem WD die Plattentypen ohne Ausbau ermittelt.
Ok, die tools muss ich mir mal anschauen, Danke! Ich kann leider nicht direkt sagen, was da drin steckt, ich kann den Deckel vom NAS aufmachen, da konnte ich irgend eine Buchstaben-Zahlen-Kombination erkennen, googeln brachte hier keine Ergebnisse. Ich müsste so ne Platte mal rausziehen, das möchte ich aber gerade nicht machen. Da das NAS als RAID1 läuft, hab ich natürlich nur 3TB zu Verfügung, und davon sind noch 1,7TB frei, sollte also noch kein "hoher Füllgrad sein".
 

fotoman

Volt-Modder(in)
Wieso wird auf der Quellplatte geschrieben? Also kopiert hab ich nur in Richtung NAS, also sollte auf der Quellplatte keine parallele Schreibaktion stattfinden.
Ich hatte das mit dem "Aufgelaufen" so verstanden, dass im Quellverzeichnis weitere 8 GB hinzugekommen sind, während die langsame Kopieraktion stattfindet.

hab ich natürlich nur 3TB zu Verfügung, und davon sind noch 1,7TB frei, sollte also noch kein "hoher Füllgrad sein".
Sollte nicht, wie WD die Daten dabei auf der Platte verteilt, weiss außer WD aber keiner. Bis vor ca. 2 Wochen hat WD noch nicht einmal zugegeben, dass sie diese Technik bei einingen Platten verwenden.

Entweder gibt Dir die Weboberfläche des NAS die Bezeichnung der HDDs aus (mein altes QNap hat das getan) oder Du musst es ausschalten und die Platten ausbauen.

Ich hatte hier schon ähnlich inperformante Kopieraktionen von Windows auf meinen Linux-Server. Mit 20.000 Einzeldateien (je 30-40 KByte) komme ich dort auf 3-5 MByte/s. Kopiere ich mit Robocopy und 8 parallelen Threads (Option /MT:8), erreiche ich fast die zehnfache Geschwindgkeit, also immerhin 40-50 MB/s. Ziel ist dabei eine einzelne HDD, die Netzwerkverbindung ein 1 GBit-Lan. Große Dateien werden mit 110-113 MB/s kopiert.
 

Er404

Schraubenverwechsler(in)
Nene, das mach ich dann doch nicht, mehr Daten auf ein Laufwerk werfen, was gerade kopiert wird.
Ich hab mir mal das robocopy auf chip.de angeschaut, das ist von 2007 und für Vista gemacht. Mag mit Win10 immer noch funktionieren, sehr vertrauenserweckend finde ich das aber nicht. Die angezeigten Alternativen haben mich auch nicht direkt überzeugt.

Inzwischen ist mein BackUp auch vollendet. Ich glaub eine Sache hatte einen großen Einfluss. Und zwar hatte ich einen Ordner kopiert, der Vorgang war irgendwo bei 85% oder so und es was spät Abends, damit der PC auch sicher die ganze Nacht was zu tun hat, dachte ich es wäre gut gleich mal noch den nächsten Ordner zu kopieren. Zwei parallele Kopierfunktionen sind nicht so gut, weiß ich schon, dachte aber der erste Vorgang ist ja gleich fertig, kein Problem. Fakt war nun aber, dass am nächsten Morgen keiner von beiden Vorgängen merklich weiter gekommen war. Deswegen hatte ich den Zweiten wieder pausiert, nicht unterbrochen, mit dem Effekt, das der Erste nach wie vor kaum weiter gekommen ist und ich dann nach 3 Tagen hier geschrieben hab. Ich war irgendwie davon ausgegangen, dass ein pausierter Prozess ja keine Ressourcen mehr blockieren sollte. Nun, nachdem mit viel Geduld der Erste nun wirklich irgendwann beendet war, hab ich den Zweiten wieder gestartet, und siehe da, die Kopierfunktion ist gleich mal wieder auf mehrere MB hoch (teilweise bis 14 oder 16 MB/s). Ich weiß es ja nicht genau, aber für mich sieht es so aus, als hätte der zweite Vorgang die ganze Zeit erhebliche Resourcen blockiert, kaum konnte sich der PC wieder explizit auf einer Kopiervorgang "konzentrieren" war die Datenrate auch wieder ok und das bei über 250GB...
 
Oben Unten