• Hallo Gast, du kaufst gerne günstig ein und erfährst oft vor deinen Freunden von interessanten Angeboten? Dann kannst du dein Talent als Schnäppchenjäger jetzt zu Geld machen und anderen PCGH-Lesern beim Sparen helfen! Schau einfach mal rein - beim Test der Community Deals!

Kurze Freezes bei geringer Last, Ryzen 3000, X570 Aorus Master, Windows 10 Pro

Psylor

Schraubenverwechsler(in)
Hi!

Ich hab da mal was Feines für euch. Der nächste Streich im Ryzen 3000, X570, Windows 10, Gigabyte (?)-Kuriositätenkabinett...


Specs
Gigabyte X570 Aorus Master (F20a aktuell)
AMD Ryzen 3600X
Corsair Dominator Platinum DDR4 3200 (32 GB Dualkit)
Samsung 970 Evo Plus 1 TB
Sapphire Radeon RX 480 Nitro+
Corsair RM 650X 650 Watt
Custom Wakü (nur CPU bisher)
Windows 10 Pro
BIOS-Settings: Alles auf Auto/Default, kein OC oder Sonstiges, nur Lüfterkurven angepasst.


Symptomatik
Ziemlich genau seit dem ersten Juniwochenende fing es an mit den kurzen (< 1 s) freezes an. Man bemerkt sie besonders gut, wenn man ein Spiel am Laufen hat oder in Windows irgendwas mit Soundausgabe, da diese freezes dann mit einem schönen prägnanten "BRRRRRZ"-Soundbug einhergehen. Diese freezes treten dabei völlig zufällig auf und lassen sich nicht zuverlässig auslösen.

Es treten während der kurzen freezes weder CPU-Lastspikes (auch nicht auf einzelnen Threads) noch RAM-, LAN-, SSD- oder GPU-Lastspikes auf.


TLTR
Kurz vor weg, was ich herausgefunden habe und meine bisher einzige Lösung mit der sich diese Nervigkeit zuverlässig zu 100% beheben lässt ist die CPU einigermaßen unter Last zu setzen, z.B. mit prime95 im Hintergrund. Verrückt.


Details
Der Rechner stand die erste Juniwoche unbenutzt rum. Der Grund dafür ist exakt dieser nervige (Hardware-)Bug, den auch der folgende User hier hat und der bei mir so ca. ein mal im Monat auftritt:
X570 Aorus Master PC geht nichtmehr an!
Das ist aber eine andere (Gigabyte-)Baustelle. Am darauffolgenden Wochenende hatte ich dann Zeit und Muse mich drum zu kümmern und habe den Rechner erneut wiederbelebt.

Kurz zur Klarstellung, diese freezes gab es zuvor nicht, der Rechner lief einwandfrei, soweit halt.
Nach dieser einen Woche Ruhezeit gab es direkt ein paar Updates. Soweit ich mich erinnere waren es allerdings nur Windowsupdates und die Corsair ICUE-Software. Sonst werkelt auf der Maschine auch nix an weiterem Gedöns im Hintergrund rum.


Bisher getroffene Maßnahmen
- Brandaktuelle AMD Chipsatztreiber installiert
- Innerhalb weniger Tage wurden gleich zwei neue BIOS-Versionen releast. Draufgeflashed, seitdem läuft nun auch endlich der RAM mit den angedachten 3200 MHz, sogar einfach über XMP: Yayyy und Wow! Aber gut.
- AMD GPU Treiberupdates angeworfen und installiert.

Mir ist irgendwann aufgefallen, dass einige zuvor installierte Treiber (LAN, NVME, Sound,) scheinbar durch MS-Versionen mit 2015er (!!!)-Datum ersetzt wurden... Wieso, warum, weshalb und warum bitte passiert sowas einfach so? Nun, ich habe diese Treiber daraufhin wieder durch die aktuellen Versionen ersetzt. Diese Sache hat meine Aufmerksamkeit auf die Windowsupdates gelenkt. Es gibt scheinbar Probleme mit einem der neueren Updates (KB4556799), das zumindest auch zu Soundbugs führen kann. Deinstallieren ließen sich zwar diverse andere Updates, nur leider ausgerechnet dieses nicht. In der leider vergeblichen Hoffnung, dass es hilft habe ich letztendlich ein Update auf Windows 10 2004 durchgeführt (von zuvor 1909).


Fazit
- absolut aktuelles Windows 10 2004
- Chipsatz-, GPU-, und sonstige Treiber aktuell
- neustes BIOS

=> Symptomatik gleichbleibend, gefühlt vielleicht sogar etwas verschlimmert.

Was nun?
 

Shinna

Software-Overclocker(in)
Hast Du nur die eine SSD oder kannst Du ggf. eine andere zum testen verwenden? Dann würde ich einfach einen Win10 Bootstick erstellen. Die SSD abklemmen und den PC vom Netzwerk trennen. Dann kann im Zuge der Installation nichts aus dem Internet gezogen werden. Dann halt sukzessive die Updates installieren. Das fragliche Update aus dem May dann eben auslassen und schauen ob das wirklich die Ursache ist.
 

blue_focus

Freizeitschrauber(in)
Hast du zufällig auf den neuen 2004er Build von Win10 upgegraded?

Alte Energiesparpläne mich hier gerne genau diese Probleme. Da hier massiv am CPU Scheduler geschraubt wurde.

Gesendet von meinem P20 Pro mit Tapatalk
 

micha30111

Freizeitschrauber(in)
Ich habe nach dem Update ähnliche Herausforderungen. Ganz kurze Freezez hauptsächlich wenn ich YT Videos schaue oder mit Reaper Audio aufnehme. Hatte mir vorgenommen jetzt Anfang Juli neu zu installieren. Vielleicht sollte ich dann versuchen einfach das große Mai Update wieder zu verabschieden...

Gesendet von meinem Mi Note 10 Pro mit Tapatalk
 

blue_focus

Freizeitschrauber(in)
Versucht einfach mal andere Energiesparpläne. Im Zweifle mal "Höchstleistung" zum Testen. Ich musste meinen selbst kreierten auch umbauen, da gewisse Settings, die im 1909er noch gut waren nun offenbar im 2004er dazu führen, dass die CPU entweder viel zu schnell wieder runtertaktet, oder andersrum einfach nicht in die Puschen kommt. Das passiert im Speziellen, wenn fast keine Last am System ist. Die CPU taktet dann einfach nicht hoch genug, wenn ein gewisser Mindestschwellwert an CPU-Last nicht überschritten wird. Hatte ich hier ganz genau so wie vom TE beschrieben.

Versucht mal den aktuellen AMD-Chipsetdriver zu installieren und und dann die mitgelieferten Ryzenpläne durchzuprobieren. Ich hab mit denen jetzt unter 2004 noch keine Erfahrungen, da ich sowieso meine eigenen Pläne verwende. Daher kann ich nicht sagen ob die aktuellen Ryzen-Pläne was taugen, oder nicht.
 
TE
P

Psylor

Schraubenverwechsler(in)
Hast Du nur die eine SSD oder kannst Du ggf. eine andere zum testen verwenden? Dann würde ich einfach einen Win10 Bootstick erstellen. Die SSD abklemmen und den PC vom Netzwerk trennen. Dann kann im Zuge der Installation nichts aus dem Internet gezogen werden. Dann halt sukzessive die Updates installieren. Das fragliche Update aus dem May dann eben auslassen und schauen ob das wirklich die Ursache ist.

Das wäre eine Idee, mal mit einem "ToGo"-System bzw. einem System über einen bootfähigen USB-Stick zu testen, ob die freezes damit auch auftreten. Oder deine Neuinstallationsmethode, aber leider habe ich nur die eine SSD.


Hast du zufällig auf den neuen 2004er Build von Win10 upgegraded?

Alte Energiesparpläne mich hier gerne genau diese Probleme. Da hier massiv am CPU Scheduler geschraubt wurde.

Gesendet von meinem P20 Pro mit Tapatalk

Nein, die freezes traten mit dem 1909er-Build schon auf. Auf den 2004er-Build habe ich nur geupgraded, weil mir keine andere Lösung mehr einfiel und ich gehofft hatte, dass er mit den aktuellen Treibern und BIOS vielleicht wieder harmoniert.


Versucht einfach mal andere Energiesparpläne. Im Zweifle mal "Höchstleistung" zum Testen. Ich musste meinen selbst kreierten auch umbauen, da gewisse Settings, die im 1909er noch gut waren nun offenbar im 2004er dazu führen, dass die CPU entweder viel zu schnell wieder runtertaktet, oder andersrum einfach nicht in die Puschen kommt. Das passiert im Speziellen, wenn fast keine Last am System ist. Die CPU taktet dann einfach nicht hoch genug, wenn ein gewisser Mindestschwellwert an CPU-Last nicht überschritten wird. Hatte ich hier ganz genau so wie vom TE beschrieben.

Versucht mal den aktuellen AMD-Chipsetdriver zu installieren und und dann die mitgelieferten Ryzenpläne durchzuprobieren. Ich hab mit denen jetzt unter 2004 noch keine Erfahrungen, da ich sowieso meine eigenen Pläne verwende. Daher kann ich nicht sagen ob die aktuellen Ryzen-Pläne was taugen, oder nicht.

Die Energiesparpläne hatte ich mir auch bereits vorgenommen. Hab es vergessen zu erwähnen. Das System lief immer auf dem Ryzen Balanced Plan ohne Probleme. Höchstleistung habe ich probiert sowie auch einfach mal die max. Prozessorleistung auf 50 % gesenkt. Letzteres hat gefühlt zu etwas weniger freezes in Windows geführt. Die Taktrate (laut Taskmanager) sank dann auch auf 2,2 GHz in Windows, jedoch, als ich ein Game (Satisfactory) gestartet habe hat die Kiste wieder auf 4,2 bis 4,4 GHz fröhlich hochgeboosted ohne das sich was geändert hätte.

Diese Energiesparpläne sind auch so ein Kuriosum, zumindest mit Ryzen.


Gamemode an/aus habe ich auch probiert, XBox-Gedöns habe ich bereits recht früh schon deaktiviert und teils deinstalliert, div. overlays (scheint ja in Mode gekommen zu sein das Zeugs, alles mögliche hat ja jetzt ein overlay) habe ich deaktiviert. Hat alles keine Auswirkungen gezeigt.
 
TE
P

Psylor

Schraubenverwechsler(in)
Ein kurzes Update:

Ich habe mal den Ryzen Master zu Rate gezogen. Da zeigt sich ein völlig anderes Bild als im Taskmanager. Mit dem Ryzen Balanced Powerplan zeigt der Taskmanager im Idle (nur mit ein bissel Musik im Hintergrund) Taktraten von 4,0x GHz an während im Ryzen Master die Kerne zwischen 500 und 900 MHz rumdümpeln. Während ein freeze auftritt sieht man mit dem Ryzen Master über das Histogramm sehr deutlich, dass es dabei leichte und kurze Boostspitzen gibt. Über den Taskmanager war das nicht auszumachen, allerdings gibt es auch keine wirklich signifikanten Auslastungsspitzen. Die "Antimalware Service Executable" hatte ein Problem mit Logitech und tauchte während der kurzen Hänger immer wieder in der Pozessansicht auf, aber auch nur mit einer Auslastung von 2 % die Ecke, soweit ich mich erinnere. Die freezes blieben jedoch und weitere Prozesse konnte ich auch nicht ausfindig machen, die was damit zu tun haben könnten.

Ich habe mich nochmal mit den Energiesparplänen beschäftigt. Es ist so, dass bei bzw. über diese Pläne deutlich mehr unter der Oberfläche geschieht als man in den Einstellungen sieht. Insbesondere wird auch das Boost- und Ansprechverhalten der Kerne darüber gesteuert. Das war mir so nicht bewusst. Ich vermute, dass sich irgendwas mit einem der neueren Windowsupdates (ab Mai) geändert hat, so dass die Ryzen Energiesparpläne nicht mehr funktionieren bzw. jetzt Probleme verursachen (zumindest bei mir).

Ich habe jetzt auf den windowseigenen Energiesparmodus-Plan gewechselt, dort USB- und PCI-E Energiesparen deaktiviert und es scheint so, als hätten sich die Hänger damit erledigt.
Performanceeinbußen habe ich jetzt noch nicht wahrgenommen, auch läuft Satisfactory wie zuvor gewohnt, nur halt ohne diese Hänger. Gleiches gilt für Mass Effect 3, wobei laut Ryzen Master sich dabei teils alle Kerne des zweiten CCX in den Ruhezustand versetzen und die CPU nur 7 bis 8 Watt verbraucht. Tut den FPS keinen Abbruch, glaube das Spiel hat eh ein cap bei 60.
 
TE
P

Psylor

Schraubenverwechsler(in)
Update:

Der Hauptunterschied beim Energiesparmodus-Plan gegenüber den anderen Plänen liegt in einem deutlich langsamerem Boostverhalten, geringeren Maximaltaktraten und deutlich geringeren Kernspannungen. Über den Ryzen Master kann man das sehr gut bei Cinebench-Runs beobachten. Ich denke hier liegt der Hund begraben, der Rechner kommt scheinbar mit sich schnell aufbauenden Taktraten nicht mehr klar.

Die Performanceeinbußen bei Benutzung des Energiesparmodus-Plans sind leider doch signifikant.

Ich habe alle windowseigene Pläne sowie die beiden Ryzenpläne und sogar die 1usmus-Custom Power Pläne mit Cinebench R15 (geht schneller als R20) getestet. Die besten Ergebnisse gab es mit dem Windows-Ausgeglichen- sowie dem 1usmus universal-Plan, aber wirklich viel Unterschied geben sich die Pläne alle nicht, mit Ausnahme des Energiesparmodus-Plans. An mein früheres Ergebnis (als der Rechner noch keine Probleme hatte) von 1597 Punkten kam ich nicht mehr ganz heran, allerbestes Ergebnis jetzt waren 1583 Punkte. Könnte an der um 2-3 °C gestiegenen Raumtemperatur liegen oder dass nebenbei der Ryzen Master offen war. Aber gut, alles soweit im Rahmen denke ich.


Die Werte dabei, frei abgelesen vom Ryzen Master, sind:

Multicore:
Kerntaktraten: 4130 MHz (sehr stabil, +- 4 MHz)
Kernspitzenspannungen: 1,39 V
Temperatur: 67,x °C

Singlecore:
Kerntaktraten: bis 4358 MHz (stark schwankend)
Kernspitzenspannungen: 1,4566 V
Temperatur: 53,x °C

Beim Singlecore-Benchmark fällt auf, dass nicht nur ein Kern boostet sondern zwei wild abwechselnd. Wenn der eine Kern die Taktrate erhöht sinkt zeitgleich die Taktrate des anderen Kerns und umgekehrt. Es handelt sich dabei zumindest nur um den besten und zweitbesten Kern im ersten CCX.


Ich habe auch die für den 1usmus-Plan empfohlenen BIOS-Einstellungen aktiviert:

Global C-state Control = Enabled
Power Supply Idle Control = Low Current Idle
CPPC = Enabled
CPPC Preferred Cores = Enabled
AMD Cool'n'Quiet = Enabled
PPC Adjustment = PState 0

Weder diese Einstellungen noch XMP an/aus halfen.


Es bleibt bei den kurzen Hängern wenn ich nicht den Energiesparmodus-Plan nutze. Das ist schon richtig suboptimal, um es freundlich auszudrücken!
Was läuft falsch mit dem Rechner? Ist die CPU irgendwie plötzlich hinüber, das Board oder verzapft Windows irgendeinen Mist?
 
TE
P

Psylor

Schraubenverwechsler(in)
Update:

Nachdem mein Gigabyte X570 Aorus Master sich kürzlich mal wieder tot gestellt hat, habe ich das neuste BIOS draufgeflashed. Mit F30 lief es gut drei Monate, nun hat es F33a mit AGESA ComboV2 1.2.0.0.

Kaum zu glauben, aber mit dieser neuen BIOS-Version ist nun die hier angesprochene Problematik wie von Zauberhand verschwunden! Direkt mit default BIOS-settings und den Standardenergiesparplänen oder den Ryzen-Plänen funzt der Rechner nun wie er sollte. Es gibt keine freezes mehr bei geringen oder leichten, inkonsistenten Lastszenarien!

Es wurde mit AGESA ComboV2 1.2.0.0 wohl etwas an der Spannungsregulierung optimiert, was genau, kann ich nicht sagen. Die Spannungen sehen auf den ersten Blick aus wie gehabt bzw wie weiter oben angegeben, allerdings habe ich auch keine detaillierten logs.

Ich habe auch ein paar Cinebench R20-Runs gemacht. Alles default stocksettings, 3600X, RAM @3200, Ryzen High Perfomance Plan:

Früherer Wert, mit F20 oder um die Zeit: 3543
F33a: 3702

Die Raumtemperatur ist aktuell vermutlich 3 oder 4 Grad niedriger als sie beim früher erzielten Wert war, aber ich denke, es sieht trotzdem ganz ordentlich aus. Der Singlecore-Score hat sich nicht großartig verändert, er ist von 501 auf 506 gestiegen.

Soweit, so gut! Endlich!
 
Oben Unten