AMD Ryzen Übertaktung deaktivieren

HoRyzen

Schraubenverwechsler(in)
Hallo PCGH-Forum,

ich habe folgendes Problem:
Wenn ich GTA V starte, dann rauschen nach einigen Minuten meine FPS von 90 auf 13-20 FPS runter und das ganze Spiel laggt.
Lüfter drehen hoch, Laptop wird heiß. GTA wird unspielbar weil das ganze Laptop einfach hängt und langsam wird.

Mein System:
Laptop: Lenovo IdeaPad 5 Pro von 2021
CPU: AMD Ryzen 7 5800U @1,90 GHz
Grafik: Geforce MX450
RAM: 16 GB
OS: Windows 11

Bisherige Schritte:
Habe mich jetzt durch das Forum und diverse andere Seiten gelesen und folgendes "analysiert" und probiert, um das Problem einzugrenzen:
1. MSI Afterburner installiert und diverse Werte zur GPU und CPU als On-Screen-Display beim Spielen anzeigen lassen (Taktfrequenz, Auslastung und Temperatur). Ich dachte nämlich die Grafik wäre das Problem.

2. Tatäschlich habe ich aber gesehen, dass die CPU mit eine Frequenz von 3,3 GHz - 4,4 GHz durchgehend bei GTA V läuft (statt Basistakt von 1,9). In dieser Zeit habe ich noch 90 FPS.

3. Sobald der CPU aber nach einigen Minuten eine Temperatur von etwas über 90 Grad erreicht, wird die Taktfrequenz auf 0,4 GHz gedrosselt (ja, 400 MHz). Und hier beginnt das Laggen und die <20 FPS. Sobald der CPU sich auf etwa 70 Grad abgekühlt hat, schießt die Taktfrequenz wieder auf 4 GHz hoch und Kreislauf beginnt von vorn. Heißt für mich, CPU wird zu heiß und reguliert sich runter, was das Spielen dann unmöglich macht

4. In Windows bei den Energieoptionen habe ich die Prozessorenergieverwaltung auf 95% begrenzt, damit er nicht mehr übertaktet. Offenbar kann GTA das aber ignorieren >> Taktfrequenz beim Spielen immernoch 3-4 GHz
2023-06-09 23_38_07-Energieoptionen.png


5. Dann habe ich gelesen, dass es AMD PrecisionBoost gibt, den man im BIOS einstellen kann, bzw dass es allgemein im BIOS Möglichkeiten gibt, den "TurboBoost" zu deaktivieren und die CPU zu regulieren. Allerdings ist das Lenovo BIOS Menü so spärlich, dass es tatsächlich nicht eine einzige Option gibt, um irgendwas am CPU zu regulieren.

6. Dann bin ich auf das Tool "AMD RyzenMaster" gestoßen. Damit hat man scheinbar die Möglichkeit die CPUs bis ins kleinste Detail zu steuern. Top. Nur leider funktioniert die Software bei mir nicht. Angeblich wird mein CPU nicht unterstützt, obwohl ja 5. Generation....


2023-06-09 23_43_45-AMD Ryzen Master.png


Ich bin nun am Ende des Internets angelangt :D Ich weiß nicht mehr weiter.
Jemand eine Idee?

Beste Grüße!
 
Hört sich wie ein Fehler im BIOS an, wo die Begrenzungen nicht sauber greifen, neueste BIOS-Version installiert?

Wärmeleitpaste erneuern und FPS begrenzen sind vor allem bei mobilen Geräten keine schlechte Idee...
 
Magst mir mal die Lenovo Treiber Seite von dem Laptop verlinken? Ich glaub da fehlt was...
Du hast genau in dem Menü aus deinem Screenshot normal n Punkt mit Turbo Boost...
 
Probier mal den Energy Management, Chipsettreiber hast du drauf?

Ich hab n Think Pad mit 5700U, ich mach dir sonst nachher n Screenshot.

Und irgendein Ding auf der Lenovo Seite schaltet den Punkt frei...

Ich kenne das Problem, übrigens hast du dann auch deutlich mehr Akkulaufzeit beim zocken :daumen:
 

Anhänge

  • 111.png
    111.png
    109,6 KB · Aufrufe: 41
Zuletzt bearbeitet:
So, BIOS Update ist gemacht. Alles bleibt beim Alten.
Weiterhin keine Option im BIOS für Power Einstellungen.
Und weiterhin die gleichen Sachen zu sehen bei den Energieoptionen wie im Screenshot oben, also leider kein Punkt für TurboBoost etc.

Hm welchen Treiber genau meinst du? Den?
2023-06-10 00_28_56-laptops and netbooks __ 5 series __ ideapad 5 pro 14acn6 __ 82l7 __ 82l700...png
 
Hm was meinst du mit Chipsettreiber beim EnergyMgmt?
Du musst ein Energy Ding von der Lenovo Seite laden, damit schaltest du den zusätzlichen Punkt frei, siehe Screenshot oben.
Ich denke mal der hier, bin mir aber nicht mehr 100% sicher...


Der normale Chipsatztreiber ist drauf?
 
Besten Dank schonmal. Habe einmal den AMD Chipsatz installiert, und anschließend den EnergyMgmt Treiber.

Erstaunlicherweise habe ich immernoch keinen Leistungssteiergungsmodus in den Energieoptionen....sehr merkwürdig
 
Merkwürdig, ansonsten hau den mal über die Registry rein:
Eingebundener Inhalt
An dieser Stelle findest du externe Inhalte von Youtube. Zum Schutz deiner persönlichen Daten werden externe Einbindungen erst angezeigt, wenn du dies durch Klick auf "Alle externen Inhalte laden" bestätigst: Ich bin damit einverstanden, dass mir externe Inhalte angezeigt werden. Damit werden personenbezogene Daten an Drittplattformen übermittelt.
Für mehr Informationen besuche die Datenschutz-Seite.

(Hab ich damals auf nem Surface gemacht, lief auch.)
 
Sehr cool! Die Änderung im RegEdit vom YT Video hat funktioniert! Die Option ist aufgetaucht, TurboBoost ausgestellt, und CPU übertaktet nicht mehr. Bei GTA bleibt er auch bei konstant 1,8 GHz.

ABER: Die Temperatur steigt dennoch im Sekundentakt hoch bis zu 90 Grad und dann wird wieder auf 400 MHz gedrosselt. Hier mal ein kurzes Video

@spidermanx
Habe ich noch nicht gemacht. Aber habe auch dieses Spezialwerkzeug nicht für diese Laptopschrauben auf der Rückseite.
 
Und was passiert wenn du beim Zocken den maximalen Leistungszustand weiter heruntersetzt? Ich nehme mal an, da gibt es irgendeinen Punkt, an dem die Kühlung überfordert ist. Den gilt es auszuloten und dann in Prozent ein paar Punkte unterhalb diesem einzustellen.
 
Also habe jetzt über die Windows Energieoption die max. Leistung auf 80% runtergesetzt. Damit läuft der CPU laut Taskmanger auf ca. 1,46 GHz.

Interessanterweise scheint GTA das aber ignorieren zu können. Denn sobald ich GTA starte, läuft er wieder mit 100% Basistakt, also knapp 1,9 GHz. Wie kann das denn sein, hm
 
Die Temperatur steigt dennoch im Sekundentakt hoch bis zu 90 Grad und dann wird wieder auf 400 MHz gedrosselt.
Hast du mal über HWinfo64 die Leistungsaufnahme deines Prozessors geloggt während des Spielens?

Klingt insgesamt nach einem Problem mit der Kühlung. Bekommt der Laptop genug Luft, um die Komponenten zu kühlen?
 
Nee HWinfo noch nicht benutzt. Kann ich gleich mal machen.
Der Lüfter läuft ganz ordentlich und pustet kalte Luft raus. Bei dem Laptop sitzt der Lüfter rechts, da ist das Laptop auch bei Last recht kühl auf Zimmertemperatur. Auf der Linken Seite, wo kein Lüfter sitzt, wird es sehr heiß.

Habe eben auch noch einen Hardware Scan über die Lenovo Seite gemacht. Interessanterweise sagt er, er findet keinen Lüfter....
Screenshot 2023-06-10 111351.png
 
Hast du vielleicht einen Lüfter für die CPU und einen für die GPU? Dann könnte der von der CPU evtl kaputt sein und daher überhitzt die sofort, wenn Last anliegt.
 
**LÖSUNG für das GTA Problem**
Es löst zwar nicht das zwanghafte hochschrauben des CPU Taktes bei GTA und das Ignorieren der maximalen Leistung von Windows, aber zumindest habe ich endlich nach 2 Jahren die Lösung gefunden wie GTA nun flüssig läuft :bier:

1. Folgendes machen:
o TurboBoost wie von @eXquisite beschrieben deaktiveren, denke das ist der erste, wichtige Punkt

2. Dann in GTA in den Einstellungen selbst:
o Grafik >> Vsync auf Halb stellen (dadurch werden die FPS auf genau 30 FPS maximal festgelegt)
o Erweiterte Grafik >> Bildskalierungsmodus auf 4/5 oder besser 2/3 stellen

Dadurch bleibt meine CPU Temperatur jetzt konstant bei 64-69 Grad. Und es gibt daher auch keine Drosselung mehr.
Ein Träumchen. Diese Einstellungen sind offenbar CPU hungrig.


Für mich reicht das daher erstmal und einen riesen Dank an euch alle. Nur so konnten wir Schritt für Schritt Dinge ausschließen und insbesondere den TurboMode deaktivieren!


---



Hast du vielleicht einen Lüfter für die CPU und einen für die GPU? Dann könnte der von der CPU evtl kaputt sein und daher überhitzt die sofort, wenn Last anliegt.
Klingt zumindest einleuchtend.
Kann ich dir aber nicht beantworten. Laut einem YT Video zu meinem Laptop sieht es so von innen aus.
Ich sehe da nur einen Lüfter. Weiß aber nicht ob es noch verdeckte gibt?

Screenshot 2023-06-10 112333.png
 
Weiß aber nicht ob es noch verdeckte gibt?
Verdeckte Lüfter glaube ich eher nicht. Macht ja auch wenig Sinn, denn die müssen irgendwo ja Luft ansaugen.

Mein Laptop hat jedenfall zwei Lüfter. Ist allerdings auch ein IdeaPad Gaming 3 mit 15". Daher bin ich darauf gekommen. Hätte zum Problem gepasst.
 
Japp, der 16" hat auch 2 Lüfter. Habe den 14" und da ist dann wohl kein Platz mehr dafür.
Dennoch natürlich komisch, dass eine Seite so heiß wird und die andere nicht, ist sowas gewollt? Und das Lenovo sagt er findet meinen Lüfter nicht. Aber ich höre und spüre ja, dass er läuft
 
Die iGPU im Ryzen hebt die Temperatur ebenfalls an.

Den Ryzen begrenzen ist eine Sache, trotzdem sitzt ja die GPU auch mit auf dem Ding an dem "CPU" Lüfter.

Kannst du nicht sogar in besagtem Energiemenü mit dem AMD Power Slider unten Einfluss auf die GPU nehmen?
Das hab ich noch nie probiert... müsste aber klappen.

Bei mir ging es damals nur um CS-GO, das lief dann einwandfrei ohne Boost.
 
Zuletzt bearbeitet:
Zurück