• Hallo Gast, du kaufst gerne günstig ein und erfährst oft vor deinen Freunden von interessanten Angeboten? Dann kannst du dein Talent als Schnäppchenjäger jetzt zu Geld machen und anderen PCGH-Lesern beim Sparen helfen! Schau einfach mal rein - beim Test der Community Deals!

Webserver mit Windows. Wie das Optimum aus der Hardware holen?

GrandAdmiralThrawn

Kabelverknoter(in)
Also ich hab einen WAMPS Server, also Windows + Apache 2.2.4 + MySQL 5 + PHP 5.2.0 + OpenSSL 0.9.8 und dann noch das WebDAV Modul, übern Apachen werden mit HTTPS auch noch SubVersion Repositories bereitgestellt.

Was ich mir wünschen würde, wär ja:
1.) Perfekte Multithreadingoptimierungen (auch für zlib und SSL Libs?!)
2.) Schlichtweg mehr Speed auf alter Hardware (Quad PPRO)
3.) Einfache Migration von Apache zum neuen, schnelleren Webserver..

Wie gesagt, ich verwend ihn halt auf Windows, und irgendwie kommts mir so vor, als würd er die Maschine nicht schön ausreizen können.. OS ist Win2000 Server.

Edit: Tut mir leid, falls ich mit meiner Anfrage bez. des Servers auf Windows hier falsch bin, aber interessant wärs halt...
 

Anhänge

  • Ryzen_03.jpg
    Ryzen_03.jpg
    574,8 KB · Aufrufe: 5.563

Marbus16

Gesperrt
AW: Webserver mit Lighttpd aufsetzen

Mit Win2000 Server... Hast du mal die CPU-Auslastung angeguckt? Bei meinem Adv.Serv. liegt die mit 2 XEON II 450MHz bei durchgehend 50-70%... Nicht grad wenig, wie ich finde.
 
TE
GrandAdmiralThrawn

GrandAdmiralThrawn

Kabelverknoter(in)
AW: Webserver mit Lighttpd aufsetzen

Adv.Server... Hast du eine Domäne drauf rennen? Wenn ja, versteh ichs, ich hab mal eine hier eingerichtet, und die GANZ schnell wieder runtergerissen, das war eine schlechte Idee!

Aber wenn am Server nichts los ist, liegt die Last auch sehr niedrig, unter 10% irgendwo (pro CPU mein ich halt, nicht insgesamt).

Aber ich glaub dennoch, daß da mehr geht. Der Apache schaffts einfach nicht, alle vier CPUs auszulasten, wenn er Mal was anspruchsvolleres tun soll. Und die Last, die PHP verursacht, sollte ja zum Apache-Prozess zählen, oder? Ich habs ja als DLL eingebunden, da müßts ja ein Tochterprozess oder -thread(s) vom Apachen sein.
 

Marbus16

Gesperrt
Nö, des läuft/lief als reiner Surfrechner. Wollte damit mal ab und zu nen DHCP Server aufsetzen, wenn der Router wieder rumwürgt. Aber dazu kams bisher nicht, trotz dessen war am Desktop die CPU-Last bei 50-70%. Könnte die etwa vom onBoard-SCSI-controller rühren? Wobei ich da kein RAID fahre, dort sind nur am Kanal B 2 SCSI-HDDs angeschlossen sowie am Kanal C ein CD-ROM-LW. IDE ist komplett ungenutzt.

Würde aber gern den Server in ein normales Gehäuse verpflanzen. Jedoch fehlt mir dazu ein vernünftiges Netzteil mit einem 6pin AUX-Anschluss (womit ich evtl. auch die XEON III 700MHz ans Laufen bringen könnte...). Haste da wat auf Lager? ;)

Haste das Danke von Edith gehört, Falk? :)
 
Zuletzt bearbeitet:

Falk

Schon immer hier...
Habe mit mal erlaubt, den Thread in den Windows-Bereich zu verschieben - da passt ein WAMPS ja besser hin :)
 

|L1n3

Freizeitschrauber(in)
Wenn ich mich mal so hier reinschmeissen darf:
Wie bekommt man denn eine Subodmain erstellt bei einem Apache 2.2 ? (unter Windows)
 
Oben Unten