Systemfestplatte erscheint bei "Hardware sicher entfernen..." nach Treiberaktualisierung

mc-stylus

Komplett-PC-Käufer(in)
Hallo zusammen,

ich habe mir neulich mit dem Treibersuchprogramm "SlimDrivers" meine Treiber aktualisiert. Nachdem ich jedoch diese beiden:

Intel(R) 5 Series/3400 Series Chipset Family PCI Express Root Port 1 - 3B42
USB Universal Host Controllers

geladen und installiert habe, kam es nach dem Neustart zum Bluescreen. Da kurz vor dem Bluescreen was mit "AHCI" stand, dachte ich mir, dass ich mal den SATA-Controller auf IDE stelle.
Und siehe da, Windows konnte wieder laden. Nun habe ich noch in der Registry den Schlüssel "Start" unter "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci" von 3 auf 0 gesetzt.
Neustart --> alles super. Allerdings sehe ich plötzlich unten rechts in der Taskleiste das Symbol, welches das sichere Auswerfen von externen Speichermedien (USB-Sticks, externe HDD, etc) ermöglicht.
Hardware sicher entfernen und Medium auswerfen ... klicke ich darauf erscheint meine 1000GB große, interne Festplatte.

Ist das so normal? Oder was könnte hier die Ursache sein?

Betriebssystem ist Windows 7 SP1 64bit Home.
 
SATA ist grundsätzlich Hot-Plug fähig, das müssen nur BIOS und Treiber unterstützen. Anscheinend ist das bei dir nach dem Treiberwechsel der Fall und damit bekommst du die Option zum auswerfen.
 
Die Hot-Plug-Fähigkeit lässt sich normalerweise im UEFI gesondert für jeden SATA-Port ein- und ausschalten, wenn dich das stört.
 
Kommt immer auf das Board an. Mein B75 bietet das einzeln an. Mein H61 hat einen ASMedia für SATA3 mit dauerhaft aktiviertem Hotplug. Mein P43 bietet nur global An oder Aus. Geht es hier um das P55? Im Handbuch habe ich keine Option für Hotplug gefunden, das scheint automatisch zusammen mit AHCI aktiviert zu werden. Allerdings wundert mich dann, dass es Windows weiterhin anzeigt, obwohl du wieder auf IDE gestellt hast.
 
Ja, es geht um ein Gigabyte P55M UD2.
Ich hatte ja nur auf IDE gestellt, damit Windows überhaupt wieder starten konnte.
Ich vermute, dass durch die Treiberaktualisierung im BIOS der SATA -Controller auf AHCI gestellt wurde (geht das?). Da jedoch der oben genannte Schlüssel in der Registry noch auf "3" gestellt war, kam beim Booten der Bluescreen.
Windows hab ich dann wohl beim letzten Mal im IDE-Mode installiert.
Erst dann hab ich Auf IDE gestellt. Dann den Reg-Schlüssel auf "0" und anschließend im Bios den Controller wieder auf AHCI.
Naja jedenfalls funktioniert ja wieder alles, nur dass die HDD mit dem "sicher entfernen" Symbol erscheint irritiert mich wie gesagt etwas.

Hab im Geräte-Manager das hier gefunden...

Screen1.JPG

Kann ich hier den Haken bei "Entfernungsrichtlinie" gefahrlos nach oben setzen?
 
Damit machst du die Platte nur noch langsamer. Die Entfernungsrichtlinie erscheint nur bei Hotplug-Geräten, ansonsten erscheint nur der Schreibcache. Unabhängig davon wird das Symbol Hardware auswerfen trotzdem angezeigt.
 
Bei Windows 7 bietet Microsoft noch die Möglichkeit für den Standard-AHCI-Treiber die "Hardware sicher entfernen"-Anzeige für jeden einzelnen Port über Registry-Einträge zu konfigurieren (Anleitung 1; Anleitung 2). Ab Windows 8 ist das nicht mehr möglich.
 
Ok, danke für die Antworten. Stören tut es mich auch nicht wirklich.
Wenn ich mal Zeit und Lust hab werde ich mal Deine Anleitungen versuchen RealMadnex.
 
Oh, jetzt lerne ich was dazu... :-)
Die Platte ist am P55-Chipsatz angeschlossen. Ist der Intel oder?
Dass die SATA-Anschlüsse über verschiedene Controller gesteuert werden war mir bis jetzt noch gar nicht so bewusst.
Welche Auswirkungen oder welchen Sinn hat die Wahl des Controllers auf's System?
Das ist für mich noch Neuland.
 
Der SATA-Controller, den der Mainboard-Chipsatz eingebaut hat, ist bestmöglich angebunden. Kann bandbreitentechnisch also aus den Vollen schöpfen. Die Zusatz-Controller sind heutzutage über die PCIe-Schnittstelle angebunden. Abhängig von der Anzahl der verwendeten PCIe-Lanes (in der Regel eine oder maximal zwei) und der unterstützten PCIe-Version ist die für alle SATA-Ports des Zusatz-Controllers zur Verfügung stehende Bandbreite um ein vielfaches geringer.

Die PCIe-Schnittstellen des P55-Chipsatzs können in der Theorie maximal 250 MB/s pro Lane übertragen (in der Praxis bleibt davon nicht viel mehr als 200 MB/s übrig). Ist der Zusatz-Controller nur mit einer Lane angebunden (was bei Mainboards dieser Generation die Regel ist) und besitzt zwei oder mehr Ports müssen alle Laufwerke, die an diesem Controller angeschlossen sind, sich diese Bandbreite teilen. Der Gigabyte SATA2 Controller (ein umgelabelter JMicron-SATA-Controller) auf deinem Board ist zudem recht mies/lahm. Dort solltest du möglichst nur Datenlaufwerke anschließen, die du selten brauchst, oder diesen Controller ganz meiden. So lange du noch freie SATA-Ports des Intel P55-Chipdatzes hast, nutze sie, wenn du weitere Laufwerke anschließen möchtest.

Zusammengefasst kann man sagen, dass Zusatz-Controller nur weitere SATA-Ports zur Verfügung stellen, die man optional nutzen kann, wenn die Ports des nativen SATA-Controllers alle belegt sind.
 
Die Platte ist am P55-Chipsatz angeschlossen. Ist der Intel oder?

Ja.

Das gleiche "Problem" mit der Systemplatte (Hardware sicher entfernen...) hatte ich auch mal bei einem P45 Board. Wenn ich mich recht erinnere, war der Eintrag weg nachdem ich den Intel Rapid Storage installiert hatte (dadurch wird auch der microsofteigene AHCI Treiber "msahci.sys" durch den Intel AHCI Treiber Iastor.sys) ersetzt.

Bei Bedarf kannst du das ja mal bei dir testen (ansonsten bringt der Rapid Storage keine Vorteile).
 
@RealMadnex
Danke für die Erklärung.
Also ich hab`s so verstanden...der P55-Chipsatz (Intel) ist der langsamere und der Gigabyte-Chipsatz (Mainboard) der schnellere. Ist das so richtig? Dann sollte ich jetzt umstöpseln!?
Gibt es eigentlich ein Tool zum Ermitteln der Schreib- und Lesegeschwindigkeit von HDDs. Für SSDs gibt es ja dieses "AS SSD Benchmark".
Unten mal ein paar Auszüge aus dem UserGuide des MB.
Da gibt es
" SATA2_0/1/2/3/4 (SATA 3Gb/s-Anschlüsse, gesteuert durch den P55j/H55k-Chip-Satz) "
und
" GSATA2_0/1 (SATA-Anschlüsse mit 3GB/s, gesteuert vom GIGABYTE SATA2) "

GSATA ist dann das schnellere in dem Fall?

@Simpel1970
"Intel Rapid Storage" dürfte dann nur bei Verwendung des P55(Intel)-Chipsatzes nutzen oder?
Werd es aber mal versuchen bevor ich auf den Gigabyte-Chipsatz umstöpsle, ob das Icon verschwindet.
 

Anhänge

  • Snip2.JPG
    Snip2.JPG
    75,6 KB · Aufrufe: 626
  • Snip3.JPG
    Snip3.JPG
    72 KB · Aufrufe: 353
  • Snip4.JPG
    Snip4.JPG
    99,5 KB · Aufrufe: 257
  • Snip5.JPG
    Snip5.JPG
    73,1 KB · Aufrufe: 545
@RealMadnex
Danke für die Erklärung.
Also ich hab`s so verstanden...der P55-Chipsatz (Intel) ist der langsamere und der Gigabyte-Chipsatz (Mainboard) der schnellere. Ist das so richtig? Dann sollte ich jetzt umstöpseln!?
Gibt es eigentlich ein Tool zum Ermitteln der Schreib- und Lesegeschwindigkeit von HDDs. Für SSDs gibt es ja dieses "AS SSD Benchmark".
Unten mal ein paar Auszüge aus dem UserGuide des MB.
Da gibt es
" SATA2_0/1/2/3/4 (SATA 3Gb/s-Anschlüsse, gesteuert durch den P55j/H55k-Chip-Satz) "
und
" GSATA2_0/1 (SATA-Anschlüsse mit 3GB/s, gesteuert vom GIGABYTE SATA2) "

GSATA ist dann das schnellere in dem Fall?
Nein, genau andersherum. Der SATA-Controller des Intel P55-Chipsatzes ist der schnellere und der JMicron-SATA-Controller (vom Mainboard-Hersteller umbenannt zu Gigabyte SATA2) ist die Gurke. Wenn du deine Laufwerke momentan am Intel-SATA-Controller angeschlossen hast, lass es so.

Zum Testen der Lese-/Schreibleistung von HDDs kannst du beispielsweise CrystalDiskMark verwenden. Dieser Benchmark arbeitet, wie der AS-SSD-Benchmark, auf Dateisystemebene. Da Festplatten nicht überall gleich schnell sind, ist das Ergebnis allerdings abhängig davon, wo die Testdaten auf der Platte landen (was vor allem von der Partionsaufteilung, Partitionswahl und dem Füllstand abhängt) und wie fragmentiert sie abgelegt werden. Low-Level-Benchmarks, wie beispielsweise HD-Tune juckt das nicht, da sie an einer unteren Ebene (unterhalb des Dateisystems und der Partitionen) ansetzen und die Leseleistung der Festplatten vom ersten bis zum letzten Sektor häppchenweise ermitteln und graphisch darstellen. Ein Test der Schreibleistung ist bei solchen Low-Level-Benchmarks in der Regel standardmäßig deaktiviert oder nur bei der Kaufversion vorhanden, weil dabei die Festplatte vollständig gelöscht wird.

Ob die Installation des RST-Treibers das "Problem" löst, hängt davon ab, wie die SATA-Ports vom BIOS markiert werden. Ob als interne oder externe SATA-Ports. Bei neueren Mainboards kann man das einstellen. Bei älteren ist das fest vom Mainboard-Hersteller vergeben. Beim RST-Treiber musst du aber sehr auf die Version achten, die du installierst. Ältere Versionen unterstützen den für SSDs wichtigen Trim-Befehl noch nicht und auch keine Festplatten mit mehr als 2 TB. Manche RST-Versionen haben Bugs, die zum eine nervig und zum anderen datengefährdend sein können. Neuere Versionen unterstützten ab einer bestimmten Versionen diesen Chipsatz nicht mehr und lassen sich nicht installieren.

Der RST-Treiber hat nichts mit dem Gigabyte-SATA2-Controller zu tun. Diesen Controller würde ich dir aber auch nicht empfehlen zu nutzen.
 
Ich hab jetzt alles so gelassen wie es ist, HDD steckte eh schon am P55-Controller.
Und das "Hardware entfernen"-Icon...vielleicht verschwindet es ja unter Windows10...
Danke nochmal.
 
Zurück