Raid 0 auf Intel Onboard Controller langsamer?

Milak98

Schraubenverwechsler(in)
Hallo,

ich habe mir ein XMG Fusion 15 zugelegt und im Zuge dessen Windows neu aufgespielt. Ich habe mich nicht lumpen lassen und direkt ein Raid 0 eingerichtet.

Vorab, ja ein Raid 0 mit 2 NVMe SSDs. Und ja, ich weiß das es grundsätzlich unnötig ist, da ein merkbarer Performanceunterschied nahezu ausbleibt. Da ich auf dem Gerät aber ohnehin keine sensiblen Daten speichern werde, wollte ich das Performanceplus einfach mitnehmen. Zusätzlich hat es den netten Nebeneffekt das die 2 SSDs als ein Laufwerk zusammengefasst werden, was ja generell aber auch mit JBod möglich gewesen wäre.

Das Raid läuft wohl über einen Onboard Sata Controller. Der Treiber dazu ist "Chipset SATA/PCIe RST Premium Controller".

Trim ist aktiviert, Schreibcache ist aktiviert. Der Cachemodus im RST Menü ist auf "Write-Back".

Nach mehreren Diskmark Benchmarks stelle ich mit Schock fest: Die SSDs sind langsamer, als wenn ich sie einzeln betreiben würde :wall::lol: .

Liegt das ganze jetzt am Onboard Controller? Bremsen die Dinger das Raid so aus, dass die Platten langsamer sind als ohne?

Ach ja. Es handelt sich um 2x Samsung 970 Evo Plus 500Gb.

Ich wäre wirklich um Hilfe dankbar, da ich schon Stunden dran sitze und trotz aller Einstellungen das Ergebnis gleich bleibt. Zur Not löse ich den Verbund selbstverständlich auf. War mal ein kleines Experiment :).
 

massaker

Freizeitschrauber(in)
Ja, generell ist ein Raid0 mit NVMe-SSDs nicht wirklich sinnvoll. Aber was ist denn genauer unter "SSDs sind langsamer, als wenn ich sie einzeln betreiben würde" zu verstehen? Hast Du genaue Zahlen/Screenshots? Sequentiell sollte man natürlich was gewinnen, die wirklich wichtige Werte, also random4K/Latenzen können sich sogar verschlechtern. Je nach Aufgabe könnte so ein Raid-Verbund sicherlich seine Daseinsberechtigung haben, ist aber für einen typischen "Schraubenverwechsler" eher irrelevant.:-)
 

IICARUS

Kokü-Junkie (m/w)
Es kommt noch dazu, dass falls eine der zwei SSDs defekt geht, alle Daten verloren sind.
Denn beim Schreiben werden Daten willkürlich auf beide SSDs geschrieben.

Ansonsten sehe ich jetzt nicht unbedingt was, was dagegen sprechen würde, denn alles, was messbar ist, wird real nicht spürbar sein und wie schnell am Ende größere Datenmengen kopiert werden können, hängt auch immer von der Gegenstelle ab. Fürs speichern und Laden von Programmen wird man selbst kein Unterschied merken.
 
TE
TE
M

Milak98

Schraubenverwechsler(in)
Ich schicke mal einen screenshot rein :).
 

Anhänge

  • Unbenannt.PNG
    Unbenannt.PNG
    33,7 KB · Aufrufe: 25

TurricanVeteran

Volt-Modder(in)
Hallo,

ich habe mir ein XMG Fusion 15 zugelegt und im Zuge dessen Windows neu aufgespielt. Ich habe mich nicht lumpen lassen und direkt ein Raid 0 eingerichtet.
Läppi mit intel HM370 express-chipsatz und mobilem i I7-9750H? Ich denke der chipsatz wird den durchsatz nicht bringen und das raid produziert noch zusätzlich latenzen. Bei sata-platten macht sowas vieleicht noch sinn, aber nvme produziert ja so schon eine gewaltige datenmenge. Dazu werden die daten über den chipsatz müssen und ob der ausreichend breit am prozessor hängt... Ich weis nicht.
 
TE
TE
M

Milak98

Schraubenverwechsler(in)
Also die Schreibgeschwindigkeit ist sequenziell unterdurschschnittlich. Selbst wenn es kein Raid 0 wäre und die Platten einzeln betrieben werden. Die Lesegeschwindigkeit ist ungefähr auf Normalnieveau einer einzelnen Festplatte.
Läppi mit intel HM370 express-chipsatz und mobilem i I7-9750H? Ich denke der chipsatz wird den durchsatz nicht bringen und das raid produziert noch zusätzlich latenzen. Bei sata-platten macht sowas vieleicht noch sinn, aber nvme produziert ja so schon eine gewaltige datenmenge. Dazu werden die daten über den chipsatz müssen und ob der ausreichend breit am prozessor hängt... Ich weis nicht.
Ja habe mir schon gedacht, dass dieser Umstand das ganze ausbremst. Schade drum aber letzendlich auch irrelevant, da setz ich noch mal neu auf und richte JBod ein. ist wohl einiger der wenigen Fälle in dem ein JBod performanter läuft als ein Raid 0 :stupid:

Aber gerade die Schreibgeschwindigkeit finde ich schon beunruhigend lahm für ein Raid 0
 

TurricanVeteran

Volt-Modder(in)
Ja habe mir schon gedacht, dass dieser Umstand das ganze ausbremst. Schade drum aber letzendlich auch irrelevant, da setz ich noch mal neu auf und richte JBod ein. ist wohl einiger der wenigen Fälle in dem ein JBod performanter läuft als ein Raid 0 :stupid:
Wenn der controller jbod unterstützt. Hab auf der webseite von XMG nur raid 0 und 1 gefunden. Kann aber sein das der chipsatz auch jbod kann...
Aber gerade die Schreibgeschwindigkeit finde ich schon beunruhigend lahm für ein Raid 0
Das liegt eher an den ssd`s. Wenn ich mich recht entsinne gibt es erst ab 1TB größe die volle geschwindigkeit in beide richtungen. Die 500GB sind also schlicht zu klein gewählt.
 
TE
TE
M

Milak98

Schraubenverwechsler(in)
Das liegt eher an den ssd`s. Wenn ich mich recht entsinne gibt es erst ab 1TB größe die volle geschwindigkeit in beide richtungen. Die 500GB sind also schlicht zu klein gewählt.

Das Bild unten hab ich im Internet gefunden. Das ist die Leistung einer einzelnen 500Gb 970 Evo Plus.

Sowohl Schreib- als auch Lesegeschwindigkeit (sequenziell) sind schneller.

Denke das Problem muss dann am Chipsatz liegen oder?
Was willst Du denn erreichen?

Eine 980 Pro schreibt sicher solo schneller, als das 970er RAID 0.

Naja, es geht gar nicht so ums erreichen. Es geht eher um die Tatsache das ein eingerichtetes Raid 0 lahmer ist, als eine einzelne Platte im losen Verbund. Ich versuche nur zu erörtern woher das Problem kommt :-)
 

Anhänge

  • samsung_970plus_04_86D10A26D3C04182930A2C311A40FF10.jpg
    samsung_970plus_04_86D10A26D3C04182930A2C311A40FF10.jpg
    156 KB · Aufrufe: 16

TurricanVeteran

Volt-Modder(in)
Das Bild unten hab ich im Internet gefunden. Das ist die Leistung einer einzelnen 500Gb 970 Evo Plus.

Sowohl Schreib- als auch Lesegeschwindigkeit (sequenziell) sind schneller.
Das sind, in meinen augen, nur burst-datenraten und diese werden sich wohl im cache abspielen. Dazu haben größere modelle größere caches. Von daher sind die eher bedingt aussagekräftig für den normal-betrieb.
Meine these ist aber, das der chipsatz und dessen anbindung an die cpu der limitierende faktor ist. (der primäre M2-slot dürfte direkt an der cpu hängen, der zweite am chipsatz) Dazu kommen halt zusätzliche latenzen, da die daten erst wieder "zusammen gefügt" werden müssen
 
TE
TE
M

Milak98

Schraubenverwechsler(in)
Bei mir waren es die Treiber und verschiedene Programme, die gebremst haben.
An meinem NB mit 2,4 Ghz auf DDR3-1600Mhz mit zwei klassischen SSDs im
RAID0 erreiche ich die nachfolgenden Werte.
Ganz am Anfang hatte auch ich nur die für SSDs typischen Leistungen.
Hat allerdings Jahre gedauert, bis ich soweit wie jetzt war.
Beim TR lag es am BIOS und am Chipset-Treiber. Die normale NVMe-Geschwindigkeit
habe ich so erst letzten August 2021 mit Updates derer erreicht. Nach VIER Jahren !
Bis dahin hatte ich mit der 960 und 970 Pro nur ca. 1300 MB/sec. erreicht. Da war ich ja noch mit RAID-SSDs schneller.

Das ist ja mal interssant. Ich denke wenn dein älteres NB das schafft, dann das Fusion erst recht.

Jetzt bin ich wieder unzufrieden, ich hatte mich gerade damit abgefunden :lol:

Also mein chipsatztreiber ist der aktuelleste. Zumindest hab ich ihn direkt von der XMG Website. Allerdings ist der RSI Treiber vom mitgelieferten Stick und der ist von 2019. Mal sehen, ich werde mal ein update wagen und gucken wie sich das verhält.

Hast du besondere Einstellungen im Bios vorgenommen, welche ich beachten muss?


Edit: Ich sehe gerade, die von der Website sind auch von 2019. Intel bietet auf der Website einen aktuelleren. Ich geh das Risiko mal ein ;)
 

wuselsurfer

Kokü-Junkie (m/w)
Naja, es geht gar nicht so ums erreichen. Es geht eher um die Tatsache das ein eingerichtetes Raid 0 lahmer ist, als eine einzelne Platte im losen Verbund. Ich versuche nur zu erörtern woher das Problem kommt :-)
Dann muß man sich wohl mal etwas mit dem RAID 0 beschäftigen.
Der Controller zerhackt die Daten, um sie dann auf die angeschlossenen Platten zu verteilen und zu protokollieren:
https://de.wikipedia.org/wiki/RAID#/media/Datei:RAID_0.svg .

Das braucht Zeit.
Wenn die Zeit zum Zerhacken, Verteilen und Protokollieren länger ist, als nur die Dateien zu speichern auf einer Platte, dann ist das RAID eben langsamer, als eine einzelne Platte.

@ Elfenmounty aka instechio: die Spam-Meldung ist raus.
 
TE
TE
M

Milak98

Schraubenverwechsler(in)
Dann muß man sich wohl mal etwas mit dem RAID 0 beschäftigen.
Der Controller zerhackt die Daten, um sie dann auf die angeschlossenen Platten zu verteilen und zu protokollieren:
https://de.wikipedia.org/wiki/RAID#/media/Datei:RAID_0.svg .

Das braucht Zeit.
Wenn die Zeit zum Zerhacken, Verteilen und Protokollieren länger ist, als nur die Dateien zu speichern auf einer Platte, dann ist das RAID eben langsamer, als eine einzelne Platte.

@ Elfenmounty aka instechio: die Spam-Meldung ist raus.

Naja, es scheint ja bei anderen auch problemlos zu klappen. Ein Raid 0 sollte schon schneller sein als ne einzelne SSD
 
TE
TE
M

Milak98

Schraubenverwechsler(in)
Mit welcher Hardware?


Also hast Du anscheinend die Beiträge nicht gelesen und/oder die Erklärung nicht verstanden.
Wenn der Herr instechio solche abartigen Werte bekommt mit der veralteten Hardware, dann sollte das Fusion 15 doch auch hinkriegen (wobei ich den Wahrheitsgehalt seines Screenshots anzweifle, Troll?)

Doch ich habe die Beiträge gelesen. Ich habe auch bestimmt schon 10 Videos geguckt. Das Resultat war immer, dass die erstellten Raid 0 Konfigurationen immer schneller waren und ich frage mich nur ob jetzt abschließend der Chipsatz das Bottleneck ist oder ob es wirklich an Treiber oder Bios Einstellungen liegt
 

wuselsurfer

Kokü-Junkie (m/w)
Wenn der Herr instechio solche abartigen Werte bekommt mit der veralteten Hardware,
Nur hat er das System komplett in die RAM_Disk verlagert ... .

(wobei ich den Wahrheitsgehalt seines Screenshots anzweifle, Troll?)

Doch ich habe die Beiträge gelesen. Ich habe auch bestimmt schon 10 Videos geguckt. Das Resultat war immer, dass die erstellten Raid 0 Konfigurationen immer schneller waren
Quellen: ...
Hardware: ...
 

massaker

Freizeitschrauber(in)
Wenn der Herr instechio solche abartigen Werte bekommt mit der veralteten Hardware, dann sollte das Fusion 15 doch auch hinkriegen (wobei ich den Wahrheitsgehalt seines Screenshots anzweifle, Troll?)
Der Elfy mag es wirklich zu tollen, deswegen schon oft gebannt worden. Aber seine Screenshots sind echt und Benchmarkswerte ebenfalls. Er macht schon viel Tuning und entschlackt Windows sehr. Dann laufen bei ihm diverse RAM-Disks bzw. RAM-Caching Tricks. Das was Du da siehst ist quasi zu >95% RAM-Benchmark und <5% Datenträger an sich. Wenn er mal 64GB-Testfile-Größe einstellen würde, so dass die Benches nicht mehr komplett im RAM ablaufen können, dann würde seine lahme SSD ihr wahres Gesicht zeigen. Also lass Dich nicht tollen 😉
 
Oben Unten