• Hallo Gast, du kaufst gerne günstig ein und erfährst oft vor deinen Freunden von interessanten Angeboten? Dann kannst du dein Talent als Schnäppchenjäger jetzt zu Geld machen und anderen PCGH-Lesern beim Sparen helfen! Schau einfach mal rein - beim Test der Community Deals!

GTA V --> 59Hz Bug

aloha84

Volt-Modder(in)
Moin moin, ist hier noch jemand vom "59Hz-Bug" betroffen, und hat eventuell schon eine Lösung??

Was ist der 59Hz Bug?

Man kann die Bildwiederholfrequenz im nur auf 59Hz stellen, nicht auf 60Hz.
Jetzt kann man natürlich sagen: "Das eine Hz ist doch völlig egal!" --> JAIN!;)
Das Problem ist, dass bei 59Hz das adaptive Vsync nicht richtig arbeitet. Und das "ingame-vsync" ist halt nicht adaptiv, sondern normales vsync + triple buffer, welches leider mit einem leichten input-lag einhergeht.
Desweiteren erzeugt das ingame vsync ein erkennbares stottern.

Von mir noch nicht getestete Lösungsvorschläge:

- benutzerdefinierte Auflösung erstellen (eventuell mit tool --> Link )
- HDMI-Kabel entfernen (hab selber noch einen Fernseher angestöpselt)
- die Hz Zahl direkt in der Config eingeben? (Ist in den eigenen Dokumenten).
- Treiber neu installieren

- Lösung gefunden!
- randlosen Fenstermodus testen (heißer Tip von Arikus aus dem Sammelthread und raveya in diesem thread)

Falls jemand von dem Bug betroffen ist, kann er ja mal testen obs was bring. (ich kann grad nicht, weil ich auf Arbeit bin.)

Update:

So als Zwischenfazit würde ich sagen, die Probleme sind solved.
Wer vom Spiel 59Hz in den Optionen angezeigt bekommt und adaptives Vsync (Nvidia) nutzen möchte, muss in den Grafikoptionen auf den rahmenlosen Fenstermodus umschalten.
Das hat zur Folge, dass GTA die Hz-Zahl der Windowseinstellung übernimmt und somit adaptives vsync funktioniert.
Auch wer Probleme mit microstuttering bei normalen vsync oder extremen Tearing ohne vsync hat, sollte diesen Modus ebenfalls testen!

Somit erstmal dank an alle Beteiligten, und mal schauen ob noch ein Fix von Rockstar kommt.
 
Zuletzt bearbeitet:

Abductee

PCGH-Community-Veteran(in)
Den Bug hab ich auch.
Monitor ist über DVI angeschlossen, im CCC und Windows sind 60Hz eingestellt.
Das Ändern der settings.xml von 59 auf 60 hat bei mir keinen Effekt im Spiel :-(
 

Abductee

PCGH-Community-Veteran(in)
Nein, der Rechner wurde letzte Woche neu installiert.
Installiert ist bei mir der WHQL 14.12 Omega.
 
TE
aloha84

aloha84

Volt-Modder(in)
Ich hab von jemand anderem (AMD-USER) im Sammelthread gelesen, bei ihm hätte neuinstallieren den Bug bereinigt.
Also GTA 5 drauf lassen und treiber neu installieren.
 

Abductee

PCGH-Community-Veteran(in)
Weil das wort "Beta" dahinter steht und das neben dem Spielen noch ein Produktivrechner ist.
Generell hab ich bisher bei den "neuesten" AMD oder Nvidia-Treiber nicht mehr als hinzugefügte Crossfire/SLI-Profile gesehen.
Oder gibts schon irgendwo einen Test das sich wirklich was geändert/verbessert hat?
 

zerrocool88

Software-Overclocker(in)
Was mir eben noch aufgefallen ist das die FPS manchmal auf 30 bleiben. Wenn ich im menü dann einmal auf 99-120 oder 144 stelle geht es wieder
 

raveya

Kabelverknoter(in)
hab das gleiche Problem mit einer GTX 980.
Spiel fühlt sich stotterig an auf 59HZ.
Spiele allerdings an einem Fernseher per HDMI.
Andere Spiele haben das Problem nicht.
Stelle ich z.b. auf 50HZ um (zeigt Fernseher 50p an) und es läuft deutlich smoother. Sogar richtig schön kontant mit 2*MSAA + TXAA usw, bis auf EXTRA EINSTELLUNG bei Streaming Flug und Schattendistanz/Sichtweite konstant 50FPS.

Hat jemand mal das Tool genutzt was der TE meint?
 
TE
aloha84

aloha84

Volt-Modder(in)
Wie gesagt, kann es gerade nicht selber testen.
Was du aber auch mal machen/testen kannst wäre, im Nvidia Treiber eine benutzerdefinierte Auflösung erstellen und dort explizit 60 Hz eintragen. (z.B.: Progressive --> 1920x1080 --> 60Hz)
 

Abductee

PCGH-Community-Veteran(in)
Bei mir wird das Standardprofil 1920x1080@60Hz auch vom Monitor-Setup (direkt am Monitor) bestätigt, der wird definitiv mit 60Hz angesprochen.
Das GTA-Setup lässt mich übrigens problemlos auf 60Hz umschalten sobald ich was anderes als den Vollbildmodus wähle.
 
TE
aloha84

aloha84

Volt-Modder(in)
Bei mir wird das Standardprofil 1920x1080@60Hz auch vom Monitor-Setup (direkt am Monitor) bestätigt, der wird definitiv mit 60Hz angesprochen.
Das GTA-Setup lässt mich übrigens problemlos auf 60Hz umschalten sobald ich was anderes als den Vollbildmodus wähle.

Und wenn du dann auf Vollbild stellst, verstellt es sich wieder auf 59Hz?
 

Abductee

PCGH-Community-Veteran(in)
Korrektur,
Die Framerate geht im "Randlosen Fenstermodus" ab und zu auf 60 rauf, bleibt großteils aber auf 59.
Im Vollbildmodus seh ich überhaupt keine 60fps.
 
TE
aloha84

aloha84

Volt-Modder(in)
Nur das hier keine Irritationen auftreten.
Mit geht es um die Hz nicht um fps. Auch wenn es diesem Fall beides zusammenhängt.:ugly:
Sprich: GTA 5 lässt nur 59 Hz zu, die Folge sind bei aktiviertem vsync maximal 59fps, und für nvidia nutzer --> ein nicht funktionierendes adaptives vsync.
 

Abductee

PCGH-Community-Veteran(in)
Jo eh,
59Hz im Options/Grafikmenü, 59fps im Spiel, Monitor wird aber mit 60Hz angesteuert.
Das aktivierte VSync sollte die max. fps doch bei 60 halten, bzw. geben die Grafikoptionen nur 59 vor.
 
TE
aloha84

aloha84

Volt-Modder(in)
Jo eh,
59Hz im Options/Grafikmenü, 59fps im Spiel, Monitor wird aber mit 60Hz angesteuert.
Das aktivierte VSync sollte die max. fps doch bei 60 halten, bzw. geben die Grafikoptionen nur 59 vor.

Mit Ingame Vsync zeigte mir fraps eigentlich immer 59fps. Da stört mich aber der inputlag.

Das Problem bei dem (im Treiber forcierten) adaptiven vsync ist, dass dieses anscheinend nur die im Windows eingestellten Hz (60) für voll nimmt.
D.h. adaptives vsync synchronisiert erst ab 60fps@60Hz, unter 60fps stellt sich dieses vsync ab um framedrops zu vermeiden --> da in GTA aber nur 59fps@59Hz erreicht werden --> synchronisiert das adaptive vsync eben nie, was hässliches tearing zur folge hat.
 
L

Laggy.NET

Guest
Hab das Problem auch. Im Optionsmenü steht immer 59 Hz.

Tatsache ist aber, dass mein Display mit 60 Hz angesteuert wird, da beim Starten des Spiels nichts umschaltet bzw. das OSD des Monitors auch nicht aufleuchtet..

Es stimmt aber auch, dass Adaptive Vsync nicht funktioniert und Vsync auf 59 FPS begrenzt, was dazu führt, dass man immer wieder minimalste Ruckler wahrnimmt (sieht man gut, wenn man mit dem Smartphone den Monitor mit 240 FPS Zeitlupe abfilmt) Da bekommt man dann das bekannte Vsync Microruckeln (jedes x-te Frame wird doppelt angezeigt), sobald man in Regionen unterhalb von 60 FPS kommt. Und das ist eben bei 59 FPS schon der Fall. 100% flüssig und gleichmäßig lassen sich auf nem 60 Hz LCD nunmal nur exakt 60 oder exakt 30 FPS darstellen.

Ist zwar jetzt kein Weltuntergang, aber mir wären 60 FPS auch deutlich lieber, als 59. So ist es einfach nicht 100% flüssig.
 
L

Laggy.NET

Guest
Was steht bei dir bei den Hz unter Optionen?

@Laggy

Hast du schon eine der Lösungsvorschläge probiert?
z.B.: Treiber mal neu installiert? oder ne Benutzerdefinierte Auflösung erstellt?


Nein, werd ich heute abend nach der Arbeit mal testen. Ich hab aber auch noch meinen TV am HDMI Port, allerdings ist der Desktop nicht darauf erweitert, sprich er ist deaktiviert. Aber ich werde mal alle Verschläge testen,...

Treiber wurde am Montag abend sauber deinstalliert, mit DisplayDriver Uninstaller die reste beseitigt und der neue Treiber installiert. Daran kann es eigentlich nicht liegen, zumal das Spiel an sich perfekt läuft, kein Absturz, nichts.
Andere Spiele zeigen 60 Hz.
 
TE
aloha84

aloha84

Volt-Modder(in)
Nein, werd ich heute abend nach der Arbeit mal testen. Ich hab aber auch noch meinen TV am HDMI Port, allerdings ist der Desktop nicht darauf erweitert, sprich er ist deaktiviert. Aber ich werde mal alle Verschläge testen,...

Treiber wurde am Montag abend sauber deinstalliert, mit DisplayDriver Uninstaller die reste beseitigt und der neue Treiber installiert. Daran kann es eigentlich nicht liegen, zumal das Spiel an sich perfekt läuft, kein Absturz, nichts.

Sehr schön, damit hast du das gleiche setting wie ich.....und somit leider das gleiche Problem, aber vielleicht brauchen wir beide dann auch nur eine Lösung!:D

Treiber wurde am Montag abend sauber deinstalliert, mit DisplayDriver Uninstaller die reste beseitigt und der neue Treiber installiert. Daran kann es eigentlich nicht liegen, zumal das Spiel an sich perfekt läuft, kein Absturz, nichts.
Andere Spiele zeigen 60 Hz.

Der Tip mit dem Treiber kam von einem AMD User.
Du hast quasi, genau wie ich, den Treiber vor GTA5 installiert.....was eigentlich völligst egal sein sollte, aber vielleicht hilft ein einfaches neu installieren trotzdem?! (ich weiß es nicht)
Bei mir ist GTA 5 auch das einzige Spiel mit dem Problem.
 
Zuletzt bearbeitet:

raveya

Kabelverknoter(in)
Hab das gleiche mal getestet mit dem Benutzerdefinierten Nvidia Profil. Hilft leider nicht. Allerdings läuft das Spiel im Fenstermodus ohne RAND mit 60FPS... diese kleinen Mikroruckler sind dann weg.
Vollbild nach wie vor bei 59FPS gelockt.
 
TE
aloha84

aloha84

Volt-Modder(in)
Hab das gleiche mal getestet mit dem Benutzerdefinierten Nvidia Profil. Hilft leider nicht. Allerdings läuft das Spiel im Fenstermodus ohne RAND mit 60FPS... diese kleinen Mikroruckler sind dann weg.
Vollbild nach wie vor bei 59FPS gelockt.

Wie/Wo stellt man das ein?
Habs unter die Vorschläge gepostet!
 

raveya

Kabelverknoter(in)
unter dem Bildmodus kannst du das ändern im Spiel selber, anstelle Vollbildmodus änderst du das, ist aber halt nicht das gelbe vom EI. Eigl sollte Rockstar da nen fix rausbringen finde ich
 
TE
aloha84

aloha84

Volt-Modder(in)
unter dem Bildmodus kannst du das ändern im Spiel selber, anstelle Vollbildmodus änderst du das, ist aber halt nicht das gelbe vom EI. Eigl sollte Rockstar da nen fix rausbringen finde ich

Alles klar, hatte da noch nicht dran rumgestellt.
Vielleicht finden wir noch eine bessere Lösung.
Und ja, ich hoffe auch auf einen fix.
 
L

Laggy.NET

Guest
Alles klar, hatte da noch nicht dran rumgestellt.
Vielleicht finden wir noch eine bessere Lösung.
Und ja, ich hoffe auch auf einen fix.


Hab eine einfache Lösung ohne herumgefrickel gefunden.

Einfach im Spiel Vsync deaktivieren und im Treiber Vsync auf AN. Fertig. Schon hat man 60 FPS.
 

Abductee

PCGH-Community-Veteran(in)
Funktioniert so das adaptive Vsync auch?
Beim CCC wird "Vsync immer an" vom Spiel ignoriert, hab ich so noch nie gesehen das ein Spiel den Treiber übergehen kann.
 
L

Laggy.NET

Guest
Funktioniert so das adaptive Vsync auch?
Beim CCC wird "Vsync immer an" vom Spiel ignoriert, hab ich so noch nie gesehen das ein Spiel den Treiber übergehen kann.

Mit AMD funktioniert das nicht, weil diese Option bei AMD so lange ich denken kann noch nie funktioniert hat. :P Weder auf meiner HD7950, noch auf meiner HD5850...
Du könntest aber mal versuchen, Vsync mit dem D3Doverrider zu erzwingen.


Mit nVidia lässt sich problemlos vsync erzwingen. Adaptive Vsync funktioniert in GTA V trotzdem nicht, da dafür das Spielinterne Vsync gebraucht wird. Aber normales Vsync + Triple Buffering @ 60 FPS funktioniert perfekt, wenn man es im Treiber erzwingt. Damit kann man den 59 Hz Bug einfach umgehen (das panel wird ja trotzdem mit 60 Hz angesteuert, zumindnest bei mir)
 

Driftking007

Freizeitschrauber(in)
Also ich hatte auch Probleme mit VSync. Extremes Microruckeln und meeega Input lag. Auto fahren und so war überhaupt nicht möglich.

Ich hatte es auf 60Hz stehen.

Nun hab ich es aus und hab tearing, und das fällt leider manchmal extrem auf. Aber es lässt sich besser spielen und fühlt sich geschmeidiger an :D
 

maikwars

Komplett-PC-Aufrüster(in)
Mit nVidia lässt sich problemlos vsync erzwingen. Adaptive Vsync funktioniert in GTA V trotzdem nicht, da dafür das Spielinterne Vsync gebraucht wird. Aber normales Vsync + Triple Buffering @ 60 FPS funktioniert perfekt, wenn man es im Treiber erzwingt. Damit kann man den 59 Hz Bug einfach umgehen (das panel wird ja trotzdem mit 60 Hz angesteuert, zumindnest bei mir)


Klappt bei mir auch mit der Variante! :daumen:
Unglaublich..ich habe noch nie so lange an einem Spiel rumgefrickelt um es sauber eingestellt zu bekommen :O RS hat jedenfalls einige Bugs zu bearbeiten!
 
Zuletzt bearbeitet:
TE
aloha84

aloha84

Volt-Modder(in)
Sooo Feedback nach 2Std zocken.
Es braucht kein "gefrickel", einfach unter Grafik Einstellungen von GTA 5 auf Rahmenlosen Fenstermodus stellen --> Fertig! (die Bildwiderholfrequenz wird dann als "automatisch" angezeigt)
Keine Mikroruckler mehr mit vsync! Und adaptives VSync funktioniert tadellos!:daumen:
 

Murdoch

BIOS-Overclocker(in)
Also bei mir gab's keine Probleme.
Hab 59hz eingestellt und normales vsync.
Läuft absolut flüssig
 

maikwars

Komplett-PC-Aufrüster(in)
Sooo Feedback nach 2Std zocken.
Es braucht kein "gefrickel", einfach unter Grafik Einstellungen von GTA 5 auf Rahmenlosen Fenstermodus stellen --> Fertig! (die Bildwiderholfrequenz wird dann als "automatisch" angezeigt)
Keine Mikroruckler mehr mit vsync! Und adaptives VSync funktioniert tadellos!:daumen:

Ok wenn das auch funktioniert, hatte das nämlich auch eingestellt aber nur auf die FPS geachtet die unter dieser Einstellung dennoch auf max 59 FPS
kamen. Gefrickel meinte ich auf andere Probleme bezogen :P Da war das hier kleinkram!
 
Oben Unten