[BIOS-Mod] RX480 -> RX580 Conversions & Custom Mod How-to RX470/RX480/RX570/RX580

eeb0

Kabelverknoter(in)
Hey Leute,

was genau ist unter " Die zusätzlichen Ausgabeports neben den 3x DP und 1x HDMI funktionieren möglicherweise nicht ordnungsgemäß" gemeint? Hab jetzt neu einen PC mit ner geflashten 480, welcher per DVI mit meinem Monitor verbunden ist. Der Monitor hat leider kein Displayport und HDMI geht wegen 144hz nicht. Heute ist der PC angekommen, gleich getestet und auf den ersten Blick schien alles zu funktionieren. Keine Bildfehler, 144HZ lässt sich einstellen. Scheint ja aktuell keine Probleme zu geben, aber habe ich da eventuell in Zukunft zu befürchten, dass Fehler auftreten könnten bei der Verbindung mit DVI?
Habe die Sapphire Nitro+ 480. Wie das genau geflasht wurde und womit, weiß ich leider nicht.
 
TE
TE
H

hellm

Software-Overclocker(in)
Falls der DVI falsch konfiguriert wäre, würdest du nicht fragen. ;-)

Wenn alles funzt ist auch alles gut. :-)
 

emre-jcw

Schraubenverwechsler(in)
Hallo zusammen,

ich habe mir vor ein paar Tagen eine RX570 Sapphire Nitro+ mit 8gb gekauft. Was habe ich bei der Karte für Möglichkeiten bezüglich eines Bios Mods? Vielen Dank
 

Scarfaxe

Schraubenverwechsler(in)

Hallo hellm

ich besitze eine MSI RX 480 Gaming X 8G, leider funktioniert Dein im "zweiten" Post angegebenes Bios nicht für meine Karte.
Memory Type ist dann "unknown" und im Bootvorgang muss der Rechner mehrmals neugestartet werden, dass mein Board überhaupt die Karte erkennt.
Der IR Typ stimmt, also muss es vermutlich mit dem Speicher der Karte zusammen hängen, der zwar auch von Samsung ist, aber dennoch wohl ein anderer Speicherchip/typ.

Ich habe mir das englische Forum durchgelesen auf das Du verweist, aber dort leider keine Lösung gefunden, außer das es verschwiedene MSI RX480 Versionen gibt.
Und dort Deine Anfrage zu dem Originalem Bios der Karte,
daher hänge ich dieses von meiner hier mal an:

MSI Radeon RX480 Gaming X 8G (original Bios)
Dieser Inhalt steht nur eingeloggten Mitgliedern zur Verfügung.


Und bin Dankbar wenn Du Zeit findest mir zu helfen
Sonnige Grüße aus dem viel zu warmen Berlin!

(achso, dass Bios aus Deinem "ersten" Post zur Karte kann ich nicht flashen, da bekomme ich einen ID Fehler)
 
TE
TE
H

hellm

Software-Overclocker(in)
Das BIOS aus Post#1 muss mit dem Zusatz -fs geflasht werden, entsprechend der Anleitung.

Ich kann nur hier keinen Unterschied festestellen, auch das von dir gepostete BIOS hat denselben Samsung Speicher, mit diesem seltsamen Zusatz: K4G80325FB_WCK2CK
Alle anderen Karten kommen ohne _WCK.. aus.

Tut mir leid, ich bin eigentlich nur noch sehr wenig mit Polaris bekannt. Ich würde dich gerne auf den Red BIOS Editor verweisen, mynm hat alles was für Polaris noch sinnvoll ist und auch funzt in den RBE implementiert. Bis auf die 6528X Pointer für die GPU Spannung, die zu ändern funzt inzwischen überhaupt nicht mehr. Also die sind immer noch an Bord (Nostalgie) aber durch Min/Max und Offsets ersetzt. Und das funzt auch. Außerdem ist Post#3 scheinbar noch immer aktuell, das FAQ auch.

Ich kann dir noch sagen was an dem BIOS an Post#2 besonders ist, eigentlich nur die PowerPlay Table. Die kannst du nicht ohne weiteres kopieren, da müsstet die die Offsets der Tables korrigieren. Ist kein Hexenwerk, steht eigentlich auch schon auch OCN, in einem sehr guten Thread von gupsterg über Hawaii.
Geht aber nur um den zusätzlichen 1000MHz Memory Step, und der ist nicht zwingend vorausgesetzt.
 

Scarfaxe

Schraubenverwechsler(in)
Das BIOS aus Post#1 muss mit dem Zusatz -fs geflasht werden, entsprechend der Anleitung.

Ich kann dir noch sagen was an dem BIOS an Post#2 besonders ist, eigentlich nur die PowerPlay Table. Die kannst du nicht ohne weiteres kopieren, da müsstet die die Offsets der Tables korrigieren. Ist kein Hexenwerk, steht eigentlich auch schon auch OCN, in einem sehr guten Thread von gupsterg über Hawaii.
Geht aber nur um den zusätzlichen 1000MHz Memory Step, und der ist nicht zwingend vorausgesetzt.

Hi hellm

Vielen Dank für die Antwort und die Zeit die Du mitgebracht hast!

Ich dussel habe einfach nur die GUI von AMDvbflash genutzt, frei nach dem Gedanken "Wozu einfach, wenn es auch schwer geht".
So konnte ich jetzt mit -fs das Bios aus Post 1 flashen:

Dieser Inhalt steht nur eingeloggten Mitgliedern zur Verfügung.


Der Memory Type wird jetzt erkannt,
Was mich allerdings ein bisschen verwundert, die "Bandwidth steht nun bei 128GBit/s", sollte doch eigentlich 256GB/s sein.
Ich werde wohl mal testen ob das Auswirkungen für das System hat.

Dein Post 3 traue ich mir (ehrlich) nicht zu, auch wenn Du sagst das ist kein Hexenwerk, und ich Dir das glaube, habe ich zuviel respekt was falsch zu machen.
Remember ich habe schon die Befehlszeile -fs nicht benutzt, da kann man sich leicht ausmalen wo das endet.

So ist auch der >"Red BIOS Editor verweisen, mynm hat alles was für Polaris noch sinnvoll ist und auch funzt in den RBE implementiert"< den Du angesprochen hast, für mich ein böhmisches Dorf.
Ich werde das wohl mal googeln.

Wenn alle Stränge reißen werde ich mich wohl an Post 3 machen und versuchen nach Anleitung das Bios zu editieren.
Wohl aber erst wenn in Berlin keine 30°C mehr sind, weil es meine Fehlerquote signifikant verbessern könnte.

Noch einmal vielen vielen Dank für Deine Hilfe.
(Falls Du eine kurze Antwort auf die Bandwidth hast, das könnte mir helfen.)
Ansonsten möchte ich Dir ein schön sonniges Wochenende wünschen.
stay safe!
 
TE
TE
H

hellm

Software-Overclocker(in)
Wie gesagt, ich bin schon lange raus aus dem Thema. Deswegen habe ich auch keine Antwort auf die 128GBit/s, die halbierte Bandbreite sollte sich jedenfalls in einem deutlichen Leistungsverlust bemerkbar machen. Dieses BIOS wurde damals ausführlich getestet und es gab keinerlei Probleme.
 
Oben Unten