Battlefield 1 & 5 werden nicht gestartet. Treiber werden nicht erkannt.

the_wide_ocean

Schraubenverwechsler(in)
Hallo,

ich liebe seit Jugendzeiten die Battlefieldreihe. Da mein alter PC ein wenig zu schwach war für BF1 war, ich musste die latenz beim schießen mit einkalkulieren, entschied ich mich einen neuen Rechner aufzubauen. Die angestrebte Auflösung ist QHD.

Hier mein Setup:

Mainboard: MSI CARBON WIFI B650
CPU: AMD Ryzen 5 7600x
GPU: XFX RX 7800 XT (AMD)
RAM: Kingston Fury 32GB DDR5
SSD: M.2 Lexar NM 790 2TB
Netzteil: MSI 850 Watt
Windows 11 PRO

Sowohl der zusammenbau als auch die Installation von Windows gingen problemlos über die Bühne. Alles wurde sofort erkannt.
Hatte nur kurz Probleme mit der Internetverbindung, dies lag aber am verwendeten USB Stick. Mit dem Onboard Wlan klappt alles super.

Steam wurde problemlos herruntergeladen die Games BF 1 und BF 5 ebenfalls. Nun zu meinem Problem.
Sobald ich das Spiel starte bekomme ich Folgende Fehlermeldung:

Detected AMD Radeon driver version 0.0.0. The required driver version is 16.20.1025 or later. Please update your driver at http://www.amd.com/ before playing the game.

Also, AMD's Adrenalin sagt mir, dass ich auf dem aktuellsten Stand bin. Habe dann nocheinmal alle Treiber mit DDU und AMD's driver deinstall Software deinstalliert und neu aufgespielt. Habe die Games deinstalliert und neu herruntergeladen, habe die Release Datei umgeändert - nichts hat geholfen. Ich bekomme immernoch diese Fehlermeldung. Was mich stutzig macht ist, dass sie nicht neu zu seien scheint.
Ich habe einen Test im Internet gefunden bei welchem diese GraKa mit BF 5 gestestet wurde. Scheint also doch bei anderen zu funktionieren?!

Die GraKA scheint aber zu funktionieren, das schließe ich daraus, dass ich CS 2 weitesgehend sehr flüssig spielen kann. Ruckeln tuts aber dennoch ab und zu vorallem dann wenn's zur Sache geht (merkwürdig bei diesem Setup?!). Der Taskmanager zeigt aber Arbeit der GraKA an und sie ist nicht gerade ausgelastet.

Der Gerätemanager hat sie auch, die CPU GraKA ist ausgeschaltet.

Meint Ihr, dass ich mit der Graka einen Griff ins Klo gelandet habe? Sie erschien mir Preis / Leistungs technisch die beste Wahl zu sein um in QHD reinzukommen! Außerdem habe ich gelesen, dass es bei Nvidea ähnliche Probleme gibt.

Ich weiß mir nicht mehr zu helfen, ich hoffe das mir hier jemand helfen kann, ich habe doch extra für diese Spiele diesen Computer gekauft und aufgebaut.

Vielen Dank im Vorraus!

Sollte ich zwischenzeitlich eine Lösung gefunden haben, werde ich sie mitteilen.

Beste Grüße
 

Anhänge

  • Screenshot 2023-10-02 105504.png
    Screenshot 2023-10-02 105504.png
    183,4 KB · Aufrufe: 21
  • Screenshot 2023-10-02 105830.png
    Screenshot 2023-10-02 105830.png
    466,2 KB · Aufrufe: 22
Probier mal folgendes:
- Grafiktreiber runterladen (nicht das Auto Detect Ding.)
- iGPU aktivieren
- Internetstecker raus
- Mit DDU alle Treiber runter, schauen ob die IGPU komplett weg ist
- Treiber wieder installieren
- Internet wieder rein

So kann Windows dir nicht dazwischen fuschen, manchmal zieht Windows während der Treiberinstallation nen falschen Treiber aus dem Internet :ugly:
 
Hallo,

vielen Dank für Deine schnelle Antwort!

Ich hatte die automatische Treiber installation beim letzten mal deaktiviert. Werde es aber glaube ich gleich nochmal versuchen.

Jetzt gerade ist CS 2 auch noch abgestürzt. Im Fehlerbericht stand irgendetwas mit "Driver timeout".

Werde auch mal meinen Starfield Aktionscode einlösen, welchen ich zu meinem Prozessor erhalten habe, um zu schauen ob Starfield auch abstürtzt oder irgendwelche Zicken macht.


Eventuell werde ich mal den Release Driver ausprobieren. Oder was meint Ihr?

eXquisite: Du meintest doch die AMD Adrenalin Software, oder? Etwas anderes finde ich nicht bei AMD.
 
Was meinst Du denn mit I GPU?

Und mit Stecker raus wird es auch nicht so einfach. Werde einfach das WIFI Ding im Gerätemanager deaktivieren. Naja ich probiers mal aus und werde gleich berichten.
 
Hallo,

so habe nun Folgendes gemacht:

  1. Die anktuelle, von Euch genannte, AMD Version herruntegeladen und auf meinem Stick gespeichert
  2. DDU herruntergeladen und installiert
  3. WLAN unter Windowseinstellungen ausgeschaltet
  4. Mein WIFI Adapter im Gerätemanager deaktiviert um sicherzustellen, dass auch wirklich keine Verbindung mit dem Internet aufgebaut wird.
  5. Dann DDU gestartet, zuerst inm normalen Modus
  6. dann einzweites mal im abgesicherten modus laufen gelassen
  7. nach Neustart hatte ich dann ein Bild wie zuletzt bei Windows 98.
  8. im Gerätemanager stand "Microsoft Basic Display Adapter" wo vorher die GraKa mit " RX 7800 XT" angezeigt wurde
  9. Aus dem abgescherten in den normalen Modus
  10. Dann das besagte AMD Adrenalin injeziert (sprich: installiert)
  11. Neu Gestartet
  12. GraKa wurde im Gerätemanager erkannt
  13. Internet wieder eingeschaltet
  14. Steam gestartet
  15. BF 5 gestartet
  16. Selbe Fehlermeldung erhalten -----> keine (!) Änderung!

Tja, lade mir jetzt mal Starfield herrunter und schaue mal nach wie die GRAKa so performt.

Für weitere Ratschläge wäre ich sehr dankbar!
 
Hatte auch mal so ähnliches dass ich nicht ins Spiel gekommen bin da ich in den Trailer fest hing b.z.w nix geladen hat vernüftig.

Neu installation oder irgend was anderes, Hat es irgend wann erledigt. Bf1 / 5 von EA ist einfach grütze man kann es kaum spielen wenn ne fehler da ist wird in EA forum auch nicht mehr wirklich geholfen. Man soll Details geben aber dann wird nicht Reagiert. Verbugt von vorne bis hinten irgend wann geht es, Oder halt nicht.
 
Was meint Ihr, würde ein GraKa tausch das Problem lösen?
Glaube nicht.
Habe wie gesagt windows neu gemacht oder so aber irgend was geändert ich kann nicht mehr sagen was. Und seit dem läuft es relativ.
Mit der Selben Grafikarte. Das sind wie gesagt random bugs die bei irgend einer sage mal tiefgreifenderen änderung wie ne neuinstallation von windows oder so behoben sind b.z.w nicht existent sind. Das kann an EA clinte liegen oder an EA selber oder am Game.

Dafür ne neue Grafikarte zu holen in der hoffnung das die 3% warscheinlichkeit ausreicht das es läuft und nochmals 2% in ungewissen zu sein und 95% vor den gleichen problem zu stehen ist nicht zeit gemäß. Würde ich dir nicht Raten.
Einfach EA titel nicht spielen da passiert halt irgend was random und dann kann man so was nicht zocken. Fertig aus.
 
Was meint Ihr, würde ein GraKa tausch das Problem lösen?
Hattest du die iGPU zwischendurch wieder aktiviert?
Ich vermute ja, dass von der dort noch ein kaputter Treiber im Windows "hängt".

Notfalls, schmeiß mal ein neues Windows drauf, da muss doch irgendwas bei der Installation schief gelaufen sein.
Es kann doch nicht sein, dass er Version 0.0 zurückmeldet.
 
Zuletzt bearbeitet:
Also, es hat tatsächlich geklappt.

Habe im Gerätemanager die interne GPU deinstalliert. Jetzt wird mir nur noch die RX 7800 GT angezeigt sonst nix. Hatte zuvor diese lediglich deaktiviert!

Vielen Dank für alle Antworten.
 
Zurück