• Hallo Gast, du kaufst gerne günstig ein und erfährst oft vor deinen Freunden von interessanten Angeboten? Dann kannst du dein Talent als Schnäppchenjäger jetzt zu Geld machen und anderen PCGH-Lesern beim Sparen helfen! Schau einfach mal rein - beim Test der Community Deals!

Xbox one gamepad Treiber Bug (?)

RobinNyan

PC-Selbstbauer(in)
Guten Abend / Morgen / Tag :)
Also. Mein Problem ist recht kompliziert und ich weiß nicht recht wie ich anfangen soll.
Ich besitze einen Xbox One Wireless Controller für PC zusammen mit dem Wireless Adapter.
Funktioniert in den meisten Spielen. In den meisten.

in gewissen, wenigen Spielen und z.B. auch im Steam Big-Picture Modus habe ich ein sehr merkwürdiges Verhalten festgestellt,
nach dem ich bereits ganz Reddit und das halbe Internet abgesucht habe.



in Need for Speed Rivals (welches trotz 30 fps lock sehr gut spielbar und hübsch ist ;) ) funktioniert die Vibration zuerst nicht.
Doch dann nach 5 Minuten ingame fangen meistens plötzlich die Trigger (!!) an zu vibrieren!
Eigentlich unterstützt dieses Feature ja nur die UWP Plattform!
Außerdem vibrieren sie ohne Zusammenhang und sehr zufällig und auch in einer sehr hohen Frequenz und Stärke.


Anderes Spiel, anderes Problem: Final Fantasy XIII. Ich gehe ins Hauptmenü auf Continue und Spiel crasht. selbiges beim Nachfolger.


jetzt auch noch Steam Big Picture. Wenn ich einen Knopf drücke, wird er doppelt registriert.
Sprich LB und RB tun gar nichts (da man mit ihnen z.B. zum Chat wechselt und zurück) und wenn ich auf den Power Button oben rechts gehe wird es direkt minimiert (sprich feld wird geöffnet und das erste Feld minimieren ausgewählt, ohne dass ich das überhaupt sehe)

jetzt habe ich allerdings in Steam was festgestellt!
Im Big Picture Modus kann man nämlich die registrierten xinput geräte anzeigen lassen und siehe da:

ES SIND ZWEI! Hab davon ein Bild mal angehängt unten!

Wenn ich nun den ersten anwähle und A drücke (oder mit der Maus antatsche) dann vibriert mein Gamepad in der Hand.
Wenn ich aber das andere drücke passiert gar nichts! Ich habe auch testweise mal den Controller deaktiviert und auf einmal waren auch beide xinput geräte weg! Stimmt also schonmal was nicht!



Nun habe ich gemerkt dass da wirklich was faul ist!
Da ich im Geräte Manager nichts gefunden habe außer die Treiber für den Controller und den Wireless Adapter,
habe ich mal unter Geräte und Drucker bei dem Controller geguckt und OHA:
es werden mehrere verschiedene treiber direkt beim Controller angezeigt!
Ist das bereits der Haken? Ich weiß es nicht, deswegen schreibe ich hier! :D



Ich hoffe jemand hat sich den ganzen Mist durchgelesen und kann mir helfen :/

windows ist übrigens auch komplett neu aufgesetzt jetzt und habe den controller auch mit Kabel und ohne Kabel gecheckt und auch mit Kabel werden zwei xinput geräte bei Steam angezeigt.



Mit freundlichen Grüßen,

Robin


übrigens mein System falls das hilft:

Windows 10 (mittlerweile) Fast Ring Beta (in der Hoffnung dass es hier geht - Fehlanzeige)
i7 4790k
8 GB DDR3 Ram
GTX 750 Ti
ne Samsung 840 Evo 250 gb ssd wo Win drauf ist
und ne 1 TB HDD für Steam-Spiele und sonstige Games
und ne Creative soundblaster Z falls das wichtig ist..


#Edit

in dem zweiten bild sieht man die Treiber die angezeigt werden wenn ich den Controller per Kabel verbinde.
ich habe versucht jeden Treiber einzeln zu deaktivieren und anschließend in Steam geguckt und bei jedem einzelnen verschwinden alle xinput geräte in Steam..
dxdiag sagt auch nur 1 Game Controller.. ich verzweifle :(
kann ja nicht am wireless dongle liegen wenn's auch per kabel passiert, selbst wenn ich vorher die entsprechenden Treiber alle manuell deinstalliere!

#Edit 2

ERLEICHTERUNG! An meinem Detachable, welches auch mit Windows 10 Fast Ring läuft, passiert es auch!
ICH BIN NICHT VERRÜCKT! :D Spaß beiseite, ich hatte das Problem schon als Win10 neu war. Könnte also natürlich tatsächlich an Windows 10 liegen.
Wollte allerdings dennoch mal gucken ob hier in der Community dieses Problem auch auftritt.

Wenn ja: bitte melden und dann auch im Feedback Hub posten!
 

Anhänge

  • Screenshot (1).png
    Screenshot (1).png
    1,3 MB · Aufrufe: 45
  • Screenshot (3).png
    Screenshot (3).png
    1,6 MB · Aufrufe: 43
Zuletzt bearbeitet:

smashbob

PC-Selbstbauer(in)
Nein, Dieses Problem habe ich nich. Kann dir jedoch empfehlen aus den Windows App Store die Xbox Zubehör App runter zuladen, die spielt die aktuellste Firmware auf den Controller auf. Vielleicht hilft das ja schon
 
TE
R

RobinNyan

PC-Selbstbauer(in)
Nein, Dieses Problem habe ich nich. Kann dir jedoch empfehlen aus den Windows App Store die Xbox Zubehör App runter zuladen, die spielt die aktuellste Firmware auf den Controller auf. Vielleicht hilft das ja schon

hab ich schon gemacht, neue firmware wurde installiert, gebracht hat's nichts :/
 

smashbob

PC-Selbstbauer(in)
Mist, dann kann ich dir leider nicht weiterhelfen. Aber räum deinen Post vielleicht mal was auf, is sehr anstrengend zu lesen und lang, vielleicht hält das andere davon ab sich dem anzunehmen.

Viel Glück
 
Oben Unten