• Hallo Gast, du kaufst gerne günstig ein und erfährst oft vor deinen Freunden von interessanten Angeboten? Dann kannst du dein Talent als Schnäppchenjäger jetzt zu Geld machen und anderen PCGH-Lesern beim Sparen helfen! Schau einfach mal rein - beim Test der Community Deals!

Steam "in-home-streaming" Problem

TJW65

Freizeitschrauber(in)
Hallo PCGH Community,
ich melde mich nun seit längerem auch mal wieder.
Denn neulich habe ich einen alte Lenovo Konsole-im Sinne von kompakter PC-
wieder hervorgekramt, und ich dachte, ich könne diese doch mal für das Steam "in home Streaming" verwenden.
Denn so könnte ich auch mal ein paar Runden im Wohnzimmer spielen, anstatt immer an meinen Schreibtisch gebunden zu sein.
Soweit so gut, doch als ich das erste Spiel testen wollte musste ich leider fest stellen, dass mein Spiel nur den halben Fernseher ausfüllt.
Nein, das Bild ist nicht abgeschnitten, sondern nur auf die Hälfte der möglichen Bildfläche gequetscht.

Also begann ich zu experimentieren, mit der Auflösung, doch alles was ich versuchte blieb am Ende erfolglos.
Denn ich landete immer wieder dabei, das Spiel, beide generellen Auflösungen-also die in Windows- und die von dem Stream auf Full HD zu setzen.


Vielen dank schon einmal für eure Ideen
Mit freundlichen Grüßen
TJW65
 

Venom89

PCGHX-HWbot-Member (m/w)
Welche Hardware nutzt du denn?
Monitor Auflösung?
TV Auflösung?

Wie sehen deine Einstellungen unter "in home streaming" aus? (Client und Host)

LG
 
TE
TJW65

TJW65

Freizeitschrauber(in)
Schon einmal Danke für die schnelle Antwort,

Der Host PC hat:
-einen Ryzen 5 1600
-eine GTX 780 "GLH"
-ein Windows 10 Home
Der Rest ist verm. Unwichtig...

Der Client hat:
-einen Intel Atom Dual Core D525
-und eine NVIDIA ION Grafik
- ein Windows 7 Home Premium

Der Monitor vom Host PC ist ein Full HD gerät, sowie der Fernseher im Wohnzimmer.

Die drei betitelten Bilder(Screenshots) sind vom Host PC selber, und die Fotos mit Nummern stammen vom Client PC
 

Anhänge

  • Client.JPG
    Client.JPG
    44,4 KB · Aufrufe: 153
  • Host.JPG
    Host.JPG
    61,8 KB · Aufrufe: 112
  • IMG_20180708_144343.jpg
    IMG_20180708_144343.jpg
    2,1 MB · Aufrufe: 128
  • IMG_20180708_144359.jpg
    IMG_20180708_144359.jpg
    2,2 MB · Aufrufe: 103
  • IMG_20180708_144409.jpg
    IMG_20180708_144409.jpg
    2,2 MB · Aufrufe: 95
  • Gennereller Infos.JPG
    Gennereller Infos.JPG
    54,1 KB · Aufrufe: 95
Zuletzt bearbeitet:

Venom89

PCGHX-HWbot-Member (m/w)
Der TV bekommt aber ein 1080 p Input Signal?

Sind nur die spiele klein oder auch big picture?
Welches Spiel?
Andere getestet?
Grafiktreiber aktuell?

Versuche es Mal mit "Desktopauflösung an streaming Client anpassen".

Falls das nicht funktioniert aktiviere Mal die Beta Teilnahme. Dort wurden viele Fehler behoben.

LG
 
Zuletzt bearbeitet:
TE
TJW65

TJW65

Freizeitschrauber(in)
Ich wüsste jetzt nicht,
wie ich am TV nach dem ankommenden Signal gucken könnte.
Laut den Infos die ich mir von Steam beim Streaming anzeigenlassen kann, ist es ein 1080P Stream.
Wobei interessant ist das das Spiel bei angezeigten Infos weiterhin gequetscht ist,
aber die anzeige für die Frametime (war das Glaube ich, oder die Verzögerung vom Host zum Client?)
als durchlaufende Balken auf der schwarzen Hälfte des TV angezeigt wird.

Wenn ich den Big Picture Modus Starte ist das Interface selbst auf dem Ganzen TV, die Spiele jedoch wieder gequetscht.

Diese Option hat leider nicht geändert, genausowenig, wie ein erneutes ändern der Auflösung des Streams.

Über eine Beta Teilnahme werde ich mal nachdenken...
 

Olstyle

Moderator
Teammitglied
Versuch mal testweise das Hardwaredecoding beim Client bzw. Hardwareencoding beim Server zu deaktivieren. Wird zwar nicht flüssig sein, sollte aber einen Eindruck liefern ob es dort schief läuft.
 
TE
TJW65

TJW65

Freizeitschrauber(in)
So,
ich habe jetzt einmal das Hardware de/-Encoding ausgeschaltet,
und siehe da, es funktioniert. Auch wenn es gelegentlich zu Rucklern kommt werde ich es erst einmal dabei belassen, denn ich hatte so oder so nicht vor egoshooter o.ä. am TV zu spielen, sondern eher ein paar Simulationen, Taktikspiele etc.

Ich bedanke mich vielfach bei euch, wenn ich doch noch Fragen haben sollte, melde ich mich einfach wieder.

Mit freundlichen Grüßen
TJW65
 

Olstyle

Moderator
Teammitglied
Kannst ja Mal Schrittweise wieder zuschalten. Das Encoding sollte dein PC durchaus auch so schaffen. Nur das Decodieren am Client wird kritisch, auch wenn ich leider befürchte dass es genau da an der HW-Unterstützung hapert.
 

Venom89

PCGHX-HWbot-Member (m/w)
Wenn du das Encoding abschaltest, wird das ganze in Software über die CPU berechnet. Daher kommen die ruckler.
Ob man jetzt Shooter oder Strategiespiele zockt, ist ja eigentlich egal. Ruckeln stört immer, eine leichte Latenz eher bei competiven Games. Wenn das bei dir nicht der Fall ist umso besser ;).

Hast du es mal nur mit dem NVidia Encoding versucht?

Als Alternative könntest du dir einen Steamlink besorgen. Bekommt man teilweise für 5 Euro.
Wenn du einen Android TV besitzt alternativ die Steamlink App darauf.

LG
 

jlnprssnr

Schraubenverwechsler(in)
Schalte mal in den "erweiterten Client-Optionen" auf der Lenovo-Kiste die Performance-Informationen an. Wenn dann der Stream ruckelt, sollte am linken unteren Bildschirmrand eigentlich angezeigt werden, warum ("slow network", "slow decode", "slow encode").
 
Oben Unten