Frage zu SPDIF von Soundblaster Xfi

FetterKasten

Software-Overclocker(in)
Hallo,

habe mal eine spezifischere Frage, wo ich aktuell mit meinem Latein am Ende bin:

Meine neuen Edifier S350DB habe ich per digital coaxial an den Flexi Jack Anschluss meiner Creative XFi extreme music Soundkarte angeschlossen. Dieser ist so eingestellt, dass der Digital Out aktiviert ist.
Bei Windows bei den Wiedergabegeräten habe ich SPDIF (Creative Xfi) eingestellt als Standardgerät.

Wenn ich nun Musik usw anhöre ist alles glasklar.
Allerdings kommt es bei häufigen Ton an/aus (zb wenn ich bei Youtube ein Video durchspule) während dem Umschalten zu einem nervigen kurzen Knacksen.
Dieses Knacksen ist mir ganz unabhängig von der Sache, auch schon an meinem Sat-Receiver aufgefallen, der über HDMI auch digital an meinen TV sendet, manchmal beim Sendern umschalten.

Beim analogen Anschluss des Systems habe ich dieses Phänomen nicht.

Desweiteren finde ich eigenartig, dass wenn ich als Wiedergabegerät nicht SPDIF aktiviere, sondern bei den Windows Wiedergabegeräten "Lautsprecher (Creative Xfi)", welche eigtl für den analogen Output stehen sollten, höre ich Ton, trotzdem die Lautsprecher coaxial angeschlossen sind?! Und da kommt dieses Knacksen nicht vor!

Was hat das zu bedeuten?
Ich fand die Software von Creative Soundkarten schon früher bei der alten Soundblaster Audigy schrecklich. Viell. hat jmd ja ne Idee, was da dahinter steckt?

Wenn nicht, werden die Boxen einfach analog angeschlossen und fertig. Aber nachvollziehen kann ich das ganze nicht.

Danke
 

MircoSfot

Freizeitschrauber(in)
Das Knaxen ist normal wenn man in über SPDIF betreibt. Das ist eben überall so, egal ob teuer und billig. Manchmal kommt am Anfang gar kein Ton bei der erstmal anspringen muss, total öde. Besser Analog anschließen.
 
C

chaotium

Guest
Das Knaxen ist normal wenn man in über SPDIF betreibt. Das ist eben überall so, egal ob teuer und billig. Manchmal kommt am Anfang gar kein Ton bei der erstmal anspringen muss, total öde. Besser Analog anschließen.

Beim Analogen Anschluss hast Du ein Knacksen. zB Chinch Stecker.

Warum sollte man beim Digitalen Anschluss ein Knacksen haben? Toslkink ist glasfaser. Was soll da Knacksen?
Ich habe seit der PS3/4 und seit dem PC nur Toslink und HDMI genutzt. Es gab nie ein Knacksen.
 

DuckDuckStop

BIOS-Overclocker(in)
Und beim TE knackt es bei Anschluss über spdif, womit er auch nicht alleine ist. Dass es bei dir nicht knackt ist dabei vollkommen egal.

@TE kann durchaus sein dass deine soundkarte Probleme mit dem flexi Anschluss hat, schließ sie einfach analog an wenn es dich stört.
 
TE
TE
F

FetterKasten

Software-Overclocker(in)
Also ich hab mir nochmal drüber Gedanken gemacht und meine logische Erklärung wäre die:

Wenn ich bei der Xfi SPDIF einstelle, dann ist es eben wirklich SPDIF, also die XFI macht gar nichts, außer evtl. verstärken (Lautstärkeregelung geht).
Dh. der digitale Bitstream kommt nur durch das coax Kabel, wenn wirklich gerade ein Ton anliegt oder zb iTunes auch beim Pause drücken das Signal nicht unterbricht, sondern "still" sendet.
Youtube bzw Firefox unterbricht den Bitstream aber zb immer. Und mit diesen schnellen an/aus Wechseln kommt der Soundchip der Edifier wahrscheinlich nicht ganz klar, wodurch dieser kurze Knacks entsteht.

Bei meinem Z5500 Digital war es aber viel krasser! Da kam ein richtig lautes Knacksen und die erste Sekunde des Tons hat man gar nicht gehört. Da sind die Edifier sofort da.

Beim analogen Anschluss arbeitet ja der Wandler der Xfi und der is genauso wie Onboard Sound ständig am arbeiten und wandeln und dieses Problem tritt nicht auf, weil die Soundkarten eben auf diese An/Aus Wechsel am PC ausgelegt sind.

Das komische ist dann nur, warum wenn ich nicht SPDIF als Wiedergabegerät auswähle trotzdem Ton über Coax gesendet wird und das Knacksen nicht auftritt?
Da denke ich, dass nun die XFi das Signal bearbeitet, aber trotzdem digital sendet. Eben kein SPDIF, sondern eine digitale Überarbeitung.
Das erkenne ich daran, dass nun im XFI Einstellungsfenster die Bass und Treble Regler erscheinen, die bei SPDIF nicht da waren.
Und in diesem Modus sendet sie einen permanenten Bitstream. Wenn es still ist, eben alles Nullen. Dadurch haben die Edifier permanent das Signal und müssen es nicht erst wieder neu erkennen.

Schon alles kompliziert im Audio Bereich. Eigtl. sollte es doch heute drin sein, Chips zu entwickeln, die SPDIF sofort verarbeiten und selbst bei schnellen Wechseln nicht Knacksen.
Mag sein, dass es vielleicht aber auch an der Xfi selbst liegt beim SPDIF.


Spdif kommt für mich als Anschluss also nicht in Frage. Ich könnte entweder digital ohne SPDIF oder analog wählen.
Und da werde ich wohl lieber analog wählen.
Denn wenn die XFI eh irgendwas am bearbeiten ist, dann kann sie auch gleich wandeln. Sonst pfuscht ja einmal die XFi rein und einmal der Edifier Chip.
Dann lieber nur die Xfi. Vom Klang hör ich eh keinen Unterschied.

edit:
Als Anhang noch zur Veranschaulichung:
Bei SPDIF geht nur coax und da ist das Knacksen beim An/Aus Wechsel.
Bei Lautsprecher geht analog und coax und kein Knacksen.
Unbenannt.PNG
 
Zuletzt bearbeitet:
Oben Unten