• Hallo Gast, du kaufst gerne günstig ein und erfährst oft vor deinen Freunden von interessanten Angeboten? Dann kannst du dein Talent als Schnäppchenjäger jetzt zu Geld machen und anderen PCGH-Lesern beim Sparen helfen! Schau einfach mal rein - beim Test der Community Deals!

Bluescreen (pfn_list_corrupt) Kingston 3x 2Gb + ASRock P67 Pro3

Invalinho

Schraubenverwechsler(in)
Hallo Community,

ich habe ein Problem und zwar stürzen bzw. hängen sich bei mir verschiedene Spiele ab/auf (Bioshock Infinite/ Dishonored).
Das war bis jetzt noch alles ziemlich verkraftbar... Nun habe ich jetzt mal wieder angefangen Far Cry 3 zu spielen und plötzlich stürzt hier manchmal mein ganzer PC ab und beim Bluescreen erscheint die Meldung pfn_list_corrupt.
Durch Googeln hab ich herausgefunden, dass dieser Fehler häufig mit dem Arbeitsspeicher zu tun hat und da habe ich durch zufälliges Lesen eines ähnliche Problems hier im Forum gesehen, dass hier eine Diagnose mit dem Debug-Tool von Windows weiterhelfen könnte, nur leider kann ich mit der der Analyse der Dump-Dateien wenig anfangen, ich hoffe ihr könnt mir da weiterhelfen.
Vielen Dank schon mal im Voraus.

LG Invalinho

Mein Sytem:
ASRock P67 Pro3
Intel i5 2500K
GTX 560 Ti von Palit
Kingston HyperX 3x 2Gb
Corsair 650W

Hier der Bugcheck des RAM:
PFN_LIST_CORRUPT (4e)
Typically caused by drivers passing bad memory descriptor lists (ie: calling
MmUnlockPages twice with the same list, etc). If a kernel debugger is
available get the stack trace.
Arguments:
Arg1: 0000000000000099, A PTE or PFN is corrupt
Arg2: 000000000002cfd8, page frame number
Arg3: 0000000000000001, current page state
Arg4: 000000000002fc58, 0

Debugging Details:
------------------


BUGCHECK_STR: 0x4E_99

CUSTOMER_CRASH_COUNT: 1

DEFAULT_BUCKET_ID: WIN7_DRIVER_FAULT

PROCESS_NAME: farcry3_d3d11.

CURRENT_IRQL: 2

LAST_CONTROL_TRANSFER: from fffff80003322a0c to fffff80003293c00

STACK_TEXT:
fffff880`0f2aae18 fffff800`03322a0c : 00000000`0000004e 00000000`00000099 00000000`0002cfd8 00000000`00000001 : nt!KeBugCheckEx
fffff880`0f2aae20 fffff800`0323fee2 : 00000000`00000000 fffff680`0011aa68 00000000`00000002 00000000`00000001 : nt!MiBadShareCount+0x4c
fffff880`0f2aae60 fffff800`032637a3 : fffffa80`054d6060 fffff700`0002b1fb 0000007f`fffffff8 fffff8a0`02ba5c68 : nt! ?? ::FNODOBFM::`string'+0x3242a
fffff880`0f2aaef0 fffff800`03264872 : fffffa80`054d6060 fffffa80`00000001 fffff880`00028909 fffff800`00000006 : nt!MiDeleteAddressesInWorkingSet+0x307
fffff880`0f2ab7a0 fffff800`03569cba : fffff8a0`0388aa50 fffff880`0f2abae0 00000000`00000000 fffffa80`07539b50 : nt!MmCleanProcessAddressSpace+0x96
fffff880`0f2ab7f0 fffff800`0354fdbd : 00000000`000000ff fffff880`0f2aba01 00000000`7eec1000 fffffa80`0802cb50 : nt!PspExitThread+0x56a
fffff880`0f2ab8f0 fffff800`0328671a : 00000000`00000001 fffff880`0f2aba68 00000000`00000001 00000000`00000000 : nt!PsExitSpecialApc+0x1d
fffff880`0f2ab920 fffff800`03286a60 : 00000000`3ea9feb4 fffff880`0f2ab9a0 fffff800`0354fd30 00000000`00000001 : nt!KiDeliverApc+0x2ca
fffff880`0f2ab9a0 fffff800`03292f37 : fffffa80`07539b50 00000000`7eec1000 00000000`000000c0 00000000`7eec1000 : nt!KiInitiateUserApc+0x70
fffff880`0f2abae0 00000000`77092c1a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceExit+0x9c
00000000`0db8e5c8 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x77092c1a


STACK_COMMAND: kb

FOLLOWUP_IP:
nt!MiBadShareCount+4c
fffff800`03322a0c cc int 3

SYMBOL_STACK_INDEX: 1

SYMBOL_NAME: nt!MiBadShareCount+4c

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: nt

DEBUG_FLR_IMAGE_TIMESTAMP: 5147d9c6

IMAGE_NAME: memory_corruption

FAILURE_BUCKET_ID: X64_0x4E_99_nt!MiBadShareCount+4c

BUCKET_ID: X64_0x4E_99_nt!MiBadShareCount+4c

Followup: MachineOwner
 

Julian1303

PCGH-Community-Veteran(in)
Sollte zwar nix zur Sache tun, aber versuch mal nur mit 2 Modulen zu fahren. Sehe, hast drei DIMMs drin. Vielleicht mag das solang gut gehen wie nicht mehr als gesamt 4 GB Ram Verwendung finden. Schon mal MemTest durchlaufen lassen? Ram übertaktet oder Timings zu scharf eingestellt?. Oder ein Moduil hat einfach den geist aufgegeben.
Würde ja am Besten sagen, investiere in 2x4GB als 8GB Ram.
 
TE
I

Invalinho

Schraubenverwechsler(in)
Nein, habe weder übertaktet noch hab ich die Timings verstellt.
Habe jetzt seit heute Nachmittag Memtest 7 mal durchlaufen lassen und es hat keinen Fehler gefunden.
Könnte es damit was zu tun haben, dass mein Mainboard im Dual-Channel-Modus läuft, aber nur 3 der 4 Steckplätze belegt sind?
 

der_knoben

Lötkolbengott/-göttin
Glaub ich weniger, dass es am Dual/Single Channel liegt.

Wie laufen denn 3DMark 11 sowie Unigine Heaven?
 
TE
I

Invalinho

Schraubenverwechsler(in)
Lasse gleich mal 3DMark 11 durchlaufen.
Nochmal zu Julian1303, habe gestern Abend nochmal versucht mit nur zwei Modulen Far Cry 3 zu spielen, der PC ist aber wieder abgestürzt, diesmal kam aber die Meldung IRQL_NOT_LESS_OR_EQUAL.

Edit: Laut 3DMark scheint alles in ordnung zu sein, alles im normalen Bereich.
 
Zuletzt bearbeitet:
TE
I

Invalinho

Schraubenverwechsler(in)
Hab mal nen Screenshot von CPU-Z gemacht.
 

Anhänge

  • Unbenannt.jpg
    Unbenannt.jpg
    74 KB · Aufrufe: 137
Zuletzt bearbeitet:
TE
I

Invalinho

Schraubenverwechsler(in)
Vielen vielen Dank Leute,
mein PC stürzt jetzt weder ab, noch hängt sich ein Programm oder Spiel auf.
Wundert mich nur warum die Standardeinstellungen zu solchen Problemen führen?
 

simpel1970

Lötkolbengott/-göttin
Vermutlich, weil das Board mit den XMP Einstellungen (straffere CL7 Timings) nicht genügend Spannung auf die Riegel gibt.
Allerdings würde ich dem Memory Controller in der Sandy CPU die nötigen 1,65V nicht zumuten wollen. Intel spezifiziert die max. DDR3 RAM Spannung für den Controller auf max. 1,575V.

Zudem macht es keinen spürbaren Unterschied in der Performance, ob die RAM nun mit CL9 oder mit CL7 laufen.
 
Oben Unten