X570 Dilemma. RAID oder PCIe Storage Device - beides geht nicht

geohei

Komplett-PC-Aufrüster(in)
Ein Frage an die Profis (no joke!).
Komme hier keinen Deut weiter.

Meine (neue) Hardware:

ASUS ROG Strix X570-E Gaming
Ryzen 3900X

Areca ARC-1220
PCI2 x8 RAID Karte
Kaufdatum 2012
no-boot volume
Ob die Karte jetzt PCIe 1.0 oder 2.0 ist konnte ich nicht in Erfahrung bringen.
Ich benutze sie als Datenspeicher fin einem 4 HDD RAID5 Verbund.
Sie steckt im PCIe_x16_2 Slot.

Samsung SSD 970 Evo Plus
boot volume
Ist im M.2_1 Slot.

Am Mobo hängen auch noch 2 HDDs (no-boot), die ich als RAID1 Verbund anbinden möchte.
Angeschlossen am SATA6G_1/2.

BIOS: 2602 (letzte Version Stand 08.08.2020)

Damit ich die beiden RAID1 HDDs als RAID1 Verbund benutzen/konfigurieren kann, ...
Advanced\SATA Configuration\SATA Mode > RAID
Advanced\RAIDXpert2 Configuration Utility > ...

Alles obige setzt aber voraus, dass ...
Boot\CSM (Compatibility Support Module)\Lauch CSM > Disabled
... oder ...
Boot\CSM (Compatibility Support Module)\Lauch CSM > Enabled
Boot\CSM (Compatibility Support Module)\Lauch CSM\Boot from Storage Devices > UEFI only

Alles andere klappt nicht. Die beiden HDDs sind nur so im BIOS sichtbar und lassen sich als RAID1 konfigurieren.

Das hier brauche ich, damit beim Booten OpROM der Areca Karte geladen wird.
Boot\CSM (Compatibility Support Module)\Lauch CSM > Enabled
Boot\CSM (Compatibility Support Module)\Lauch CSM\Boot from Storage Devices > Legacy only

Hier liegt jetzt der Konflikt!

1. Das hier brauche ich um die Areca Karte zu sehen:
Boot\CSM (Compatibility Support Module)\Lauch CSM > Enabled
2. Damit die beiden HDDs vom BIOS als RAID1 Verbund eingebunden werden brauche ich:
Boot\CSM (Compatibility Support Module)\Lauch CSM\Boot from Storage Devices > UEFI only
3. Damit die Areca Karte Beim Start erkannt wird brauche ich:
Boot\CSM (Compatibility Support Module)\Lauch CSM\Boot from Storage Devices > Legacy only

2. oder (!) 3. Beides geht nicht!

Was mache ich falsch?

Ich verstehe nicht warum der X570 nicht im RAID arbeiten kann, und gleichzeitig eine PCIe Karte im Legacy erkannt werden soll!

BTW ... unter den Erklärungen für Boot from Storage Devices steht:
"Storage devices will run the selected type first during system boot. It is recommended to select either Legacy only or UEFI drivers first by the devices specification for a better stability. ..."

Das heißt doch, dass die eingestellten vor den nicht-eingestellten eingebunden werden. Es scheint aber so, als ob nur (!) die eingestellten eingebunden werden, und die nicht-eingestellten ignoriert werden.

Ich nehme an es würde auch nichts bringen die Areca Karte in den PCIe_x16_3 Slot zu schieben, oder?

Würde mich echt über Antworten freuen !!!
 
Zuletzt bearbeitet:

ich111

Lötkolbengott/-göttin
Das ließt sich für mich so als ob der Raid Controller nicht mit Uefi kompatibel ist und das Onboard Raid nur im Uefi modus Ohne Fallback für MBR Laufwerke läuft.
Würde da nochmal beim Boardhersteller nachfragen, aber wahrscheinlich kommst du um einen neuen Raid Controller nicht rum sofern es keine passende neue Firmware gibt.
 

Birdy84

Volt-Modder(in)
Wird das Raid vom Arcea unter Windows erkannt? Das ist doch die entscheidene Frage. Wenn der Controller beim Booten nicht auftaucht, kann man ihn eben nicht konfiguerieren. Aber das könnte man ja bei Bedarf ändern und ansonsten eben nur von UEFI Geräten booten.
 
TE
TE
geohei

geohei

Komplett-PC-Aufrüster(in)
Das ließt sich für mich so als ob der Raid Controller nicht mit Uefi kompatibel ist und das Onboard Raid nur im Uefi modus Ohne Fallback für MBR Laufwerke läuft.
Würde da nochmal beim Boardhersteller nachfragen, aber wahrscheinlich kommst du um einen neuen Raid Controller nicht rum sofern es keine passende neue Firmware gibt.
Korrekt - Der Areca RAID Controller ist nicht UEFI kompatibel.
Die letzte Firmware ist drauf.
Das Teil wird vom Hersteller nicht mehr gepflegt.

Trotzdem dachte ich bisher immer, dass CSM non-UEFI Geräte mit in den Bootvorgang einbindet, und nicht ausschließlich benutzt (also UEFI ignoriert).

Wird das Raid vom Arcea unter Windows erkannt? Das ist doch die entscheidene Frage. Wenn der Controller beim Booten nicht auftaucht, kann man ihn eben nicht konfiguerieren. Aber das könnte man ja bei Bedarf ändern und ansonsten eben nur von UEFI Geräten booten.
Ich habe jetzt einmal testweise W10 auf dem Rechner installiert (M.2 SSD). Die letzten Treiber der Areca RAID Karte sind für Vista, und ... sie funktionieren unter W10 !!!

Durch die ganzen Tests ist mir ein Missverständnis meinerseits klar geworden. Ich dachte immer, dass das BIOS die Geräte zuerst erkennen muss, damit sie später von einem aufgesetzten OS erkannt werden sollen. Das scheint nicht so zu sein. Egal, ob ich im BIOS CSM aktiviere oder nicht (mit egal welchen Unter-Einstellungen), die RAID1 HDDs und (!) das Areca RAID Volume (ich habe nur eines erstellt) tauchen unter Windows auf ... immer!

Also spielt es für W10 keine Rolle was im BIOS eingestellt ist.

Bleibt trotzdem die Frage, warum ich im BIOS mit diesen beiden Einstellungen das onboard RAID1 nicht sehe/konfigurieren kann?
Boot\CSM (Compatibility Support Module)\Lauch CSM > Enabled
Boot\CSM (Compatibility Support Module)\Lauch CSM\Boot from Storage Devices > Legacy only
Es geht bei obigen Einstellungen ja lediglich um das Booten. Das BIOS geht anscheinend davon aus, dass ich von diesem Array booten will. Will ich aber nicht. Die HDDs sollen für Daten herhalten.

Warum erlaubt mir das BIOS nicht das Array zu erstellen wenn nicht zum Booten benutzt werden soll ?!
 
Zuletzt bearbeitet:

ich111

Lötkolbengott/-göttin
Das sind alles Features, die implementiert und getestet werden müssen, zudem ist es nicht von Vorteil wenn Firmware unnötig aufgebläht ist.
Bios Support wird jetzt eh langsam gestrichen und da wird nunmal mit Sachen begonnen, die nur wenige Nutzer betreffen
 

Birdy84

Volt-Modder(in)
Ich habe jetzt einmal testweise W10 auf dem Rechner installiert (M.2 SSD). Die letzten Treiber der Areca RAID Karte sind für Vista, und ... sie funktionieren unter W10 !!!

Durch die ganzen Tests ist mir ein Missverständnis meinerseits klar geworden. Ich dachte immer, dass das BIOS die Geräte zuerst erkennen muss, damit sie später von einem aufgesetzten OS erkannt werden sollen. Das scheint nicht so zu sein. Egal, ob ich im BIOS CSM aktiviere oder nicht (mit egal welchen Unter-Einstellungen), die RAID1 HDDs und (!) das Areca RAID Volume (ich habe nur eines erstellt) tauchen unter Windows auf ... immer!
Nur, wenn du von etwas booten willst, ist das Erkennen im Bios Voraussetzung.

Also spielt es für W10 keine Rolle was im BIOS eingestellt ist.
Pauschal würde ich das so nicht sagen, in diesem Fall ist es aber richtig.

Bleibt trotzdem die Frage, warum ich im BIOS mit diesen beiden Einstellungen das onboard RAID1 nicht sehe/konfigurieren kann?
Boot\CSM (Compatibility Support Module)\Lauch CSM > Enabled
Boot\CSM (Compatibility Support Module)\Lauch CSM\Boot from Storage Devices > Legacy only
Es geht bei obigen Einstellungen ja lediglich um das Booten. Das BIOS geht anscheinend davon aus, dass ich von diesem Array booten will. Will ich aber nicht. Die HDDs sollen für Daten herhalten.

Warum erlaubt mir das BIOS nicht das Array zu erstellen wenn nicht zum Booten benutzt werden soll ?!
Das ist wahrscheinlich einfach nur eine Limitierung durch das Bios. Vermutlich wirst du darum nicht herumkommen.
 
Oben Unten