Windows 10: "AVG Antivirus Clear Uninstall" hat sich in den Bootmanager "eingegraben"

Citehtnyx

Schraubenverwechsler(in)
Hy all,
ich habe folgendes Problem mit meiner Windows 10 Installation:
Ich war der Meinung, dass ich mal AVG Antivirus auf meinem PC installiert hatte und wollte eventuelle Reste entfernen. Also habe ich AVG Clear runtergeladen und ausgeführt. Der Computer sollte anschließend im abgesicherten Modus neu gestartet werden. Bei diesem Neustart erschien plötzlich ein schwarz/weißes Bootmenü mit zwei Optionen: 1. Windows 10, und 2. AVG Antivirus Clear Uninstall.
Ich habe Option 2 gewählt, dann aber beim Login-Screen abgebrochen weil ich mich erinnert habe, dass ich nicht AVG, sondern AVAST installiert hatte (ich Idiot!). Also habe ich den PC neu gestartet und Option 1 gewählt und normal Windows 10 gestartet. Anschließend habe ich die Datei "AVGClear.exe" (?) vom Desktop gelöscht und "msconfig" aufgerufen, um den AVG-Eintrag im Bootmanager wieder zu entfernen. Das hat auch soweit funktioniert, allerdings hat sich dadurch im msconfig-Reiter "Allgemein" die "Systemstartauswahl" auf "Benutzerdefinierter Systemstart" umgestellt.
Jetzt habe ich das Problem, dass ich nicht mehr auf "Normaler Systemstart" umstellen kann, ohne dass im Reiter "Start" der Eintrag "AVG Antivirus Clear Uninstall" wieder erscheint. Sobald ich diesen wieder lösche, schaltet sich im Reiter "Allgemein" die "Systemstartauswahl" wieder auf "Benutzerdefinierter Systemstart" um.
Was ich schon versucht habe: Ich habe im Dezember (lange vor der Aktion mit AVGClear) eine Sicherung des Bootmanagers über die Kommandozeile erstellt ("bcdedit /export C:\Bootmanagersicherung"). Diese Sicherung habe ich wieder importiert ("bcdedit /import C:\Bootmanagersicherung). Allerdings bleibt das Problem bestehen.
Kann mir jemand erklären, wie ich den Eintrag "AVG Antivirus Clear Uninstall" dauerhaft aus dem Bootmanager entfernen kann, sodass ich in "msconfig" wieder auf "Normaler Systemstart" umstellen kann, ohne dass das Bootmenü erscheint? Oder muss ich einfach damit leben, dass ich im Reiter "Allgemein" die Option "Benutzerdefinierter Systemstart" ausgewählt lassen muss? Das kann ja eigentlich nicht sein, oder?
Danke Euch im Voraus!
C.
 
N

NatokWa

Guest
Das Ding einfach mal durchlaufen lassen fällt dir nicht als Option ein oder ? Das merkt schon wenn das was es löschen soll nicht da ist und entfernt sich dann (wie bei erfolgreichem Vorgang) danach selbst.
 
TE
TE
C

Citehtnyx

Schraubenverwechsler(in)
Das Ding einfach mal durchlaufen lassen fällt dir nicht als Option ein oder ?
Das habe ich natürlich ausprobiert, da ich die AVGClear.exe (oder wie auch immer die Datei hieß) aber vom Rechner gelöscht habe passiert, wenn ich in diesen "AVG Antivirus Clear Uninstall"-Modus boote, einfach nichts. Ich sehe einen leeren Desktop, es laufen keine Prozesse, alles was ich machen kann ist Neustart und danach ist dasselbe Bootmenü wieder da. Ich kriege es nur weg wenn ich "msconfig" öffne und den Eintrag aus "Start" lösche, aber dann stellt sich im Reiter "Allgemein" wie beschrieben die Option "Normaler Systemstart" automatisch auf "Benutzerdefinierter Systemstart" um.
Gibt es keinen "bcdedit"-Befehl, mit dem ich diesen Bootmenüeintrag dauerhaft entfernen kann, sodass ich wieder auf "Normaler Systemstart" umstellen kann ohne das Bootmenü angezeigt zu bekommen?
Immerhin habe ich schon die Bootmanager-Sicherung aus dem Dezember wieder importiert, nicht mal das hat dabei geholfen den Eintrag wieder zu entfernen...
 
Zuletzt bearbeitet:

Dooma

Freizeitschrauber(in)
bcdedit hast doch schon gefunden, damit kann man das was du willst doch machen.

cmd als admin starten.
bcdedit /export c:\bcdbackup
bcdedit /v
bcdedit /delete {identifier}

wenn auch noch EFI Einträge gelöscht werden müssen dann "bcdedit /enum firmware" nutzen.

Ich hoffe du weisst wass du da machst, löscht du den falschen Eintrag fährt das System nicht mehr hoch!!!
 
TE
TE
C

Citehtnyx

Schraubenverwechsler(in)
Danke Dooma, mit dem Befehl "bcdedit /delete {identifier}" konnte ich den Eintrag löschen. Klar, "bcdedit" hatte ich schon gefunden, ein "bcdedit /?" hätte mich wahrscheinlich auch selbst auf die Lösung gebracht, aber auf die Idee bin ich nicht gekommen.
Mich wundert nur, dass der Import meiner alten Sicherung das Problem nicht behoben hat. Genauso wundert es mich, dass ich den Eintrag nicht einfach mittels "msconfig" löschen konnte, sondern nur über die Kommandozeile. Aber egal.
Nochmals vielen Dank, der Eintrag ist jetzt weg und ich kann wieder auf "Normaler Systemstart" umstellen.
 
Zuletzt bearbeitet:
Oben Unten