• Hallo Gast, du kaufst gerne günstig ein und erfährst oft vor deinen Freunden von interessanten Angeboten? Dann kannst du dein Talent als Schnäppchenjäger jetzt zu Geld machen und anderen PCGH-Lesern beim Sparen helfen! Schau einfach mal rein - beim Test der Community Deals!

Von AHCI auf RAID wechseln ohne Neuinstallation

tommy-n

PC-Selbstbauer(in)
Hallo zusammen,

ich stehe hier gerade vor einem kleinen Problem und mir sind irgendwie die Ideen ausgegangen :(.

Und zwar geht es um den PC aus meiner Signatur. Ich habe also eine ICH8R Southbridge, an der bisher eine einzelne Festplatte im AHCI Modus gearbeitet hat. Nun habe ich vier zusätzliche Festplatten eingebaut, welche ich gerne für Backups und wichtige Daten verwenden möchte und welche dafür im Raid 5 betrieben werden sollen. Also die ICH8R unterstützt Raid 5 mit vier Festplatten, allerdings bekomme ich es nicht zum laufen.

Zuerst habe ich im Windows einfach nur den Intel Matrix Storage Manager installiert, allerdings lässt dieser mich keine Raid-Arrays anlegen. Problem ist da wie ich mal annehme das als Treiber ein SATA AHCI Treiber installiert ist und ich allerdings einen SATA RAID Treiber brauche. Mein erster Versuch war diese manuell zu erzwingen, aber irgendwie sind alle Treiber von Intel die ich auswählen kann SATA AHCI Treiber (die RAID Treiber scheinen ausgeblendet zu sein, obwohl ich auch nicht kompatible Treiber anzeigen lasse).

Danach habe ich versucht den Standard Treiber zu installieren, allerdings ist Windows danach weder hochgefahren wenn ich die ICH8R im AHCI noch im RAID Modus betrieben habe und genausowenig fährt es hoch wenn der AHCI Treiber installiert ist und ich die Southbridge im RAID Modus betreibe. Aber das war ja zu erwarten.

Hat also irgendjemand einen Tipp für mich, wie ich nachträglich auf Raid wechseln kann, wenn ich das Betriebssystem als AHCI installiert habe? Habe keinerlei Lust auf eine Neuinstallation.
 

Wannseesprinter

BIOS-Overclocker(in)
Tommy-n,

ich habe dieses Thema nochmal von unten aufgewühlt, da ich aktuell auch in einer AHCI-Krise stecke.

Solltest du noch nicht fündig geworden sein, schau mal hier nach, Tommy-n.

Bei mir sitzt der ICH9-Controller auf meinem P35-DS4. Allerdings knabber ich auch an dem Problem. Wie hier beschrieben habe ich alles gemacht, nur leider verweigert Windows das komplett und schmeißt mich auf einen Bluescreen.

Selbst die dazugehörige Registry habe ich hier und da mal geändert, mal gelöscht und neu installiert. Muss wirklich ein komplett neues XP her? Die dazugehörige Arbeit verursacht bei mir jetzt schon Sodbrennen.

Danke im Voraus für die helfenden Beiträge.
 

vogelscheuche

PC-Selbstbauer(in)
Das Problem sollte an deinem Eintrag in der Windowsstartdatei Boot.ini liegen. Zunächst würde ich den Raidtreiber ins Windows integrieren. Anschließend im Bios auf Raid umstellen. Nun kannst du dein Raid über das Raidbios einrichten. Anschließend solltest du noch die Festplatte im Bios als erste Bootplatte wählen, die auch vorher die erste Bootplatte war, damit der Starteintrag in der Boot.ini noch stimmt. Stimmt der Pfad in der Boot.ini nicht mit dem tatsächlichen Windowspfad überein so quittiert windows dies mit einem Bluescreen beim starten. Solltest du es nicht hinbekommen die Pfade im Bios so zu wählen, wie in der Boot.ini angegeben oder umgekehrt in der Boot.ini wie im Bios gewählt, so bleibt dir wohl nur noch die Reparaturinstallation.
 
Oben Unten