• Hallo Gast, du kaufst gerne günstig ein und erfährst oft vor deinen Freunden von interessanten Angeboten? Dann kannst du dein Talent als Schnäppchenjäger jetzt zu Geld machen und anderen PCGH-Lesern beim Sparen helfen! Schau einfach mal rein - beim Test der Community Deals!

[VMware Server 2] Wie kann der gierigen VM Rücksichtnahme beigebracht werden?

The Master of MORARE

Software-Overclocker(in)
[VMware Server 2] Wie kann der gierigen VM Rücksichtnahme beigebracht werden?

Hallöchen liebe Mitfalter,

Seit einigen Tagen habe ich VMware Server 2 bei mir installiert um per Linux-SMP etwas effizienter zu falten zu können.
Dummerweise sind der Linux-SMP und die VM selbst derart gierig in Sachen Auslastung. Daher bekomme ich sie nicht so zum laufen, dass den GPUs noch etwas "Luft" gelassen wird um eine möglichst hohe ppd zu erreichen.

Im Moment bringen diese so nur etwa 50% ihrer normalen ppd zu Stande :motz:.

Was ich bereits probiert habe:

-CPU-Auslastung in der SMP-.cfg in der LinuxVM begrenzen.
-Priorität aller VM-zugehörigen Prozesse im Host OS (Vista Ultimate x64) auf das unterste Level bringen und im Gegenzug die GPU-zugehörigen Prozesse möglichst hoch setzen.

Beide Methoden werden schlichtweg von den Betriebssystemen "ignoriert"

Ich bin in der Hinsicht leider kein Einzelfall - JayX hat die gleichen Probleme und konnte sie auf dem Hostsystem (Win XP?) nichteinmal mit dem "Prozesstool Prifinnity" effektiv lösen.

Wie kann ich die Prozesslast im Linux selber regeln?
 

BiTbUrGeR

PCGH-Community-Veteran(in)
AW: [VMware Server 2] Wie kann der gierigen VM Rücksichtnahme beigebracht werden?

hm, ich habe bislang nur dann negative resultate bei der leistung der GPU gehabt wenn ich 2 clients auf der GPU laufen hatte und darauf gleichzeitig 2 kleine WU's gelaufen haben. darum habe ich das falten mit 2 consolen auf der GPU wieder dran gegeben. 2 große WU wie die 1888er gingen sehr gut. bei den kleinen war die cpu last enorm.

solange ich aber über linux den smp und in windows nur den einen gpu client laufen lassen habe war alles ok. die prozess priorität hab ich nie seperat ändern müssen
 

JayxG

Komplett-PC-Aufrüster(in)
AW: [VMware Server 2] Wie kann der gierigen VM Rücksichtnahme beigebracht werden?

wie der Master es bereits erwähnt hat, drückt meinem Opteron-sys genau der gleiche Schuh^^

Da der GPU Consolen Client ein paar mehr ppd liefert und ein klein wenig stabiler läuft, wollte ich diesen nun auch auf dem Zweitsys mit der 8800GTS installieren. Nach dem konfigurieren (F@h.cfg + hohe Priorität der Fahcores 11&14) startete ich die Console vorerst ohne die VM. Nach den ersten paar Prozent des GPU´s, wurde die VM (Priorität unter normal) bzw. der LinuxSMP gestartet.

Als die Prozessorlast auf 100% stieg, stellte die GPU-Console alldgs. ihre Arbeit sofort ein.

Erst das Beenden des LinuxSMP´s überzeugte die Console davon- ihre Arbeit wieder aufzunehmen.

Bei dem Mix aus GPU-tray & VMSMP gibt es seltsamerweise keine Probleme (ist nur ein bissl langsamer und nicht ganz stabil)

Anschliessend hab ich noch probiert die tray-cfg gegen die der Console zu tauschen, und die VM Prozesse auf niedrig bzw. GPU auf hoch- immer wieder gleiches Resultat: VM faltet- GPU idelt!

Wurde dieses Problem schon bei anderen DualCore-sys beobachtet, welche an einem VMSMP + GPU@Console arbeiten müssen?
 

nfsgame

Lötkolbengott/-göttin
AW: [VMware Server 2] Wie kann der gierigen VM Rücksichtnahme beigebracht werden?

Wenn du den Console-Client hast, dann starte ihn mal mit dem Parameter "-configonly" und gib am Punkt "Priority" "low" statt "idle" ein ;).
 

JayxG

Komplett-PC-Aufrüster(in)
AW: [VMware Server 2] Wie kann der gierigen VM Rücksichtnahme beigebracht werden?

danke für den Tip nfsgame, werd es morgen früh dann gleich mal testen- muss den "kleinen" mit der 8800er erst noch aufbauen ... der schlummert grad noch schön ... wollte eh nochmal debian 5.03 bei der Opteron VM probieren, nach dem bescheidenen Ergebnis mit Ubuntu ...

openSUSE 10.3 - 4.232GFlops

Ubuntu 8.04 - 3.817GFlops

___________________________________________
EDIT:
das mit der "Priority" hat gefunzt ... :hail: :daumen:

PS: bei der debian install gab es nur das prob, dass die Einbindung in die Windows-Domäne (muss mich da nochmal schlau machen- hab iwann keine Ruhe mehr gehabt :ugly:) nicht funktioniert hat ... momentan läuft erstmal wieder die openSUSE VM auf dem Opteron, werde mich bei debian nächstes WE nochmal ransetzen ... to be continued ...
 
Zuletzt bearbeitet:
TE
The Master of MORARE

The Master of MORARE

Software-Overclocker(in)
AW: [VMware Server 2] Wie kann der gierigen VM Rücksichtnahme beigebracht werden?

Wenn du den Console-Client hast, dann starte ihn mal mit dem Parameter "-configonly" und gib am Punkt "Priority" "low" statt "idle" ein ;).

Hatte ich vor längerer Zeit mal probiert und es hat nichts gebracht :(.
Das "low" setzt bei mir nur die Priorität in der .cfg auf 96.
 

Julian Kruck

PC-Selbstbauer(in)
AW: [VMware Server 2] Wie kann der gierigen VM Rücksichtnahme beigebracht werden?

Also benutze jetz nicht VM, aber bei Parallels Server konnte man bei der Erstellung der Virtuellen Maschine festlegen ob der host oder der gast priorität bekommt. hab dass dan auf host gestellt und funktioniert soweit auch ganz gut. Wenn aber meine TV-karte 2 sendungen gleichzeitig in Divx aufnimmt, ruckelt es beim schreiben leicht. indem ich aber die priorität von firefox, bzw icq oder skype höher gestellt habe läuft es wieder absolut flüssig(es stört aber auch nur wenn grad youtube läuft:))...soweit meine erfahrnungen, kann jetz aber nichts zum GPU-Clienten sagen...
 
TE
The Master of MORARE

The Master of MORARE

Software-Overclocker(in)
AW: [VMware Server 2] Wie kann der gierigen VM Rücksichtnahme beigebracht werden?

Hmm, also hier in dem Thread gehts ja um den SMP Clienten... Jayx hatte höchstens den bitteren nachgeschmack der Tatsache, dass die GPUs beiihm dann abschmiern.
So nen Knopf will ich auch :D.
 
Oben Unten