robocopy erkennt Dateien als "geändert"

Martin-F2000

Kabelverknoter(in)
Guten Tag,

Jetzt war ich endlich in der letzten Etappe und habe von einer extern angeschlossenen SSD ein paar Ordner mit Videodateien auf die finale 6TB-Festplatte (WD Elements aber neuformatiert) mit robocopy kopiert. Da jedoch Windows an dem Tag unbedingt Updates installieren wollte während ich in der Arbeit war, hatte ich keine Informationen mehr wie der Kopiervorgang gelaufen ist. Also habe ich den Befehl nochmal mit /l ausgeführt um alles aufzulisten und musste feststellen, dass es bei einigen Dateien "geändert" anzeigt. Also habe ich von den ganzen Dateien den CRC berechnet und bei ein paar die Zeitstempel in den Eigenschaften verglichen und es scheint wirklich alles identisch zu sein (Bis auf "Letzter Zugriff", der wird ja bei jedem Öffnen der Datei aktualisiert).

Probehalber habe ich es an meinem PC nochmal versucht und die Dateien auf eine andere externe Festplatte mit 4TB kopiert, welche noch ab Werk von WD vorformatiert war. Da ist auf einmal alles in Ordnung und es zeigt keine Dateien als "geändert" an, auf der "richtigen" Platte dagegen scheinen jetzt alle Dateien geändert und ich weiß nicht was da los ist. Ich habe jetzt höchstens noch die Befürchtung, dass es durch die Neuformatierung kommt... Ich hatte nämlich letztes Jahr einen fatalen Fehler gemacht (https://extreme.pcgameshardware.de/...tem-volume-information-ueberschrieben.614454/) und weil ich nirgends was dazu gefunden habe und mir keiner gesagt hat was ich machen soll/kann habe ich sie sicherheitshalber am PC neuformatiert. Dabei habe ich natürlich NTFS ausgewählt und alles auf Standardwerte zurückgesetzt, doch vielleicht ist es jetzt trotzdem nicht identisch mit der Werksformatierung, ich weiß ja nicht was für eine Software WD dafür intern benutzt.

Befehlt, den ich benutzt habe: robocopy E:\ D:\Zielordner /COPYALL /DCOPY:DAT /e /xd $RECYCLE.BIN /xd "System Volume Information"

Auch mit /FFT erkennt es die Dateien immer noch als geändert während in den Windows-Eigenschaften die Zeitstempel auf die Sekunde genau identisch sind.

Ich bin jetzt langsam wirklich am Ende, will seit letztem Jahr diese paar Dateien auf eine Festplatte kopieren wo sie endlich mal "archiviert" werden sollen und dann kommen ständig neue Probleme auf...

Was mache ich jetzt, ist diese Festplatte jetzt doch wirklich nicht mehr zu retten oder was?

Mit freundlichen Grüßen
 

Poulton

BIOS-Overclocker(in)
Mir fehlt da der Parameter "/MIR".
Zum Vergleich mein Skript für robocopy von Ordnern:
Code:
robocopy "D:\Ordner1" "G:\Ordner1" /E /R:1 /W:1 /MIR /ETA /TEE /MT:16 /ZB /XJ /DCOPY:T /LOG:"D:\Robocopy\robocopy_Ordner1.log"
 
TE
TE
M

Martin-F2000

Kabelverknoter(in)
Die anderen Programme hab ich jetzt noch nicht versucht, habe ja jetzt eigentlich alles drauf was hin soll nur frage ich mich was jetzt falsch ist.
Einen Virenscanner habe ich auf dem "Server" wo der eigentliche Kopiervorgang lief gar nicht, außer dem integrierten Windows Defender.
/MIR habe ich bewusst nicht benutzt weil ich bereits vorhandene, zusätzliche Dateien im Zielverzeichnis NICHT löschen will.
Das mit dem Log in eine Datei schreiben könnte ich mir aber vielleicht mal angewöhnen.
 
Oben Unten