• Hallo Gast, du kaufst gerne günstig ein und erfährst oft vor deinen Freunden von interessanten Angeboten? Dann kannst du dein Talent als Schnäppchenjäger jetzt zu Geld machen und anderen PCGH-Lesern beim Sparen helfen! Schau einfach mal rein - beim Test der Community Deals!

PCIe Belegung bei 2/3 GPUs?

ronde

PC-Selbstbauer(in)
Hallo Leute,

ich muss gerade beruflich viel Videoarbeit und 3D-Rendering machen, wozu ich möglichst viele CUDA Cores benötige. In meinem aktuellen System mit einem Ryzen 5950X und dem Asus ROG Strix X570-E habe ich eine EVGA 3080 XC3 Ultra. Als Netzteil hab ich das beQuiet 1200W Straight Power. Läuft auch alles prima soweit.

Ursprünglich wollte ich zwei 3080 in das System packen, aber der Markt ist ja immernoch ziemlich schlecht.
Ich hatte aber Glück und konnte zwei EVGA 3060 XC zu einem annehmbaren Preis ergattern.

Eine 3060 möchte ich definitiv in dem System verbauen. Evtl. auch die zweite, falls mein Bruder diese doch nicht möchte.

Bin etwas unsicher bezüglich der PCIe Belegung und hätte kurz paar Fragen dazu:

1) Wenn ich die 3080 und eine 3060 verbaue, macht es vermutlich Sinn, den ersten und zweiten Slot zu nehemn, damit diese auf x8 laufen (siehe auch hier die Belegung)
Die sollten mit x8 immernoch schnell genug sein, ist ja Gen4. Oder geht da viel Leistung bei der 3080 verloren wenn die nicht mehr auf x16 läuft?
Capture2.PNG

2) Falls ich die zweite 3060 auch noch verbaue, dann hätte die nur x4 - verliert man damit spürbar an Leistung?

3) Das Netzteil mit 1200W sollte die 3080 und die 3060 ja packen - würde das auch noch für die zweite 3060 reichen? Also 3080 + 3060 +3060?

(Und nur zum Verständnis ich benutze hauptsächlich den Rendered Octane, für den sind hauptsächlich die CUDA Cores wichtig und man kann problemlos mehrere GPUs kombinieren)

Danke für Eure Hilfe!
 

HisN

Kokü-Junkie (m/w)
Also bevor wir jetzt raten ....
Du hast alle Mittel, die Du brauchst um die ersten beiden Fragen zu beantworten doch an der Hand.

1) Schalte jetzt im UEFI den Slot für Deine Graka auf Gen3 und Du merkst sofort was Deine Graka an Leistung verliert in Deiner Software und Deinen Settings.
Ganz ohne uns.
2) Schalte jetzt im UEFI den Slot für Deine Graka auf Gen2 und Du merkst sofort was Deine Graka an Leistung verliert in Deiner Software und Deinen Settings.
Ganz ohne uns.

Zur Erklärung:
Gen3 PCIe x16 = Gen4 PCIEe x8
Gen2 PCIe x16 = Gen4 PCIe x4


3) Energie-Messgerät (genug Geld scheint ja vorhanden^^. Kostet nur nen 10er).
Auch da isses schwer für uns zu raten, was Deine Grafikkarten beim Rendern verbrauchen. UND ... Du hast mit dem Power-Target ein Mittel in der Hand die Leistungsaufnahme zu begrenzen, FALLS es wirklich zu Engpässen kommen sollte. Ich weiß, blöde Antwort, die Du nicht hören möchtest. Aber eventuell findest Du ja hier einen der auch rendert und exakt die gleiche Hardware-Konfiguration betreibt^^).
 
Zuletzt bearbeitet:
TE
R

ronde

PC-Selbstbauer(in)
Hey,
danke für Deine Antwort.

Stimmt, auf die Ideen bin ich garnicht gekommen. Ich kann einfach mal im UEFI auf Gen3 stellen und dann seh ich konkret, wie groß der Unterschied ist. Danke für den Tipp. Dann teste ich das einfach mal.

Das mit dem Energie-Messgerät hab ich auch nicht auf dem Schirm gehabt, das werde ich auch mal probieren :))
 

MezZo_Mix

PC-Selbstbauer(in)
Also bevor wir jetzt raten ....
Du hast alle Mittel, die Du brauchst um die ersten beiden Fragen zu beantworten doch an der Hand.

1) Schalte jetzt im UEFI den Slot für Deine Graka auf Gen3 und Du merkst sofort was Deine Graka an Leistung verliert in Deiner Software und Deinen Settings.
Ganz ohne uns.
2) Schalte jetzt im UEFI den Slot für Deine Graka auf Gen2 und Du merkst sofort was Deine Graka an Leistung verliert in Deiner Software und Deinen Settings.
Ganz ohne uns.

Zur Erklärung:
Gen3 PCIe x16 = Gen4 PCIEe x8
Gen2 PCIe x16 = Gen4 PCIe x4


3) Energie-Messgerät (genug Geld scheint ja vorhanden^^. Kostet nur nen 10er).
Auch da isses schwer für uns zu raten, was Deine Grafikkarten beim Rendern verbrauchen. UND ... Du hast mit dem Power-Target ein Mittel in der Hand die Leistungsaufnahme zu begrenzen, FALLS es wirklich zu Engpässen kommen sollte. Ich weiß, blöde Antwort, die Du nicht hören möchtest. Aber eventuell findest Du ja hier einen der auch rendert und exakt die gleiche Hardware-Konfiguration betreibt^^).
Wenn alle wie du denken würden, dann würde es keine Foren mehr geben.
 

MezZo_Mix

PC-Selbstbauer(in)
So einfach ist das ja nicht. Für games gibt es da ja vermutlich Erfahrungswerte, aber für bestimmte Programme eher weniger.
@HisN Anleitung zur Selbsthilfe ist deswegen genau richtig.
Stimmt schon, ist ja auch nicht schlecht gemeint oder so. Aber Foren sind halt dazu da um Fragen zu stellen die für den einen logisch sind und für den anderen eben erstmal nur ein Fragezeichen ergeben. Würden wir alle so denken wären 90% der PC-Foren tod. :D
 
TE
R

ronde

PC-Selbstbauer(in)
Danke auf alle Fälle für die Hilfe, ich hab das gerade getestet und komme auf sehr ähnlich Ergebnisse in den Benchmarks. In Octanebench (der Benchmarktest des Renderers und wichtigste Anwendung für mich) ist der Score identisch zwischen Gen4 and Gen3 - und selbst der Gen2 Score ist nur minimal langsamer gewesen (noch nichtmal 1%).

Ich hab auch in den Nvidia Einstellungen nachgeschaut, dort steht unter Bus "PCI Express x16 Gen2" - gehe also davon aus, dass die GPU in der Tat auf weniger Lanes läuft. Erstaunlich, dass der Unterschied so gering ist in der Performance.
Capture.PNG

Gibt aber sicherlich einige Anwendungen/Games wo man einen Unterschied spüren würde.
 

Lexx

Lötkolbengott/-göttin
Foren sind halt dazu da um Fragen zu stellen ...
... wären 90% der PC-Foren tod. :D
Wäre schön, wenn sie so tot wären.
Statt Foren gäbs auch noch... Google.
Das für 99 % der Probleme bereits auch Lösungen bietet.

Aber - frei nach Clint Eastwood - zerst deppat schreiben und
dann erst denken, bzw. sich mit seiner Hardware zu beschäftigen,
scheint neuerdings Zeitgeist oder Bildungsauftrag zu sein.
 
TE
R

ronde

PC-Selbstbauer(in)
Wäre schön, wenn sie so tot wären.
Statt Foren gäbs auch noch... Google.
Das für 99 % der Probleme bereits auch Lösungen bietet.

Aber - frei nach Clint Eastwood - zerst deppat schreiben und
dann erst denken, bzw. sich mit seiner Hardware zu beschäftigen,
scheint neuerdings Zeitgeist oder Bildungsauftrag zu sein.
Also um ehrlich zu sein, ich bin kein Hardware Experte und mir war garnicht klar, dass ich durch das umstellen von Gen4 auf Gen3/Gen2 auswählen kann, wieviele Lanes benutzt werden.

Die Info hab ich auch sonst nirgends gefunden, als ich gesucht habe wie groß der Unterschied für mein System sein könnte in Bezug auf die PCIe Slots/Lanes. Daher war der Tipp für mich viel Wert - und dafür sind doch auch Foren da - dass man fragen kann, wenn man sich in gewissen Bereichen nicht bis ins Detail auskennt. Ich hab z.B. ins Mainboard Handbuch geschaut, daraus konnte ich aber nicht ableiten, dass mit dem Umstellen auf Gen3/Gen2 ich einfach selber testen kann, wie groß der Unterschied ist.

Ich will jetzt garnicht, dass mein Thread hier zu soviel Diskussionen führt - nutzt die Zeit lieber und macht etwas das euch gut tut :) Danke auf alle Fälle für Eure Hilfe!
 

Lexx

Lötkolbengott/-göttin
Also um ehrlich zu sein,
War ja auch nicht an Dich gerichtet.
Die Frage war schon ok und durchaus berechtigt.
Ist ein echter Spezialfall. (Herausfordernd sozusagen.)

Meinte eher den Zitierten, (Fach-)Foren sind kein "illuminierter" Quasselstammtisch,
die es mit geistigen Abfall (und intellektueller "Unterforderung") zuzumüllen gilt.

In diesem Sinne, gut, dass "es nun blubbert"...
 

HisN

Kokü-Junkie (m/w)
Wenn alle wie du denken würden, dann würde es keine Foren mehr geben.
Wenn alle denken würden wie ich, würden wir nur noch mit Links zu schon beantworteten Threads mit der gleichen Frage linken und den Hinweis geben: Hätte man auch mit Google gefunden. (Aber, Du hast mich erwischt, ich bin auch manchmal zu faul zum Suchen^^)
Aber es denken wohl alle wie Du, das Foren ein Google für ganze Sätze ist. Und wir uns gerne 1000x wiederholen. Deshalb gebe ich Hilfe zur Selbsthilfe, anstatt Antworten vorzukauen, so wie Du das gerne hättest.
Hilft meiner Meinung nach mehr als gabel fertige Bissen zu servieren, bei denen man den Kopf abschalten kann.
Also nur für Deinen Hinterkopf: Ein Forum ist eine Diskussionsplattform im Grunde genommen. Kein Google für ganze Sätze.
Den Foren gehen nämlich irgendwann die Antwortgeber aus, weil sie keinen Bock mehr haben ewig die gleichen Fragen zu beantworten. Oder glaubst Du das macht in irgend einer Form Spaß? Es muss beiden Seiten Spaß machen oder bezahlt werden. Aber die Seite haste Du noch nie gesehen, oder? Wir sind alles nur Antwort-Knechte für Dich. Richtig?
1000x das Gleiche schreiben empfinde ich jedenfalls nicht als Lustig und für andere Googeln/Sufu bedienen auch nicht.

Ich frag mich, warum mir sowas immer Leute vorwerfen die gerade mal 200 Antworten hier im Forum verfasst haben. Hast Du 20.000 geschrieben (von denen sich 18.000 wiederholt haben), dann reden wir nochmal über meine Art Antworten zu geben.

Traurig?
Traurig!

@ronde
Du hast alles richtig gemacht. Du hast kapiert was ich will und dabei noch was gelernt.
Nenn mich Oberlehrer, passt schon :-)
 
Zuletzt bearbeitet:

TheGermanEngineer

BIOS-Overclocker(in)
Ich hab auch in den Nvidia Einstellungen nachgeschaut, dort steht unter Bus "PCI Express x16 Gen2" - gehe also davon aus, dass die GPU in der Tat auf weniger Lanes läuft. Erstaunlich, dass der Unterschied so gering ist in der Performance.
Anhang anzeigen 1361507

Gibt aber sicherlich einige Anwendungen/Games wo man einen Unterschied spüren würde.
Na, das kann man aber nicht ganz so stehen lassen :ugly:
Sie läuft weiterhin mit 16 Lanes. Nur die Übertragungsrate pro Lane ist deutlich geringer. Aber ich denke mal das du das damit meintest. Und praktisch hast du damit ja PCI Express x4 Gen4 simuliert.

Im Grunde ist es eine einfache Rechnung: Was kann mich in meinem Workflow limitieren? Die GPU an sich? Der Speicher der GPU? Die Verbindung, sprich die Übertragungsrate zur Plattform? So gesehen ist das ideal für dich, da du planst die Übertragungsrate zu reduzieren, diese aber praktisch keinen Einfluss auf die Performance hat. Die Daten sind also schneller da, als sie verarbeitet werden. Das ist bei Spielen in der Regel übrigens auch so.
 
TE
R

ronde

PC-Selbstbauer(in)
Hallo Leute,
ich bräuchte nochmal kurz eure Hilfe.

Ich hab nun beide GPUs eingebaut, die 3060 im ersten Slot, die 3080 im zweiten.

Leider bekomme ich jetzt aber kein Bild, egal welchen Ausgabe ich nehme, hab beide GPUs an unterschiedlichen Ausgängen (HDMI / Displayport) probiert. Er fährt hoch ich bekomme aber kein Bild, auch nicht für das BIOS.

Muss ich irgendwas machen weil sich die Hardware geändert hat wie ein BIOS reset oder so? Ich bin davon ausgegangen dass ich die zweite Karte einfach nach plug and play einbauen kann?!

Und bin gerade nur am Handy, kann daher nicht so gut googlen, würde mich über eure Hilfe freuen.
 
TE
R

ronde

PC-Selbstbauer(in)
Die Diagnose LED vom Mainboard sagt AA und das heißt "Reserved for ASL" und soviel ich weiß heißt es dass keine Probleme erkennt. Oder?
Ob er hochfährt bin ich mir nicht ganz sicher, die LEDs von meinem Keyboard gehen dreimal an und aus, ähnlich wie wenn er hochfährt. Kann aber auch gut sein dass er nicht bootet.
Ich hab auch schon mal beide GPUs vom Storm getrennt dass nur eine angeschlossen ist aber ohne Erfolg.
 

HisN

Kokü-Junkie (m/w)
Ob er wirklich hochfährt siehst Du an der HDD-LED (im Notfall die aufm Mainboard). Die Flackert ja ne ganze Weile wenn der Rechner tatsächlich booten würde.

Und wenn er das macht, dann gibt auch irgend ein Device irgendwo ein Bild aus, sonst würde er nicht hochfahren, oder wenigstens BEEP machen (Kein Monitor angeschlossen). Was man natürlich nicht hört, wenn kein Speaker drann ist^^

Hast Du mal die neue Graka "alleine" getestet ob die in Ordnung ist?
 
TE
R

ronde

PC-Selbstbauer(in)
Okay, also ich hab jetzt nochmal alles an und abgesteckt an der neuen und alten Grafikkarte und auch nochmal geprüft, dass beide feste im Slot sitzen. Ich bin jetzt im Windows mit der 3060 die im ersten Slot ist.
Aber leider erkennt er die 3080 nicht - werder im Bios noch im Windows. Im Bios hab ich bei den PCIe Slots Auto gewählt, das sollte der dann ja automatisch erkennen. Aber da steht nur das wenn ich auf GPU gehe:

1.jpg

Eine Optione zum Umstellen gibts aber auch nirgends, ich kann nur die Gen ändern bei den PCIe Slots.

Im Windows steht das Capture.PNG

Hast du eine Idee was ich noch machen kann? Die 3080 hat auch Strom und leuchtet.
 

HisN

Kokü-Junkie (m/w)
Wie alt ist das Bios?
Letztens hatten wir einen mit einem neuen B550er Chipsatz, der brauchte ein Bios-Update um eine 2. Karte laufen zu lassen. (Was mich wundert, aber groß ist die Welt).

Und die Graka läuft auf 1x ?
Die sitzt nicht richtig oder hat nen Schuss.

160301223549guktl.png


Mit F12 macht man bei Asus übrigens Screenshots vom Bios^^
 
TE
R

ronde

PC-Selbstbauer(in)
Also Bios ist vom Februar die Version 3405 - meinst ich soll mal Updaten?

Aber komisch das die nur 1x läuft oder? Im Windows wurde es ja aber korrekt angezeigt mit PCIe Gen4 und hab auch ein Benchmark laufen lassen bei Octanebench wo die Karte genau da liegt wo sie sein sollte.
Also ich kann die kaum noch fester in den Slot drücken, ich prüf das gleich nochmal. Ich tausch vielleicht mal die Karten und die Slots und Steck die 3080 wieder in den ersten Slot.

// Update:

Ich hab jetzt mal die Karten getauscht - die 3080 wieder im ersten Slot auch gleich erkannt und mit x16 Native angezeigt im Bios. Die 3060 im zweiten Slot wird aber nicht angezeigt, weder im Bios noch im Windows.

Hab dann das aktuelle stable Bios ufgespielt - aber ohne Verbesserung. Bei den PCIe Slots hab ich alles auf Auto - ich find auch keine weiteren Settings wo ich sonst etwas verstellen könnte. Ich kann nur auf Gen 4/3/2/1 stellen. Gibts da vll eine Einstellung was dem 1. Slot alle Lanes gibt und den 2. Slot blockt?

// Update 2:

So hab die Karte jetzt in den 3. Slot gesteckt - musst dafür aber den Thermal Sensor vom Mainboard abstecken - ist das schlimm? Sonst hätte dir Karte nicht reingepasst.

Im Bios wird diese auch angezeigt, ebenso im Windows:


3.jpg

Die läuft halt nur x4. Die Frage ist immernoch warum der 2. Slot nicht geht, bzw. die Karte nicht erkannt wird. Die Karte scheint zu funktionieren - ich vermute es liegt an dem 2. Slot - entweder an irgendwelchen Bios Einstellungen - oder ist der Slot vielleicht kaputt? :/
 
Zuletzt bearbeitet:

HisN

Kokü-Junkie (m/w)
Hast Du ne Einstellung im Bios die verhindert dass der 2. Slot die 8 Lanes vom 1. Slot bekommt?
Mir würde da jetzt nix einfallen, normalerweise ist das ein Automatismus. Wenn keine Lanes am 2. Slot ankommen, wird da auch nix erkannt.

Slot "kaputt" ist eher selten. Schau halt mal von oben rein, ob alle Pins gerade sind und kein Dreck drinne ist.
Der PCIe-Controller ist übrigens ein Teil der CPU. Wenn es ein Problem gibt, würde ich ihn eher bei der CPU als beim Board suchen, denn wenn ein oder zwei Pins im CPU-Sockel verbogen sind, die zu diesem Slot gehören ....

Aber das ist jetzt auch nur raten.
 
TE
R

ronde

PC-Selbstbauer(in)
Okay vielen Dank für Deine Hilfe!

Das mit dem Bios war auch meine Idee, hab da aber alles auf den Standard Einstellungen - hab bei PCIe alles auf Auto, die einzigen Optionen für die Slots sind dass man die Gen ändern kann anstatt Auto. Das hatte ich auch schon probiert aber ohne Erfolg. Ich tendiere auch fast dazu dass es eine Bios Sache ist, aber weiß nicht weiter.

Den Slot werde ich morgen nochmal checken.

Update:
Ah ich hatte gerade noch ein Gedanke. Beide M2 Slots sind belegt mit SSDs - könnte es daran liegen? Das die irgendwelche Lanes wegnehmen oder so? Wenn ich die Tabelle aus dem Manual (siehe ersten Post) aber richtig verstehe, dürfte das nicht das Problem sein?!
 
Zuletzt bearbeitet:
Oben Unten