• Hallo Gast, du kaufst gerne günstig ein und erfährst oft vor deinen Freunden von interessanten Angeboten? Dann kannst du dein Talent als Schnäppchenjäger jetzt zu Geld machen und anderen PCGH-Lesern beim Sparen helfen! Schau einfach mal rein - beim Test der Community Deals!

PCGHX intern: Umstellung auf neue Forensoftware am Montag (7. September)

Stryke7

PCGHX-HWbot-Member (m/w)
Zum Löschen geht doch "Strg+A" und "Entf"
An Handy einfach lang drauklicken und "Alles auswählen" und dann einmal löschen. Funktioniert bei mir perfekt!
Das ist genau der Punkt: Das dauert EWIG!

Das dauert so lange, dass ich schneller einen zweiten Computer hochfahren und den Post dort neu schreiben könnte.


Zitier mal den Startpost hiervon, und versuche ihn wieder aus dem Editor zu löschen, dann siehst du was ich meine:



Edit: Ich habe gerade mal die Zeit gestoppt: Strg+A , Entf dauert ca 35 Sekunden, wenn ich den Startposts des Laufzeit-Threads zitiert habe.

Das ist viel zu lang. Da ist offenbar irgendwas an Entwurf-Implementierung kaputt.
 

ZAM

Wartungsdrohne
Teammitglied
Kann man vielleicht abschalten, dass das Forum sich Entwürfe von Beiträgen merkt, wenn man die Seite geschlossen und neu aufgerufen hat?

Man kann Entwürfe nur generell abschalten und den Zeitrahmen definieren. Aber die Wunschabschaltung gibt es nicht. Die Entwurfsfunktion ist vom Entwickler unter anderem so gedacht, dass man bei Browser-Abstürzen oder versehentlichem Seitenwechsel nicht den Inhalt verliert.
 

Stryke7

PCGHX-HWbot-Member (m/w)
Man kann Entwürfe nur generell abschalten und die Anzahl der gemerkten, sowie Zeitrahmen definieren. Aber die Wunschabschaltung gibt es nicht.
Aber die Funktion ist offensichtlich kaputt.

Probiers mal selbst aus, ein wirklich langes Zitat wieder aus dem Editor zu löschen.
 

ZAM

Wartungsdrohne
Teammitglied
Ich habe das auf dem Desktop probiert und Firefox 86 rechnet daran 35 Sekunden, bevor der Post aus dem Textfeld gelöscht ist.
Kann ich nicht reproduzieren, ist fix. Muss eher ein lokales Problem sein.

Das hier gibt es noch als Alternative:
1615897646272.png
 

Stryke7

PCGHX-HWbot-Member (m/w)
Ich kann das hingegen auf 3 verschiedenen Rechnern reproduzieren, unter Chrome und Firefox, in Ubuntu, Windows 7 und Windows 10. Letzteres war ein bisschen schneller aber immer noch sehr langsam.


ZAM bist du im gleichen lokalen Netz wie die Forenserver?

Vielleicht habt ihr einen Bottleneck in der Netzwerkanbindung des zuständigen Servers?
 

flx23

Software-Overclocker(in)
Das ist genau der Punkt: Das dauert EWIG!

Das dauert so lange, dass ich schneller einen zweiten Computer hochfahren und den Post dort neu schreiben könnte.


Zitier mal den Startpost hiervon, und versuche ihn wieder aus dem Editor zu löschen, dann siehst du was ich meine:



Edit: Ich habe gerade mal die Zeit gestoppt: Strg+A , Entf dauert ca 35 Sekunden, wenn ich den Startposts des Laufzeit-Threads zitiert habe.

Das ist viel zu lang. Da ist offenbar irgendwas an Entwurf-Implementierung kaputt.
Also auf meinem Handy (mate 10 pro) mit Chrome dauert es keine 5 Sekunden :ka:
 

kaepteniglo

Freizeitschrauber(in)
Ich kann das hingegen auf 3 verschiedenen Rechnern reproduzieren, unter Chrome und Firefox, in Ubuntu, Windows 7 und Windows 10. Letzteres war ein bisschen schneller aber immer noch sehr langsam.


ZAM bist du im gleichen lokalen Netz wie die Forenserver?

Vielleicht habt ihr einen Bottleneck in der Netzwerkanbindung des zuständigen Servers?

Hab das ganze jetzt auch mal ausprobiert:
Hab den den Beitrag zitiert, dann das Zitat markiert und entfernt.

Dauert keine Sekunde am Desktop.

Umgebung: Windows 10, Edge 89.0.774.54, Telekom Leitung mit ~40 MBit.
 

PCGH_Torsten

Redaktion
Teammitglied
Ohne WYSIWG klappt das sogar in Millisekunden. :-)
Aber das Mach(t)werk enthält wirklich extrem viele Formatierungen. Wenn da eine ineffiziente Javascript-Engine die Ansicht während des Editierens aktualisieren möchte...
 

Stryke7

PCGHX-HWbot-Member (m/w)
Ohne WYSIWG klappt das sogar in Millisekunden. :-)
Aber das Mach(t)werk enthält wirklich extrem viele Formatierungen. Wenn da eine ineffiziente Javascript-Engine die Ansicht während des Editierens aktualisieren möchte...
In der Tat, wenn ich auf BBCode umschalte, ist das sofort weg. So wie man das von ein paar KB Text erwarten würde.

Dann ist das offenbar ein Problem des WYSIWYG Editors.
 

ZAM

Wartungsdrohne
Teammitglied
In der Tat, wenn ich auf BBCode umschalte, ist das sofort weg. So wie man das von ein paar KB Text erwarten würde.

Dann ist das offenbar ein Problem des WYSIWYG Editors.
Im Vergleich zu der veralteten ckeditor-Grütze im alten VB-Forum ist der Froala Editor kein Problem und ein Traum.
 

ZAM

Wartungsdrohne
Teammitglied
Habe eben einen Test gemacht mit speziell großen Tabellen und hatte auch ~4 Sekunden bis der Inhalt weg war.
Tabellen-Parsing im Editor-Fenster im WYSIWYG-Mode ist zwar fuckly, aber solche Monster wurden garantiert von den Entwicklern nie vorgesehen und sind auch nicht Standard.
Da muss man halt leider (erst mal) mit den Limitierungen des Parsers und der Javascript-Engine leben und das so hinnehmen.
 

Stryke7

PCGHX-HWbot-Member (m/w)
Nun, mit dem Wissen dass ich einfach kurz auf BBCode umschalten kann, ist das für mich nun auch nicht mehr so dramatisch.

Ich bin trotzdem neugierig, warum das im WYSIWYG Editor so grausam langsam ist, aber für mich ist das nicht mehr wichtig genug um mehr Zeit dafür aufzuwenden.
 

ZAM

Wartungsdrohne
Teammitglied
Ich bin trotzdem neugierig, warum das im WYSIWYG Editor so grausam langsam ist
Das Speichern von Drafts passiert eigentlich nur alle 60 Sekunden (sofern Fokus auf den Editor ist), oder wenn man es auslöst. Aber offenbar auch, wenn man bspw. Tabellen einbaut und innerhalb der Tabellen etwas ändert. Aber beim Übermitteln entsteht kein Lag - selbst bei maximaler Datenlänge.
Das Live-Rendering ist das, was im Editor alles langsam macht. Wir haben bspw. die Markup-Funktion des Editors nie aktiviert, die würde noch mehr Performance im Javascript-Parser fressen, weil die bspw. Live *text* zu text umwandelt.
 

ZAM

Wartungsdrohne
Teammitglied
Werden eigentlich die Cookies automatisch gelöscht?
Muss sie alle ~5 Tage neu bestätigen.
Nicht von uns - aber nach einem gewissen Zeitraum (jedoch länger als 5 Tage), kommt es wieder, wenn man alles abgelehnt hat. Außerdem kommt es wieder, wenn sich etwas in der Haupt-Liste durch den Werbevermarkter geändert hat.
Wir müssen es leider auch für Online-Abonnenten ausspielen, denn wenn man sich ausloggt wäre das wieder alles aktiv.
Das geht übrigens deutlich schlimmer, habe ich schon oft Webseiten gesehen, da bekommt man bei jedem Klick auf der Seite das Ding wieder, wenn man nicht zugestimmt hat. Oder CMPs die auch beim Öffnen der Einstellungen alles aktiv haben und man alles einzeln wegklicken muss und keinen Ablehnen-Button in den Einstellungen anbieten.
 

Stryke7

PCGHX-HWbot-Member (m/w)
Ich will zur Abwechslung mal was positives loswerden: Die Darstellung von Quellcode ist absolut wunderschön. Gut lesbar, richtig formatiert, und ein sehr angenehmes Syntaxhighlighting! :)
 

ΔΣΛ

PCGH-Community-Veteran(in)
Mir ist immer wieder aufgefallen das neue Nutzer ihre Themen in Unterforen unterbringen können, wo man keine Antwort darauf geben kann, wie zum Beispiel in "Anleitungen, wichtige Praxis- und Test-Artikel", heute sind mir bereits wieder zwei neue Themen in diesem Unterforum aufgefallen.

Wäre es nicht besser, wenn man als normaler Nutzer keine Themen dort platzieren kann?
 

chill_eule

Volt-Modder(in)
Ja, bitte.

Irgendwie erstellen jungfräuliche User immer wieder Themen in irgendwelchen Unterforen, wo wir dann nicht antworten und helfen können :ka:
 

ZAM

Wartungsdrohne
Teammitglied
Der Importer hat damals nicht alle Rechte aus dem VB-Forum in Xenforo korrekt abgebildet oder Abbilden können.
Einfach ein Hinweis, dass die Rechte nicht mehr passen (und vielleicht wie es vorher war) reicht aus.
 

chill_eule

Volt-Modder(in)
Huhu!
Habe seit ein paar Tagen oftmals probleme, die sich dann in dieser Meldung äußern:
1617000780497.png


Ist da eurerseits irgendwas bekannt?

Habe natürlich jetzt auch zwischenzeitlich mal die cookies entfernt, und werde weiter beobachten ;)

PS: Firefox Nightly 89.0a1 zur Zeit, also kann natürlich auch am (beta-)Browser selbst liegen :ka:

*UPDATE*

Und eben wieder, 9:15 Uhr.
Hier gelesen:

Dann oben geklickt auf:
1617002239575.png


Zack, Fehlermeldung.

Eben kam sie schon nach 5 Sekunden, teilweise hat es aber auch viel länger gedauert :confused:
Direkt im Anschluss fluppt dann (erstmal) wieder alles.
 
Zuletzt bearbeitet:

Gohrbi

BIOS-Overclocker(in)
Das ist kein Feature unserer Seite - bitte nicht diesen Thread hierfür nutzen, das verwirrt nur und ist nicht hilfreich beim Protokollieren von Fehlern.
... von wo /wem ist das Feature? Ich dachte das Problem wurde hier schon mal erklärt. Ich finde das nicht mehr, auch nicht mit Suche von "Breite". Man mußte im DarkMode die Breite verändern. Trotzdem noch mal HILFE. Wenn es nicht geht, dann lasse ich es halt und die Tabellen bleiben so unübersichtlich.
 

c1i

Freizeitschrauber(in)
Ich finde das seltsam. Wenn es kein Feature dieser Seite ist, warum kann man es dann hier nutzen? Ist das nicht ein Widerspruch?
 

Olstyle

Moderator
Teammitglied
In dem Zitat auf das Zam sich bezog ging es um ein Browser Add-On welches einen Dark-Mode baut und weil es eben dafür Script Injektion betreibt auch dazu erweitert werden kann das Breitenlimit des Forums auszuschalten.
Nichts davon wird vom Betreiber hier angeboten, ergo gibt es auch keinen Support wenn es schief läuft.
Sollte es doch um ein "normales" Problem mit Tabellen gehen darf man das sicher hier thematisieren.
 
  • Like
Reaktionen: ZAM

ZAM

Wartungsdrohne
Teammitglied
Vor allem wären Link und Screenshot hilfreich. Dinge wie "Früher" und "Schalter" sagen mir nichts und ich kann hier nicht weiterhelfen.
 

Gohrbi

BIOS-Overclocker(in)
Vor allem wären Link und Screenshot hilfreich. Dinge wie "Früher" und "Schalter" sagen mir nichts und ich kann hier nicht weiterhelfen.
das ist die Tabelle .... siehe 1. und letzte Spalte, die müssen breiter sein. Oder ich beschneide die Angaben ... alle Takte und CL weglassen, das geht aber dann müßte ich die 1000 Einträge alle per Hand kürzen .....


@ZAM ... man konnte irgendwo im Darkmodus die Komplettbreite verändern .... aber ich finde es nicht mehr.
 
Zuletzt bearbeitet:

flx23

Software-Overclocker(in)
Mal ne andere Frage... Im luxx gibt es im forum oben so eine kleine glühbirne mit der man zwischen normal und Dark mode umschalten kann :gruebel:

Da die ja auf die gleiche platform setzen wäre die Frage ob man das eventuell auch hier implementieren kann (natürlich nur wenn Zeit und Kapazitäten dafür frei sind)
 

ΔΣΛ

PCGH-Community-Veteran(in)
Ich glaube vorher friert die Hölle zu :schief:
Installiere dir doch einfach die Erweiterung Dark Reader, habe ich auf dem Desktop und dem Smartphone, funtzt sauber.
Das kannst du überall nutzen, oder nur bei bestimmten Seiten, auch individuell anpassen wenn du willst :daumen:
 

ZAM

Wartungsdrohne
Teammitglied
Vielleicht übersehe ich es ja, aber kann man sich mobil nicht die Signaturen einblenden lassen?
Das ist von Xenforo nicht vorgesehen - also Mobil werden Signaturen immer ausgeblendet per CSS.
Ich hatte vor Ewigkeiten dazu mal einen Hack vorbereitet aber nie finalisiert. Jetzt ist er finalisiert - in den Einstellungen (nur eingeloggt) kann man jetzt selbst entscheiden, ob man auch Mobil Signaturen sehen will.
 

flx23

Software-Overclocker(in)
Wie gesagt, wenn ich Mein Handy drehe (Querformat) sehe ich die Signaturen.
Ist für mich zumindest ein guter work around
 
Oben Unten