• Hallo Gast, du kaufst gerne günstig ein und erfährst oft vor deinen Freunden von interessanten Angeboten? Dann kannst du dein Talent als Schnäppchenjäger jetzt zu Geld machen und anderen PCGH-Lesern beim Sparen helfen! Schau einfach mal rein - beim Test der Community Deals!

MBR Windows 7 haut nicht hin

Black_Beetle

Software-Overclocker(in)
Hey

Ich habe eine Platte mit Windows Vista und eine Platte mit Windows 7. Ich habe Windows 7 vor kurzem installiert und nun wollte ich nur noch Windows 7 benutzen. Ich habe die alte Platte mit Windows Vista ausgebaut. Leider ist es so das mein Windows 7 nicht startet sondern bekomm ich das keine bootbare Partition vorhanden ist.

Wenn ich die alte Platte mit Windows Vista ran hänge funktioniert alles aber das ist ja nicht der Sinn. Kann mir jemand sagen wie ich das hinbekomme das nur die Platte mit Windows 7 drin bleibt.

Wie mach ich das der Master Boot Record auf der Windows Platte bleibt. Kann ich diese boot.ini auf der Windows 7 Platte speichern oder so?
 

midnight

BIOS-Overclocker(in)
Werf die Vista-Platte raus und leg die 7-DVD ein, dann reparierst du das System von der DVD (da ist ein Button für "Startprobleme") und dann sollte Windows wieder ordentlich funktionieren.

so far
 
TE
B

Black_Beetle

Software-Overclocker(in)
Hab ich probiert. Wenn ich die Vista Platte raushaue und dann von CD aus starte findet er die Partition mit Windows 7 nicht.
 

Sarge_70

BIOS-Overclocker(in)
Hi,

versuch mal von der Windows DVD zu booten, und öffne nach dem Start in der ersten Anzeige die Wiederherstellungskonsole mit "R" gefolgt von "K" (oder wähle die Eingabeaufforderung in den Optionen), und gib per DOS Prompt den Befehl "fixmbr" ein, danach sollte das BS eigentlich wieder normal starten.

Wenn das nicht hinhaut, nochmal die Konsole öffnen und es mit dem Befehl "fixboot c:" versuchen. So werden die Bootdateien neu erzeugt.


Mfg
 
TE
B

Black_Beetle

Software-Overclocker(in)
Freak das hab ich auch schon alles probiert nur ändert sich nichts.

Ich habe jetzt den Befehl

bcdedit.exe eingeben und folgendes bekomm ich angezeigt



Windows Vista ist D:
Windows 7 ist C:

Wie bekomme ich nun hier d: raus?
 
Zuletzt bearbeitet:

Sarge_70

BIOS-Overclocker(in)
Was passiert, wenn du z.b versuchst W7 neu zu installieren, kannst du dann irgendwie im Setup-Menu auf die Partition C: zugreifen ?

Oder es mal mit der Vista-DVD versuchen, obwohl wenn auf der W7 Partition keine wichtigen Daten waren, wäre es vielleicht auch besser W7 nochmal zu installieren.


Hatte auch mal so ein MBR Problem, in meinem Fall war es Zeitverschwendung alle möglichen Befehle einzugeben, es half nichts, auch ein CMOS Clear hat nix gebracht, die Festplatte war nämlich schon im Eimer. :ugly: :D


Mfg
 
Zuletzt bearbeitet:

Byonik

Kabelverknoter(in)
Ha

Das gleiche Problem habe ich auch nur mit Win 7 und Linux. Die ganzen Befehle gehen nicht und deswegen neu install ist auch uncool.

PS: meine Platte ist nicht im Eimer ;-)

Mfg

Byonik
 
TE
B

Black_Beetle

Software-Overclocker(in)
Juhu ich würde euch gern sagen was ich gemacht habe, ich habe in der letzten Stunde soviel Befehle eingegeben das ich jetzt absolut nicht mehr weiß welcher funktioniert hat. Jedenfalls haut es jetzt definitiv hin!

DAnke euch
 

Byonik

Kabelverknoter(in)
Ok hab es raus bekommen was man eingeben muss.

Code:
bootrec.exe/Fixmbr

bootrec.exe/Rebuildbcd
nach einander eingeben und dann läuft die Sache wider, in gewohnten Bahnen.

Mfg

Byonik
 
TE
B

Black_Beetle

Software-Overclocker(in)
Ja nicht ganz. Er sagt dir bei Rebuildbcd Das Element nicht gefunden wurde. Keine Ahnung.

Problem war ja bei mir das der MBR auf einer anderen Festplatte lief. Irgendwann hatte ich es soweit das ich beim booten die Meldung MBR nicht gefunden - Starten sie den PC neu. Ich habe dann CD rein getan und aufeinmal erkannte er die WIndows 7 Partition. DAnach haben auch die Befehle funktioniert.
 
Zuletzt bearbeitet:
Oben Unten